Announcement

Collapse
No announcement yet.

Sudden bad resolution texture on every meshes

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Sudden bad resolution texture on every meshes

    I have been working for a few months on a video made within Unreal sequencer.
    Everything was working well until today that all my mesh's textures are suddenly displayed in low resolution.

    The problem seems to appear randomly.
    It happened once, the same day, but rebooting the engine fixed the issue. So I thought of a bug.

    Now it seems I am stuck with it.

    I don't think I have changed any settings. Or perhaps by mistake..
    I was simply putting in place different sprites I made, and when I was ready to record the scene, I noticed this issue.

    Engine scalability setting is on Cinematic.
    Material quality is on high.
    So the problem isn't coming from there..

    The funny thing is that when I open a mesh's texture menu, the texture on the mesh in the viewer will appear at the correct resolution.
    Once I close the window, it is back at low resolution.

    Also, if I place an Epic mesh with an Epic texture, I have no problem.
    It only concerns meshes and textures I have imported.

    Could it be that for one sprite, coming from a PNG, I remembered fiddling in order to get its original transparency.. but cannot find the option again.
    Could it be that it affected the whole world?

    I have seen similar questions here and there, but answers were not exactly fitting this case..Did anyone run into a similar issue?

    Thank you!


    #2
    That's texture streaming, it loads a lower resolution version of the texture before it loads in the full texture resolution. You can turn that off in Sequencer when you want to record a video.

    Comment


      #3
      Thank you,
      That is a hint about something I wasn't aware of!

      Though in the Capture Settings area, before rendering, the Texture Streaming box is unchecked, and the problem persists.
      So it does not quite do the trick.
      Is there a way to modify Texture Streaming for the viewer window?

      Comment


        #4
        Ha! So that was definitely it.

        Figure that in the project settings, engine, rendering and then, uncheck the Texture Streaming box.

        Thanks a lot!

        Comment

        Working...
        X