Announcement

Collapse
No announcement yet.

Suddenly have weird aliasing and "vibrating" lines

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Suddenly have weird aliasing and "vibrating" lines

    So this kind of came out of nowhere. at first I thought it was a problem with a specific asset, but getting it everywhere on all installed UE engines (latest UE 4.18 & 19) and even old files.

    Not sure what happened but just looking across a room I can see the lines and edges of some far walls vibrating, and sort of "flashing" like its z-fighting, so it throws off the lighting. It's worse with reflective surfaces - for example, it seems to affect the lines between tiles, rather than the tiles themselves. It doesn't seem to affect the lines directly in front of me, but a few steps ahead (in FPS view for example)

    Setting temporal AA samples to 0 seems to stop the shimmering/z-fighting when I'm just standing there, but the flashing remains/gets worse when moving.

    Any ideas? I know it's not the assets as they are fine in previous videos I made. Some UE config change? I did reinstall my gfx card drivers recently, but I went back to an older version and the problem remained. Not having any problems elsewhere, so not sure what's up.

    #2
    I get this effect with fine hair. Vibrates like heck. Turned off AA but doesn' look as nice.

    Comment


      #3
      Originally posted by syrom View Post
      I get this effect with fine hair. Vibrates like heck. Turned off AA but doesn' look as nice.
      Yeah it's pretty annoying, it seems to affect thin objects/lines the most. Turning off AA doesn't seem to work well for me either. At the moment I've switched to a post process that minimises the damage somewhat, but it's still apparent.

      And all my UE4 icons/gizmos that are located halfway inside meshes are vibrating as heck too. It seems to be some strong version of the moire effect as a lot of the outlines around objects have it when I click around a scene.

      Comment


        #4
        Maybe it gets fixed with 4.20. who knows.

        Comment


          #5
          Had this since 4.15 or something, and it was very subtle most people didn't notice it, and it has got worse with 4.19. Specially on leaves there is a lot of flickering. It's like the image isn't still at all and continuously vibrates for itself and it gets worse as things get farther from camera.
          Artstation
          Join the support channel
          Gumroad Store

          Comment


            #6
            Originally posted by Maximum-Dev View Post
            Had this since 4.15 or something, and it was very subtle most people didn't notice it, and it has got worse with 4.19. Specially on leaves there is a lot of flickering. It's like the image isn't still at all and continuously vibrates for itself and it gets worse as things get farther from camera.
            Yes, exactly! Your last sentence sums it up, it's quite concerning when you have a empty room that should be quiet and atmospheric but instead has vibrating things all over the place.

            I must have missed it in 4.15 etc, but now I notice it all the time! When rendering cut scenes, I now have to find alternative angles or change the materials around. Sometimes it feels like the rendering is unpredictable, like there will be some sort of shadow or flash out of nowhere in the background.

            Comment


              #7
              Originally posted by RodenHirata View Post

              Yes, exactly! Your last sentence sums it up, it's quite concerning when you have a empty room that should be quiet and atmospheric but instead has vibrating things all over the place.

              I must have missed it in 4.15 etc, but now I notice it all the time! When rendering cut scenes, I now have to find alternative angles or change the materials around. Sometimes it feels like the rendering is unpredictable, like there will be some sort of shadow or flash out of nowhere in the background.
              Can you post a video or gif to show how it looks like on your end?
              Artstation
              Join the support channel
              Gumroad Store

              Comment


                #8
                Originally posted by Maximum-Dev View Post

                Can you post a video or gif to show how it looks like on your end?
                Here's a video of a room I noticed it most in (due to reflections), but I've seen it in lots of maps to various degrees. Look at the floor/ceiling (and remember, nothing is supposed to be moving) its fine when close up but far away starts to shimmer. I also included some vibrating lines from another map at the end https://www.youtube.com/watch?v=jrJrNFkTENE

                I actually originally recorded this in 4K uncompressed from sequencer, but the problem wasn't nearly as apparent (which would confirm why some people say you should increase screen percentage in post process to fix this) so I redid it at standard HD. The problem is obviously worse in PIE..

                BTW sort of off-topic: I just downloaded your new upgraded landscape pack. 18gb, it's huge, grass mountains is absolutely stunning now! I really love how you can zoom right in to get all the detail and yet still zoom out for the nice, big view. Oh and what happened to that sweeping sand effect in SandLand? "SandDunes" seems different now, much darker, still alien and cool though

                Comment


                  #9
                  this has the looks of temporal AA jitter, either on the scene itself or on the SSR
                  Follow me on Twitter!
                  Developer of Elium - Prison Escape

                  Comment


                    #10
                    Originally posted by Chosker View Post
                    this has the looks of temporal AA jitter, either on the scene itself or on the SSR
                    I did some more testing.. I even got a new graphics card with 8GB VRAM, same problem. So I started to think it was some new project setting, I found a project from 4.17 that didn't have the problems even when problem scenes were imported into it:

                    The engine project settings under renderer seem to be the main difference when compared to default created UE4 projects:

                    [/Script/Engine.RendererSettings]
                    r.DefaultFeature.AmbientOcclusion=False
                    r.DefaultFeature.AmbientOcclusionStaticFraction=False
                    vr.InstancedStereo=False
                    r.SeparateTranslucency=0
                    r.HZBOcclusion=0
                    r.EyeAdaptionQuality=0
                    r.SSR.MaxRoughness=0
                    r.rhicmdbypass=0
                    r.TiledReflectionEnvironmentMinimumCount=10
                    r.ForwardShading=False
                    r.DefaultFeature.AntiAliasing=3
                    r.CustomDepth=1
                    r.VertexFoggingForOpaque=False

                    These settings make everything too shiny by default and aliasing a little jaggy, but the UE4 vibrating gizmos/lines have stopped. I haven't had time to test all of these in details, so would be interested in any quick feedback if someone is familiar with these (I'm used to changing it within the editor itself).

                    Comment


                      #11
                      Saw the vid. Exactly what I get. Exept mines is 10 time worse since I'm rendering a head model with actual poly hair. The hair is so nervous! I always thought this was a normal ue4 thing since I started using it at around version 4.15.

                      Comment


                        #12
                        Originally posted by syrom View Post
                        Saw the vid. Exactly what I get. Exept mines is 10 time worse since I'm rendering a head model with actual poly hair. The hair is so nervous! I always thought this was a normal ue4 thing since I started using it at around version 4.15.
                        Using an AMD card by any chance?

                        Regarding those project settings I posted earlier, r.DefaultFeature.AntiAliasing=3 is the one that fixes the vibrating, but its just turning off temporal AA I think (not sure what 3 refers to), so back to square one. The other settings do nothing in relation to it, it seems.

                        Comment


                          #13
                          r.DefaultFeature.AntiAliasing=3
                          means it will try to use MSAA but that only works in Forward, so in Deferred it will simply disable antialiasing entirely
                          if you're using Deferred you should be using
                          r.DefaultFeature.AntiAliasing=1 to use FXAA at least, so you get some AA but no vibration
                          after that, you might want to clarify if the vibration happens on screenspace reflections as well
                          Follow me on Twitter!
                          Developer of Elium - Prison Escape

                          Comment


                            #14
                            It' temporal AA. I turn it off and its gone but the material looks terribly shiny and not realistic. I have to leave it on.

                            Comment


                              #15
                              Originally posted by Chosker View Post
                              r.DefaultFeature.AntiAliasing=3
                              means it will try to use MSAA but that only works in Forward, so in Deferred it will simply disable antialiasing entirely
                              if you're using Deferred you should be using
                              r.DefaultFeature.AntiAliasing=1 to use FXAA at least, so you get some AA but no vibration
                              after that, you might want to clarify if the vibration happens on screenspace reflections as well
                              Yes, you're exactly right. With it set to 1 the vibrations disappear and only the reflection vibrations remain - at least that fixes it somewhat. I don't think I noticed this earlier because I was messing around with so many settings while in a reflective room.

                              What is a good use case for forward shading anyway?

                              Comment

                              Working...
                              X