Announcement

Collapse
No announcement yet.

2d scene capture component alpha inversion issue.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I had similar issue. In my case it was silly mistake, as usually. In widget I've set render target as a brush instead of material, so maybe make sure you proper brush in widget?

    Leave a comment:


  • replied
    Yeah, it would be great to have an option for regular alpha as well. I am using a RT texture as a workaround to get widget blueprints to work in VR spectator screen. And being able to get non-inverted alpha would help a lot.

    Leave a comment:


  • replied
    Can someone from Epic please explain why the Rendr Target Alpha is Inverted and no option for a regular alpha?

    Leave a comment:


  • replied
    Ok so I went back to the problem last night and couldn’t figure it out. So here’s what I’ve done so far in trying to fix the inversion issue.

    - inverted the alpha texture for the shield in photoshop and reimported - no effect
    - turned the alpha completely off in photoshop and reimported - no effect
    - Re-enabled the alpha but completely filled the alpha channel and reimported- no effect.
    - plugged in the minus one node and again no effect
    - didn’t plug in the minus one node and again no effect.

    no matter what I seem to do the object renders transparent and the background renders opaque. its like the render target isn’t even reading the proper texture or something.

    In the capture source option of the 2d capture component when i have the source as RGB with alpha inversion I get this problem, when I change it to RGB with alpha zero nothing renders. And when I change it to straight RGB everything renders (the object and background) I really don’t know what I’m doing wrong here. Anyone out there with ideas? Again any help or advice I’m willing to try. Thanks you!

    Leave a comment:


  • replied
    That’s the strange thing. The material preview that has the correct rendering has that one-minus node. I’ve even inverted the textures alpha in photoshop and ran the one minus node and it still doesn’t render the object correctly. It seems like nothing I’m doing is taking with the render target and the inversion issue. I’ll try it again tonight just in case. Thanks!

    Leave a comment:


  • replied
    If the alpha is inverted, just use a one-minus on it to revert it back to what you want.

    Leave a comment:


  • started a topic 2d scene capture component alpha inversion issue.

    2d scene capture component alpha inversion issue.

    Hi everyone I don’t know where else to turn maybe someone here knows the answer. I was following this tutorial last night for getting a 3d item priview system working. https://youtu.be/2ZiNFXSH4ZU functionaly everthing works like it should. The issue I’m having however is when i click on the object and it renders with the alpha channel inverted on my object. So I the outer parts of the model are opaque and the model itself is transparent.

    As as you can see in the first image in the material editor it renders correctly, but in the editor view the shield is transparent. I don’t know how to fix this, in the 2d capture component I see the capture source it has the first option as the alpha being inverted but I don’t know how to fix this issue, I even tried inverting the alpha channel in the texture itself in photoshop and nothing. Is this just some odd bug? Or am I missing something entirely different here? Please any help is appreciated.

    Thank you
Working...
X