Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How do you know its baking with GPU? cause when i look at my swarm agent i think it still using my CPU.

    Comment


      Originally posted by Shadowjonny View Post
      How do you know its baking with GPU? cause when i look at my swarm agent i think it still using my CPU.
      Open Window's task mangager, go to the "performance" tab, select your gpu and on the right select one of the small windows and choose "cuda"

      Comment


        Originally posted by NiukNiuk View Post

        Open Window's task mangager, go to the "performance" tab, select your gpu and on the right select one of the small windows and choose "cuda"
        Got it working, But now i got some weird results:

        Comment


          Hi, how can i change the settings for GPU lightmass in UE 4.21.2 ?
          Thank you



          Comment


            Originally posted by Muchasty View Post

            Why didn't you move to UE4.22 yet ?
            UE4.19 was quite early version of GPULM.
            Those splotches can be reduced sometimes by using higher values in Baselightmass.ini:
            [DevOptions.GPULightmass]
            NumPrimaryGISamples=128
            NumSecondaryGISamples=128

            But I still recommend to move to 4.22 at least and use these values I mentioned above for bake ( in PRODUCTION mode - always ).
            Thank you so much for the reply. I'm gonna give it a try

            Comment


              Nvm got the results to fade by increasing the:

              [DevOptions.GPULightmass]
              NumPrimaryGISamples
              NumSecondaryGISamples

              But i love how fast this bakes compared to cpu its lightning fast. And with 2 RTX 2080 ti, imma soon test it with 4 RTX 2080 ti in the swarm agent

              Comment


                its only currently using just 1 gpu, how can i tell it to use both? there SLI connected. Click image for larger version

Name:	Screenshot-468.png
Views:	1310
Size:	65.7 KB
ID:	1682402
                Attached Files

                Comment


                  Originally posted by Muchasty View Post

                  Why didn't you move to UE4.22 yet ?
                  UE4.19 was quite early version of GPULM.
                  Those splotches can be reduced sometimes by using higher values in Baselightmass.ini:
                  [DevOptions.GPULightmass]
                  NumPrimaryGISamples=128
                  NumSecondaryGISamples=128

                  But I still recommend to move to 4.22 at least and use these values I mentioned above for bake ( in PRODUCTION mode - always ).
                  I installed 4.22 and I get this error
                  Click image for larger version

Name:	error.jpg
Views:	1294
Size:	59.5 KB
ID:	1682420

                  Comment


                    Originally posted by letsoc79 View Post

                    I installed 4.22 and I get this error
                    Click image for larger version

Name:	error.jpg
Views:	1294
Size:	59.5 KB
ID:	1682420
                    Did you install the correct version of GPULightmass? There's a different one for each Unreal version
                    Freelancer Game Dev Generalist and Unreal Consultant | Portfolio
                    Unreal products: Dynamic Picture Frames, Neo Kinect

                    Comment


                      Originally posted by RVillani View Post

                      Did you install the correct version of GPULightmass? There's a different one for each Unreal version
                      Yes, I installed Unified Settings for 4.22...
                      I made a test with 4.20 version and its better, but still have some dots in shadowy areas Click image for larger version

Name:	HighresScreenshot00000.jpg
Views:	1245
Size:	85.3 KB
ID:	1682900

                      Comment


                        Do Distance field Shadow work with gpu lightmass?

                        Comment


                          Originally posted by pax invictus View Post

                          If you're not building Unreal Engine from source - you don't need that folder. Even if you are, unless you want to build from source using my GPU Lightmass fork - ignore that folder. If you don't know what building from source is or what fork I'm referring to - you don't need that folder.

                          Everything you need is in the zip file.
                          Hi pax, I want to build Unreal engine from source, I've cloned your https://github.com/irobot/UnrealEngi...4.23.1-release branch and built the engine, however after trying to build UnrealLightmass in VS, the build had failed with
                          Code:
                          LNK1181: Cannot Open input file 'GPULightmassKernel.lib'
                          Now I've downloaded the folder GPULightmassKernel.lib from your dropbox but don't know what to do with it, could you tell me where do I unzip it to.

                          And I have read one of your comment saying
                          Originally posted by pax invictus View Post

                          I've uploaded GPULightmassKernel.lib in the same dropbox share. You would obviously need to add the path to wherever you save it to the build settings for UnrealLightmass in VS.
                          Could you please elaborate on how do I "add the path" to the "build setting for UnrealLightmass"? Is it adding a line after the
                          Code:
                          static const FEngineDependencyPaths RequiredDependencyPaths64 = {
                          ...
                          TEXT("Binaries/Win64/GPULightmassKernel.lib")
                          };
                          something like this in Lightmass.cpp? (I've tried it, putting the GPULightmassKernel.lib in Win64 folder and add the line above, the build still failed.) Or do I have to add something to another specific file? Thanks.

                          Comment


                            Originally posted by pax invictus View Post
                            I managed to port GPU Lightmass to 4.23.0-preview-6. Here's the download for the binary engine integration:
                            https://www.dropbox.com/sh/fjr63yeut...npYezFena?dl=0

                            And here's my UE4 fork with GPU Lightmass cherry-picked from Yujiang's code on top of 4.23:
                            https://github.com/irobot/UnrealEngi...23.0-preview-6

                            Hope you guys find it helpful!
                            Can I use this for 4.23.1? 4.23.0 is no longer available for download
                            Last edited by leoletsrock; 11-06-2019, 11:33 AM.

                            Comment


                              Originally posted by leoletsrock View Post

                              Can I use this for 4.23.1? 4.23.0 is no longer available for download
                              It should work. Minor version releases shouldn't break anything.

                              Comment


                                I tried to use the LightmassConfiguration .bat file but it can't find the official fgpu lightmass source to download. is it down?
                                behance.net/fael097

                                Comment

                                Working...
                                X