Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by dustintinkler View Post
    I have been getting a strange bug where certain faces usually facing in one direction in both positive and negative render completely back. all of a sudden it started happening on meshes I haven't touched or changed anything on. I have tried what seems like everything, I have re uv'd, changed lightmap res, and countless other things. in one section i have had luck with just simply exporting and re importing while changing nothing and it has fixed the issue. In other areas that fix dosent seem to work. Ill post some images in lit, unlit, and lighitng only.
    Its the horizontal beam above the ceiling.

    Thanks in advanced,

    Click image for larger version  Name:	HighresScreenshot00053.jpg Views:	1 Size:	120.7 KB ID:	1618933Click image for larger version  Name:	HighresScreenshot00054.jpg Views:	1 Size:	113.4 KB ID:	1618934
    Still having this error, here are some more images. i tried migrating the level to a fresh project and it fixed some but introduced others. I also tried using cpu lightmass and im getting similar unpredictable errors.
    I am at a loss, I dont understand why all of a sudden these meshes started acting like this and I just cant figure out a fix or why its happening.

    Click image for larger version  Name:	HighresScreenshot00055.jpg Views:	1 Size:	197.5 KB ID:	1622740Click image for larger version  Name:	HighresScreenshot00056.jpg Views:	1 Size:	221.0 KB ID:	1622741Click image for larger version  Name:	HighresScreenshot00054.jpg Views:	1 Size:	139.1 KB ID:	1622742Click image for larger version  Name:	HighresScreenshot00053.jpg Views:	1 Size:	171.8 KB ID:	1622743
    Dustin Tinkler

    https://www.artstation.com/dustomatic

    Comment


      Is there a way to use more than 1 local gpu? Can I run an example using four gtx1070 at the same time?

      Comment


        Originally posted by timob View Post
        Is there a way to use more than 1 local gpu? Can I run an example using four gtx1070 at the same time?
        Multiple GPU on one machine is not supported. You can setup four different machines and use Swarm. That works.

        You can use lower spec power computers and pop the 1070s in there.

        Comment


          [QUOTE="dustintinkler;n1622739"]

          Still having this error, here are some more images. i tried migrating the level to a fresh project and it fixed some but introduced others. I also tried using cpu lightmass and im getting similar unpredictable errors.
          I am at a loss, I dont understand why all of a sudden these meshes started acting like this and I just cant figure out a fix or why its happening.


          I recommend you reimport the mesh and see if it fixes it. Depending on which UE4 (4.20 I think) version, there is a nasty bug where you have a import the new mesh with a different name or delete the old Uasset together before it refreshes correctly.

          There are other oddities with static mesh imports sometimes...

          Comment


            Originally posted by dustintinkler View Post

            Still having this error, here are some more images. i tried migrating the level to a fresh project and it fixed some but introduced others. I also tried using cpu lightmass and im getting similar unpredictable errors.
            I am at a loss, I dont understand why all of a sudden these meshes started acting like this and I just cant figure out a fix or why its happening.

            Click image for larger version Name:	HighresScreenshot00055.jpg Views:	1 Size:	197.5 KB ID:	1622740Click image for larger version Name:	HighresScreenshot00056.jpg Views:	1 Size:	221.0 KB ID:	1622741Click image for larger version Name:	HighresScreenshot00054.jpg Views:	1 Size:	139.1 KB ID:	1622742Click image for larger version Name:	HighresScreenshot00053.jpg Views:	1 Size:	171.8 KB ID:	1622743
            are you using double face materials? this causes problems.

            Comment


              Hi Everyone,

              my first comment here, just love this GPU lightmass project.

              I'm busy with my first project and I'm very impressed with quality. I am however now starting to get this error on lightmass calculation below, can anyone please help me decode what the problem is?

              The failure happens just before the GPU lightmass calcs start, so before the progress bar pops up. CPU, RAM and GPU memory seems fine (I have two GPUs, 1070ti on two monitors and 1080ti for rendering) and I have cleared the cache

              Much appreciated.

              <None> === Lightmass crashed: ===
              Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:c:\ue4-gpulightmassintegration\engine\source\runtime\core\public\Containers/Array.h] [Line: 611]
              Array index out of bounds: 9745770 from an array of size 9745770


              0x00007ffc09918e6c KERNELBASE.dll!UnknownFunction []
              0x00007ffb31aded47 UnrealLightmass-Core.dll!UnknownFunction []
              0x00007ffb31ae16d7 UnrealLightmass-Core.dll!UnknownFunction []
              0x00007ffb3197234a UnrealLightmass-Core.dll!UnknownFunction []
              0x00007ffb318fd699 UnrealLightmass-Core.dll!UnknownFunction []
              0x00007ffb318fdde9 UnrealLightmass-Core.dll!UnknownFunction []
              0x00007ff76b026528 UnrealLightmass.exe!UnknownFunction []
              0x00007ff76afa8b70 UnrealLightmass.exe!UnknownFunction []
              0x00007ff76afa905a UnrealLightmass.exe!UnknownFunction []
              0x00007ff76afa905a UnrealLightmass.exe!UnknownFunction []
              0x00007ff76af6b39b UnrealLightmass.exe!UnknownFunction []
              0x00007ff76af9374a UnrealLightmass.exe!UnknownFunction []
              0x00007ff76afb6dd9 UnrealLightmass.exe!UnknownFunction []
              0x00007ff76af6bb64 UnrealLightmass.exe!UnknownFunction []
              0x00007ff76af8f36d UnrealLightmass.exe!UnknownFunction []
              0x00007ff76afae4da UnrealLightmass.exe!UnknownFunction []
              0x00007ff76b021bb8 UnrealLightmass.exe!UnknownFunction []
              0x00007ffc0a1313d2 KERNEL32.DLL!UnknownFunction []
              0x00007ffc0c6454f4 ntdll.dll!UnknownFunction []

              Comment


                I should start by saying a big thank you to Luoshuang for the amazing work on this project. I'm using a 2080ti and it reduces my build times to about a fifth of that on CPU, I couldn't believe it first time.

                However, my main stumbling block is that I'm using a single skylight as the only pre-rendered light source in my game. This light is set to Stationary which meant, when I was using CPU-lightmass, this light's intensity could be reduced over time via a blueprint and its baked lightmaps in the world would be reduced along with it. This was how my day/night cycle was working (there was only ever one general lighting condition during the day).

                However, with GPU Lightmass, this light (I'm assuming) gets converted to a static light (as stated in the description) and so the lightmaps stay at a fixed intensity, even when the light is turned down via blueprint. In other words the whole map looks illuminated at night (even when all lights are off).

                I know, for now, this is a hard limit of the GPU Lightmass method but is there any news on current / future development to remedy this?

                I would be eternally grateful for a solution to this problem. Thanks!

                Comment


                  Why the SWARM does not work anymore?
                  I have connection. All hosts are seeing each other and the Coordinator.
                  But the task is not distributed to the networked hosts even if AvoidLocalExecution is TRUE ( then the main host still baking the Lightmaps even if it should not ).

                  Anybody knows what's happen ?

                  Fixed: ESET Firewall Problem. SWARM works.
                  Last edited by Muchasty; 05-23-2019, 02:33 PM.
                  https://www.artstation.com/tomaszmuszynski

                  Comment


                    @Luoshuang
                    Hi,
                    I use GPU calculations to light scenarios levels.
                    I have found a problem when calculating.
                    lets say "night" level after successful build lightmap calculation, other level "day" got mostly lights and some objects already calculated turn back to "need to be rebuild".
                    I migrated main level and his light scenarios to clean project, did try clean new light levels and problem persist.
                    I don't have any new idea how to solve it, can it be that it is a bug?
                    I would appreciate a lot your help. I'm stack with my project.
                    Thanks


                    Attached Files

                    Comment


                      Hi guys,

                      i just wanted to share some GPULightmass shots!
                      It took 50 minutes with 12 x RTX 2080ti in our ARCWARE Studio.
                      Sorry for the Compression quality of the images, it was impossible to upload Quality Shots due to 550kb upload limit.

                      Comment


                        Originally posted by Bimbachi View Post
                        @Luoshuang
                        Hi,
                        I use GPU calculations to light scenarios levels.
                        I have found a problem when calculating.
                        lets say "night" level after successful build lightmap calculation, other level "day" got mostly lights and some objects already calculated turn back to "need to be rebuild".
                        I migrated main level and his light scenarios to clean project, did try clean new light levels and problem persist.
                        I don't have any new idea how to solve it, can it be that it is a bug?
                        I would appreciate a lot your help. I'm stack with my project.
                        Thanks

                        i use multiple light scenarios with GPU lightmass and it has no issies renedering them. PM me, I'll try to help you, but i don't think this is related to GPU.
                        Technology Officer
                        Magma3D

                        Comment


                          Originally posted by PsiCondition View Post
                          Hi guys,

                          i just wanted to share some GPULightmass shots!
                          It took 50 minutes with 12 x RTX 2080ti in our ARCWARE Studio.
                          Sorry for the Compression quality of the images, it was impossible to upload Quality Shots due to 550kb upload limit.
                          Looks gorgeous! But 12 GPUs? I thought it was only able to use 1 GPU at a time...?

                          Comment


                            Originally posted by DsyD View Post

                            Looks gorgeous! But 12 GPUs? I thought it was only able to use 1 GPU at a time...?
                            I suppose they are using 12 separate PC's with one card each

                            Comment


                              Originally posted by zoostation View Post
                              Hi Everyone,

                              my first comment here, just love this GPU lightmass project.

                              I'm busy with my first project and I'm very impressed with quality. I am however now starting to get this error on lightmass calculation below, can anyone please help me decode what the problem is?

                              The failure happens just before the GPU lightmass calcs start, so before the progress bar pops up. CPU, RAM and GPU memory seems fine (I have two GPUs, 1070ti on two monitors and 1080ti for rendering) and I have cleared the cache

                              Much appreciated.

                              <None> === Lightmass crashed: ===
                              Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:c:\ue4-gpulightmassintegration\engine\source\runtime\core\public\Containers/Array.h] [Line: 611]
                              Array index out of bounds: 9745770 from an array of size 9745770


                              0x00007ffc09918e6c KERNELBASE.dll!UnknownFunction []
                              0x00007ffb31aded47 UnrealLightmass-Core.dll!UnknownFunction []
                              0x00007ffb31ae16d7 UnrealLightmass-Core.dll!UnknownFunction []
                              0x00007ffb3197234a UnrealLightmass-Core.dll!UnknownFunction []
                              0x00007ffb318fd699 UnrealLightmass-Core.dll!UnknownFunction []
                              0x00007ffb318fdde9 UnrealLightmass-Core.dll!UnknownFunction []
                              0x00007ff76b026528 UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76afa8b70 UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76afa905a UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76afa905a UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76af6b39b UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76af9374a UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76afb6dd9 UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76af6bb64 UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76af8f36d UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76afae4da UnrealLightmass.exe!UnknownFunction []
                              0x00007ff76b021bb8 UnrealLightmass.exe!UnknownFunction []
                              0x00007ffc0a1313d2 KERNEL32.DLL!UnknownFunction []
                              0x00007ffc0c6454f4 ntdll.dll!UnknownFunction []
                              Anybody? Nobody?

                              Comment


                                Originally posted by zoostation View Post

                                Anybody? Nobody?
                                Seems to me I had similar problems when started using GPU.
                                For memory problem I increased swapfile

                                Comment

                                Working...
                                X