Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Hey! I have been having a strange issue with bounce light recently, maybe someone here knows how to solve it.

    I am using an emissive hdr sky for the Skylight to capture, I also have a physical lights setup, so the intensity values of the emissive sky material as well as the directional sun light are really high. I haven't had any issues with this exact setup for months though, everything was baking fine, but now it seems like the light is not bouncing at all. I don't think I have changed anything other than maybe re-downloading the gpu lightmass. Has anyone had a similar issue and know what could be causing this? I feel like I have tried everything without any luck

    I'm on 4.20.

    Edit: I didn't think to try this earlier, but I grabbed an older version of the 4.20 gpu lightmass and everything works as expected now :O So what has changed in the most recent version that could be causing the issue I mentioned above?
    Attached Files
    Last edited by sbz_edvinas; 04-30-2019, 08:12 AM.

    Comment


      Originally posted by aequoy View Post


      Can you please verify the lightmap resolution of your geometry ?
      They are all set so to get the most out of it, haven't had this on while i was baking on CPU.
      Regarding to those fireflies, what worked for me to get rid of where the Sunlight directly hits was to set the FireflyClampingThreshold to 10.
      Eventhough i ve got weird splotches around the whole scene. The scene also went a lot darker

      Comment


        Originally posted by MarcoF View Post

        They are all set so to get the most out of it, haven't had this on while i was baking on CPU.
        Regarding to those fireflies, what worked for me to get rid of where the Sunlight directly hits was to set the FireflyClampingThreshold to 10.
        Eventhough i ve got weird splotches around the whole scene. The scene also went a lot darker
        Have you tried to turn OFF "Use Ambient Occlusion" in World Settings?

        Comment


          Does "Generate Ambient Occlusion Material Mask" in the World Settings do anything while using GPU Lightmass? Because I'm intending to use the Precomputed AO Mask node in my material but it doesn't work.

          Edit: Just read it's not supported. Any chance to get it in the future?
          Last edited by Brygelsmack; 05-03-2019, 07:11 AM.

          Comment


            Script updated to detect 4.22.1 CPU. It is really not important thou and a minor update, as the GPU kernel remains the same.
            Technology Officer
            Magma3D

            Comment


              Originally posted by Situx View Post
              Script updated to detect 4.22.1 CPU. It is really not important thou and a minor update, as the GPU kernel remains the same.
              Hello, looks like it doesn't recognise my UE4 version
              "Unreal Engine Version 4.22 not installed or registry not set"
              How con I resolve that? Thanks

              Comment


                Is that possible to get rid of this area shadow of skylight? I would like that my skylight distributes better the light...

                Comment


                  Originally posted by Bakikibakibabaki View Post

                  Have you tried to turn OFF "Use Ambient Occlusion" in World Settings?
                  Yep...is currently set to OFF, its not taking it into account.
                  BTW: Does any of these settings in the World Settings matter with this GPU Approach?

                  Comment


                    Would anyone know why this gets stuck for me on a RTX 2070 Max-Q machine, but works fine on a GTX 1060?

                    Here's some detail: I run the same project and lightmass setup, but when I run the light builder, everything seems to work fine up until it finishes the radiosity cache. Then, it just sits there. No modal errors, nothing in the output log, it just sits at "Overall texel progress 0.00%".

                    From a task manager standpoint, when the build is first started, it crunches away as expected - the CPU utilization pegs high, and cuda cores peg 100%. Then, as soon as the radiosity cache is done (10 passes) the CPU settles down to 20%, and then 0% on cuda. I've left it like this for hours. The "Building Lighting: 0%" never changes, nor does the "Current batch 0.76% Block 1/132" and "Overall texel progress 0.00%" in the GPU Lightmass progress window.

                    Things I've tried:
                    - TDRLevel is set to 300
                    - Cleared the SwarmAgent cache
                    - Rolled back to try two different sets of drivers on the RTX 2070
                    - Last ditch effort: just mass deleting elements from the project and re-testing until light building works; which it never did

                    Using 4.20.2 of Loushuang's with a project that is set up in 4.20.3.

                    The system it works on with the GTX 1060 has the same amount of system RAM (32GB). The 1060 has 6GB of GPU memory, while the 2070 has 8GB. I'm convinced it's a 2070 thing, and possibly something to do with the Max-Q architecture. ¯\_(ツ)_/¯

                    Comment


                      Originally posted by Sanjuan View Post
                      Is that possible to get rid of this area shadow of skylight? I would like that my skylight distributes better the light...
                      You should change "lower hemisphere color".. Make it more brighter. If you use hdri for skylight, you can disable it.

                      Comment


                        Originally posted by MarcoF View Post

                        Yep...is currently set to OFF, its not taking it into account.
                        BTW: Does any of these settings in the World Settings matter with this GPU Approach?
                        Yes the Indirect lighting Bounces and the Num Sky Lighting bounces

                        Comment


                          Hi,
                          Any info to fix this error?

                          16:59:46: GPULightmass Kernel: Importing mesh: 94746496 vertices, 104756177 triangles
                          17:00:30: GPULightmass Kernel: Embree SBVH Construction finished, 43179MS
                          17:01:10: GPULightmass Kernel: Convert to CudaBVH finished, 40695MS
                          17:01:14: GPULightmass Kernel: Line 86: cudaCheckError: out of memory

                          I'm using a 2080Ti, i7-9700k and 32GB of ram

                          Thank you

                          Comment


                            Originally posted by Luoshuang View Post
                            I've uploaded a new version of unified settings to fix the quality problem.

                            Also, for source integration:

                            [ATTACH]n1529967[/ATTACH]

                            Two files in the zip: Engine\Source\Programs\UnrealLightmass\Public\SceneExport.h and Engine\Source\Editor\UnrealEd\Private\Lightmass\Lightmass.cpp.
                            You need to either replace the two files, or use a diff tool to apply the patch to your source build. The change is about copy dependencies and reading ini files.

                            Hi all. In the same way as many other UE4 users, I have found this tool a bit late. Unfortunately I am following the steps that Luoshuang poses, but I can not install the GPULightmass engine from the source. The version I have of UE4 is 4.22.1, it jumps an error that says: "GPULightmasKernel.dll is missing. Some of you can tell me the steps to perform the correct installation. I am not a video game programmer, I am an architect in love with the tool that UE4 gives me.

                            Comment


                              Did anybody have the opportunity to test 2080 ti or maybe 1080ti vs 2080ti in GPU Lightmass?

                              Comment


                                Originally posted by rakikavun View Post

                                You should change "lower hemisphere color".. Make it more brighter. If you use hdri for skylight, you can disable it.
                                Worked! Thx!

                                Comment

                                Working...
                                X