Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Hi guy's,
    I'm posting here because I have a problem with my skylight using GPULightmass in 4.21 Unified Settings on a GTX 980 4Gb.
    As you can see on the screen, my shadows are really dark and we don't see any skylight in it.

    https://imgur.com/qxcJlxW

    I tried different things like :

    - Increased intensity
    - Moved to static --> stationary and go back to static
    - Increased Sky bounced
    - Unchecked "Lower Hemishpere Is Solid Color"
    - Unsing : Preview, Medium & high quality

    I don't have any new idea for fixing this ... if anyone can help me it would be great.

    Thanks !

    Comment


      hi
      thanks for your great GPUlightMass
      I have a question.
      how can I reduce noises on objects?
      I use UE4.21.2 and I couldn't find any setting to change quality.

      Last edited by Pooya.king; 03-03-2019, 04:01 AM.

      Comment


        Originally posted by Defcon44 View Post
        Hi guy's,
        I'm posting here because I have a problem with my skylight using GPULightmass in 4.21 Unified Settings on a GTX 980 4Gb.
        As you can see on the screen, my shadows are really dark and we don't see any skylight in it.

        https://imgur.com/qxcJlxW

        I tried different things like :

        - Increased intensity
        - Moved to static --> stationary and go back to static
        - Increased Sky bounced
        - Unchecked "Lower Hemishpere Is Solid Color"
        - Unsing : Preview, Medium & high quality

        I don't have any new idea for fixing this ... if anyone can help me it would be great.

        Thanks !
        Exactly the same problem. Skylight doesn't affects the scene at all, all black for some reason... weird thing is that i have the same gpu... gtx 980 ti

        love the gpu lightmass all the same, just reporting

        Comment


          Originally posted by Defcon44 View Post
          As you can see on the screen, my shadows are really dark and we don't see any skylight in it.
          Originally posted by Juanmilanese View Post
          Exactly the same problem.
          I mentioned it in one of my posts. Same problem. Solved by setting my skybox mesh to not generate shadows. Sometimes, even with Unlit materials, I have to disable generate shadows (set a lit material, untick the shadows setting and set your Unlit material back).
          Freelancer Game Dev Generalist and Unreal Consultant | Portfolio
          Unreal products: Dynamic Picture Frames, Neo Kinect

          Comment


            Originally posted by RVillani View Post



            I mentioned it in one of my posts. Same problem. Solved by setting my skybox mesh to not generate shadows. Sometimes, even with Unlit materials, I have to disable generate shadows (set a lit material, untick the shadows setting and set your Unlit material back).
            Working now, thanks. Your workaround seems to be the thing that fixed it.

            Comment


              Thanks a lot Luoshuang for your plugin!
              It just saved our lives on an impossible delivery. ( https://youtu.be/3xO3UX0BC58 )
              I can't even remember what life was like when we used 3dsmax and Vray
              Cheers

              Any 3D application available anywhere, anytime, on any device.

              Cloud deployment web platform for your UE4 applications
              www.furioos.com

              Comment


                Hi all, im having some problems with te rectangular light and emissive material why the secondary bounce are not calculated there is a way to solve this defect?

                Comment


                  Originally posted by Pooya.king View Post
                  hi
                  thanks for your great GPUlightMass
                  I have a question.
                  how can I reduce noises on objects?
                  I use UE4.21.2 and I couldn't find any setting to change quality.
                  Have you found a solution t this??

                  Comment


                    Originally posted by Khimari View Post

                    Have you found a solution t this??
                    I've used the script installer to get better results (LightmassConfiguration.bat). With Ultra High Quality the noise is less noticiable, with Extreme and Insane quality the noise is gone.

                    Try doing testings with a basic level and see if some of these settings are ok for you.
                    Attached Files
                    Last edited by Jhosep_Chevarria; 03-07-2019, 01:13 PM.
                    The Virtual Photographer, welcome to my world!
                    AQP City, Open World Game
                    My Artstation: Click me!
                    *AQP City Fan page
                    *AQP City on Indie DB

                    Comment


                      Originally posted by Jhosep_Chevarria View Post

                      I've used the script installer to get better results (LightmassConfiguration.bat). With Ultra High Quality the noise is less noticiable, with Extreme and Insane quality the noise is gone.

                      Try doing testings with a basic level and see if some of these settings are ok for you.
                      Also, try disabling (if you haven't already) texture compression in general settings of your scene.
                      Technology Officer
                      Magma3D

                      Comment


                        Has anyone encountered this issue? Skylight set to static results in no lighting, but set to Stationary does:

                        Static:
                        Click image for larger version

Name:	static.jpg
Views:	1
Size:	44.7 KB
ID:	1592619


                        Stationary:
                        Click image for larger version

Name:	stationary.jpg
Views:	1
Size:	89.8 KB
ID:	1592620


                        The only difference between the above two is the Static vs. Stationary setting.

                        The original post says:

                        • However stationary skylight is not supported so if you have one in your scene it will still be baked since it is treated as a static one
                        But this doesn't seem to be the case...

                        This is with Ultra Dynamic Sky and 4.20 unified settings, if that matters. It has a sky sphere but it's definitely set to not cast shadows.

                        Comment


                          Originally posted by Jhosep_Chevarria View Post

                          I've used the script installer to get better results (LightmassConfiguration.bat). With Ultra High Quality the noise is less noticiable, with Extreme and Insane quality the noise is gone.

                          Try doing testings with a basic level and see if some of these settings are ok for you.
                          Thank you a lot, now the problem is solved!
                          Attached Files
                          Last edited by Khimari; 03-08-2019, 11:57 AM.

                          Comment


                            Im having an issue in 4.21.2 it is still only using CPU to build lightmass. Ive used the installer and checked the settings to make sure CPU is disabled in the baselightmass.ini but i still see 100% usage on CPU during the entire build. Is there something im missing?
                            Architectural Designer

                            Comment


                              I had to switch to CPULightmass, which I haven't used for quite some time, and it's so horrible Even q3map2 map/lighting compiler for Quake 3 is much more stable and predictable, and it's an ancient small app! I have black polygons where there shouldn't be any, even with Production quality settings. Lightmap UV map is perfect, there is nothing that should stop CPULightmass from building lighting properly on those polygons :/ Several editor restarts and tweaking "build settings" on static mesh seem to fix the issue ... until next restart :/

                              Luoshuang I keep my fingers crossed that you are not burnt out after 4.22 release and that we'll see updated GPULightmass shortly after

                              Comment


                                Originally posted by Jhosep_Chevarria View Post

                                I've used the script installer to get better results (LightmassConfiguration.bat). With Ultra High Quality the noise is less noticiable, with Extreme and Insane quality the noise is gone.

                                Try doing testings with a basic level and see if some of these settings are ok for you.
                                Where can I find these options (Ultra High Quality,Extreme,Insane quality)?

                                Comment

                                Working...
                                X