Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    you should implement nvidia optix denoiser

    Comment


      I'm struggling with getting it work - seems directional light and skylight are 'ignored', as in it results in black areas. Exceptions are point/spot lights - these work.UE4 4.21.2, gpu lightmass is 4.21.0. Could it be version incompatibility?

      I've tried different levels, in same project, replacing light sources with default ones, different intensity values (10 lux up to few thousands, for directional light). Stationary and Static.

      All I did for installation, is extracting gpu lightmass files and replacing in ue4 folder.

      EDIT: By accident, but it seems that sky sphere is blocking lightning from skylight/directional, which wasn't the case few months ago/before installing gpu lightmass. Going to investigate it later
      Last edited by tonpix; 02-14-2019, 06:14 AM.

      Comment


        @tonoix I had kind of simillar problem, and had to change a sphere, correct her UV’s . It helped.

        Comment


          Originally posted by Bimbachi View Post
          @tonoix I had kind of simillar problem, and had to change a sphere, correct her UV’s . It helped.
          Unchecking on "Cast shadows" on sky sphere properties fixed it, I'm not sure why it was different, last time I've used UE4 was 4.18 (and it wasn't blocking sky/sun lightning then), I can guess that few versions update changed something

          Comment


            I am having a problem when I build lights. It is giving me an error "Invalid device symbol". I am attaching a screenshot of my problem. Please help.
            Attached Files

            Comment


              I am having a problem when I build lights. It is giving me an error "Invalid device symbol". I am attaching a screenshot of my problem. Please help.
              Attached Files

              Comment


                I have did another small test with HDR backgorund for GI. I will send all test later, but it seems to me it is not working right. Practically, there are 3 basic ways how to create IBL. You can load HDR by skylight or you can create mesh sphere to light te scene by loading HDR or EXR (they have different mapping)
                But in any case, I didn't get same result as in 3DS max + Vray. There was no different between loading HDR in to skilight and using EXR on mesh. The HDR on mesh was absolutely blured.
                The biggest problem was with precision of shadows. It seems to me, that HDR that is used for calculation is in much smaller resolution then you are loading. So the results are just tints by HDR but there is no visible dynamic range in the light.
                I have to do another test by CPU also. Every time I am using the same files as I render in 3ds max to compare results.

                How GPU render does manage the HDR(exr) files Luoshuang? Is it supported and how we should use it to get proper results?

                Comment


                  why,black,here

                  Comment


                    Originally posted by guiwuzhe333 View Post
                    why,black,here
                    Double check UVWs and material. Seems to be there.

                    Comment


                      Does anyone else get the "out of memory" error? RAM memory, thats the problem not video memory. Does anyone know how to fix it?

                      I have 32GB of RAM and I always get to 98% or more and then it crashes, don't know what to do.

                      Any suggestions? Thanks.

                      Comment


                        Hello!! This is normal?¿ GPU Lightmass its working fine in RTX? My GPU is relaxed...


                        Attached Files
                        Last edited by 3ismar; 02-19-2019, 05:04 PM.

                        Comment


                          3ismar Hi, i have the same issue with Gtx 1070. When my lightmass are building, it just uses 7 % of all powerful. I don't know why. If you will solve this problem, let me know plz.

                          Comment


                            Originally posted by ahmadsy1 View Post
                            3ismar Hi, i have the same issue with Gtx 1070. When my lightmass are building, it just uses 7 % of all powerful. I don't know why. If you will solve this problem, let me know plz.
                            I have a 1070 as well and GPU usage stays at 100% baking lightmaps. v4.21.2

                            Comment


                              Originally posted by ahmadsy1 View Post
                              3ismar Hi, i have the same issue with Gtx 1070. When my lightmass are building, it just uses 7 % of all powerful. I don't know why. If you will solve this problem, let me know plz.
                              With the most recent 2 drivers NVIDIA changed the scheduling priority of CUDA:
                              1. While the device's compute CUDA cores are fully used they won't show up in task manager
                              2. Whenever there's a 3D application running in foreground it will take priority
                              This results in generally slower CUDA execution

                              Comment


                                Originally posted by Xivader View Post

                                I have a 1070 as well and GPU usage stays at 100% baking lightmaps. v4.21.2
                                Seems that in 19.2 speed is lower, besides i use source code engine from GitHub by Nvidia.

                                Comment

                                Working...
                                X