Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by JoeWintergreen View Post
    Anyone encountered this? Happens on one of my larger maps.
    Time to get a GPU with more VRAM ! I also got this error on big archviz projects (multiple houses and buildings). Happens when swarm unloads everything in the memory of your GPU : if you dont have enough, the baker crashes with this error.
    Antoine Guillo, FR
    Virtual Reality Designer
    https://groupe-legendre.com/

    Comment


      Originally posted by DIO_666 View Post
      I just installed and tried GPU Lightmass for the first time with 4.21.
      Speed and quality are great, but my result is much darker than with the CPU baker. It is as if less GI bounces are computed. I tried increasing the indirect lighting contribution of the lights without any difference in the result. Bounces in the lightmass settings are set to 100.
      Also I get a lot of errors in the lightmaps when setting any rectangle light to stationary. Only when setting it to static the bake works fine.
      Try to increase the FireflyClampingThreshold in the BaseLightmass.ini in the engine\config folder from 10 to 50 or 100. Be aware that since you increase the threshold you might need to increase samples as well to get a clean result.
      ArtStation - Portfolio

      Comment


        Originally posted by The_Distiller View Post

        Try to increase the FireflyClampingThreshold in the BaseLightmass.ini in the engine\config folder from 10 to 50 or 100. Be aware that since you increase the threshold you might need to increase samples as well to get a clean result.
        Thanks! I´ll check it out! I already increased the samples in the BaseLightmass.ini and the results were great. I got a better quality in 10 minutes on my 1080ti than in almost two hours on my CPU.
        But I didn´t touch the fireflyClampingThreshold until now, because I didn´t know what it was for.

        Comment


          Originally posted by DIO_666 View Post
          I just installed and tried GPU Lightmass for the first time with 4.21.
          Speed and quality are great, but my result is much darker than with the CPU baker. It is as if less GI bounces are computed. I tried increasing the indirect lighting contribution of the lights without any difference in the result. Bounces in the lightmass settings are set to 100.
          Also I get a lot of errors in the lightmaps when setting any rectangle light to stationary. Only when setting it to static the bake works fine.
          Thats funny, for me GPU luightmass is like 10 x brighter than the simple CPU lightmass. I was using 300 lumen lights and i had to put them down to 30 lumen to match my old results.

          Comment


            Originally posted by JoeWintergreen View Post
            Anyone encountered this? Happens on one of my larger maps.
            For me, it helped to change MappingSurfaceCacheDownsampleFactor to 4 or even 8 value in BaseLightmass.ini

            Comment


              Originally posted by Situx View Post

              I don't have access to GitHub from work, unfortunately, but I'll take a look at it tonight.
              Done, updated for 4.21
              Technology Officer
              Magma3D

              Comment


                Luoshuang just thought I'd pop in to say thanks for all your work! GPULightmass is amazin' and I'm using it for everything I don't need HLOD clusters for. Saving me a huge amount of time.
                Impromptu Games|dev blog|twitter|itch.io store|Patreon
                Impromptu Procedural Ladders|Impromptu Procedural Handrails|Impromptu Procedural Stairs
                |Impromptu Fire Propagation|InFlux Example Game|Impromptu Vector Field Painter

                Comment


                  Luoshuang hey ! Awesome work on the 4.21 release, GPULM is a tool we cant work without

                  I just got this error after trying to bake lights on datasmith model, wonder why it happens on this one only ? (also the first time I see a primitiveCount >0 error)

                  Cheers !
                  Antoine
                  Antoine Guillo, FR
                  Virtual Reality Designer
                  https://groupe-legendre.com/

                  Comment


                    Originally posted by LegendreVR View Post
                    Luoshuang hey ! Awesome work on the 4.21 release, GPULM is a tool we cant work without

                    I just got this error after trying to bake lights on datasmith model, wonder why it happens on this one only ? (also the first time I see a primitiveCount >0 error)

                    Cheers !
                    Antoine
                    Same here. I get no error though, it just stops the baking. Works in empty scene.

                    Comment


                      Originally posted by Situx View Post
                      I made a script that will automatically download and install GPULightmass on your binary installation folder, perform a batch of checks to avoid issues (like nvidia driver version and TdrDelay), and allow to change GPU bake quality among fast, medium, high, extreme, without the need to restart Unreal.

                      If it helps someone, just give me a "Like" below.

                      UPDATE 12/11/2018: Now updated to work with 4.21 (Unified Settings). Allows to chage settings on the fly between different BaseLightmap.ini configurations.
                      Thank you so much...

                      Comment


                        Millions thanks to Loushuang and Situx Your life time saver the scripts you made woks perfectly on my RTX gpu My job work flow become easier faster ,I can baked project very fast and I can switch the quality settings without restarting unreal ,..

                        Thanks Again.,

                        Comment


                          I receive an Unspecified Launch Error when GPULightmass on radiosity cache 3/xyz



                          Comment


                            Luoshuang, how does GPU Lightmass determine how much VRAM it needs? It loads all level geometry, materials, and then makes lightmap (image) files, right? It seems to vary build-to-build; my 1080 ti 11GB has been fine but I'm wondering when I'll hit the limit if I make my design larger, go to 4K textures, etc. Any way to check on specific things using VRAM during a command line build simliar to what Octane Render does? Thank you again.
                            Ryzen 9 3950X / 64GB DDR4 / EVGA RTX 2080 Ti / Sketchup Pro / Substance Designer and Source / Unreal Studio / Twinmotion

                            Comment


                              Hello, Luoshuang!
                              I was very inspired by the pictures of your plugin and decided to try it with Unreal Engine 4.20.3
                              But one error constantly disrupts the whole process.

                              I got latest drivers Nvidia on two Geforce 1080 cards
                              I changed Windows TDR to 300
                              Lightmass is fast preview

                              Can you help me with it?

                              Click image for larger version

Name:	Error.jpg
Views:	199
Size:	493.9 KB
ID:	1563151

                              Comment


                                I just start to use this project. I installed it through Situx's script to UE4.21.1. Somehow I got no indirect lighting effect for static lights in my scene. It appears that light building was completed before GPU lightmass process finished.

                                Comment

                                Working...
                                X