Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by motorsep View Post
    Luoshuang

    Well, that source you shared a few posts ago doesn't seem to work with binaries for 4.20.2. UE 4.20.3 builds fine with it, but then if I use .dlls and .exe from binary package for 4.20.2, Lightmass (swarm rather) fails. If I only use GPULightmass DLL from binary package, I get this crash: https://pastebin.com/e5AGHifh

    I probably need 4.20.3 binary package from you in order to make it work with the new source you released a few posts above.
    The idea is to build only UnrealEd (do not build UnrealLightmass) and use all the binaries excluding UE4Editor-UnrealEd.dll

    Comment


      Originally posted by Luoshuang View Post

      The idea is to build only UnrealEd (do not build UnrealLightmass) and use all the binaries excluding UE4Editor-UnrealEd.dll
      I can't not build Lightmass. It builds with UnrealEd by default.

      I tried again.

      I built UE 4.20.3 from source, then I did the code changes according to your source files and copied GPULightmassKernel.dll into where it should be (along with reporter app and .ini changes). Then I re-built UnrealEd, copied the rest of the files from 4.20.2 binary package you provided (except for UE4Editor-UnrealEd.dll), overwrote existing files.

      Now it seems that lighting is being built, but I don't see reporter window pop-up. Scene is extremely simple, so maybe that's why?

      EDIT: Built lighting on a complex scene - same thing - progress bar for GPULIghtmap doesn't show up in the top left corner of the screen as it used to with 4.19.x engine.
      Last edited by motorsep; 09-22-2018, 02:25 AM.

      Comment


        Originally posted by motorsep View Post

        I can't not build Lightmass. It builds with UnrealEd by default.

        I tried again.

        I built UE 4.20.3 from source, then I did the code changes according to your source files and copied GPULightmassKernel.dll into where it should be (along with reporter app and .ini changes). Then I re-built UnrealEd, copied the rest of the files from 4.20.2 binary package you provided (except for UE4Editor-UnrealEd.dll), overwrote existing files.

        Now it seems that lighting is being built, but I don't see reporter window pop-up. Scene is extremely simple, so maybe that's why?

        EDIT: Built lighting on a complex scene - same thing - progress bar for GPULIghtmap doesn't show up in the top left corner of the screen as it used to with 4.19.x engine.
        Did you forget to place ProgressReporter.exe in the proper folder?

        Comment


          Originally posted by Luoshuang View Post

          The idea is to build only UnrealEd (do not build UnrealLightmass) and use all the binaries excluding UE4Editor-UnrealEd.dll
          Just want to say everything works like a charm now on my 1080Ti with a source build. Even rendering with crazy high DevOptions!
          One thing I haven't seen mentioned in the thread is that the "Use emissive for static lighting" checkbox now works. On previous version emissivenes was always taken into account.
          Last edited by Norman3D; 09-22-2018, 05:31 AM.

          Comment


            Originally posted by Norman3D View Post

            Did you forget to place ProgressReporter.exe in the proper folder?
            I sure did, but now I went over the code changes and I put path to the reporter into 32bit dependencies block of code :P Fixed it and rebuilding.. Fingers crossed

            Comment


              Is Working for 4.20.3?

              Comment


                So, finally got it running (at least reporter shows up and building times are definitely faster than on CPU). However, this is what I am getting:



                Not really sure what's going on. It looks like lighting works as expected, when showing level in Lighting only mode. However as soon as textures are back on, as if there is no indirect lighting

                Comment


                  Originally posted by motorsep View Post
                  Not really sure what's going on. It looks like lighting works as expected, when showing level in Lighting only mode. However as soon as textures are back on, as if there is no indirect lighting
                  What are your world settings like? how many light bounces?

                  Have you tried reloading the level? I found sometimes light maps or materials failing with black after baking

                  Finally and may not be related, but seems you are killing specularity on your material, which may change how light bounces of it or reflects on your reflection capture actors, not just the look.
                  Technology Officer
                  Magma3D

                  Comment


                    Originally posted by Situx View Post

                    What are your world settings like? how many light bounces?

                    Have you tried reloading the level? I found sometimes light maps or materials failing with black after baking

                    Finally and may not be related, but seems you are killing specularity on your material, which may change how light bounces of it or reflects on your reflection capture actors, not just the look.
                    I show the entire setup, including materials, world and lights settings in that video.

                    Having fully rough materials is necessary for performance reasons - the project is for mobile VR.

                    Comment


                      Originally posted by motorsep View Post

                      I show the entire setup, including materials, world and lights settings in that video.

                      Having fully rough materials is necessary for performance reasons - the project is for mobile VR.
                      Maybe you can tell me the time of the video where world settings are shown. Also a good look at the base color would be good indicator. My guessing is your textures are extreamly dark for lighting information to properly bounce off. Can you show the same with CPU lightmass?
                      Technology Officer
                      Magma3D

                      Comment


                        Originally posted by Situx View Post

                        Maybe you can tell me the time of the video where world settings are shown. Also a good look at the base color would be good indicator. My guessing is your textures are extreamly dark for lighting information to properly bounce off. Can you show the same with CPU lightmass?
                        What kind of sorcery is this - I could have swore I recorded the world settings

                        Here is what I got:

                        Click image for larger version

Name:	ue4_gpulightmass_worldsettings.PNG
Views:	145
Size:	62.0 KB
ID:	1531041


















































                        To show it in CPU Lightmass, I'd have to convert project into another version of UE4

                        Comment


                          Originally posted by motorsep View Post

                          To show it in CPU Lightmass, I'd have to convert project into another version of UE4
                          I don't think this is related to GPU Lightmass. If you tried everything else, only trying CPU lightmass to make it sure is what's left. You can repair the installation by using "verify" on the epic launcher, that would take you back to CPU. After that, you can use this script to save CPU lightmass files and change between CPU and GPU on-the-fly without much hassle later if you whish to get back to GPU.
                          Technology Officer
                          Magma3D

                          Comment


                            While CPU Lightmass did better than GPU LIghtmass, it wasn't really any better.

                            Not quite sure what's going on. Going to mess with faking indirect lighting.

                            P.S. Strangely enough, it looks better in ES3.1 preview :

                            Last edited by motorsep; 09-22-2018, 06:55 PM.

                            Comment


                              Originally posted by motorsep View Post
                              While CPU Lightmass did better than GPU LIghtmass, it wasn't really any better.

                              Not quite sure what's going on. Going to mess with faking indirect lighting.

                              P.S. Strangely enough, it looks better in ES3.1 preview :

                              imo this problem has nothing to do with GPU Lightmass. If I had to guess, I'd say your textures are way too dark.
                              Double check your textures, here is a guideline of how dark "black" color in PBR textures should look like:
                              https://docs.unity3d.com/uploads/Exp..._Materials.pdf

                              Comment


                                Seems like I got something going:

                                Comment

                                Working...
                                X