Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Situx View Post

    I have the same issue. I tried on a swarm with 4 workstations, they all worked in parallel until the last bit and failed to sync. The single workstation took the same time to render as when it was alone. I was under the impression it was some network/firewall issue also but they all communicate properly.
    I just had a look at the log file and it says: "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"

    UPDATE: After using "Verify" in the Epic Games Launcher (resets to CPU) and immigrating the GPU files again its working now!
    I CAN'T BELIEVE HOW FAST IT IS!! I hope it will still be working after a restart of UE or some other action that might mess it up again...
    Attached Files
    Last edited by SiLiUSD; 08-23-2018, 07:02 AM.

    Comment


      Originally posted by SiLiUSD View Post

      I just had a look in the log file and it says: "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"
      Yeap. Same error. Now I wonder if it's related to this version. I rolled back to CPU and had the same problem. Seems it's not related to GPULightmass. There was a big on 4.20 which they left out the swarm coordinator executable out of the build. I remember I copied the file from 4.19 and thought "hey, it worked" to find out this error, so I went back to 4.19.

      UPDATE: Verifying worked! Thanks, SiLiUSD. Seems like I was still using the old SwarmCoordinator. Updated my script to account for this changes also. Now back to test if Swarm on GPU works.
      Last edited by Situx; 08-23-2018, 10:47 AM.
      Technology Officer
      Magma3D

      Comment


        Just updated drivers for 1080. Helped to get me further along, but I', still getting the timeout error message. Does the TDRDelay setting need to be changed?

        Comment


          Originally posted by Luma3d View Post
          Just updated drivers for 1080. Helped to get me further along, but I', still getting the timeout error message. Does the TDRDelay setting need to be changed?
          That's exactly where it helps. Try using the script and let me know if it works.
          Technology Officer
          Magma3D

          Comment


            I’m buying a nvidia card for this, Would you recommend 1080ti oc or titian Xp? Or should I wait for the RTX series which will release next month? I have concern if RTX is compatible? Appreciate to any advises

            Comment


              Can anyone suggest a display card for this GPU lightmass script?

              I googled stuff like graphics card for GPU rendering but most of them are about vray. And the rest is about PUBG....

              Comment


                I've uploaded 4.20.2 version. Also, support for Sparse Volume Lighting Samples should have been recovered in 4.20.2. Let me know if it doesnt work.

                For video card recommendation, I would suggest waiting for RTX.

                Comment


                  Originally posted by Luoshuang View Post
                  I've uploaded 4.20.2 version. Also, support for Sparse Volume Lighting Samples should have been recovered in 4.20.2. Let me know if it doesnt work.

                  For video card recommendation, I would suggest waiting for RTX.
                  Are the RTX going to perform much better? I get how they advertise the real time raytracing but does that mean they are also good for regular raytracing?

                  Oh and Luoshuang I just added another GPU to my system and it seems to use just one of them. Is there a way of choosing which GPU is used for the calculation (other than just connect the monitors to the other one). Or maybe even use both (without SLI)?
                  Originally posted by Situx View Post

                  Yeap. Same error. Now I wonder if it's related to this version. I rolled back to CPU and had the same problem. Seems it's not related to GPULightmass. There was a big on 4.20 which they left out the swarm coordinator executable out of the build. I remember I copied the file from 4.19 and thought "hey, it worked" to find out this error, so I went back to 4.19.

                  UPDATE: Verifying worked! Thanks, SiLiUSD. Seems like I was still using the old SwarmCoordinator. Updated my script to account for this changes also. Now back to test if Swarm on GPU works.
                  Glad it worked out! It's still working for me

                  Comment


                    Originally posted by SiLiUSD View Post

                    Are the RTX going to perform much better? I get how they advertise the real time raytracing but does that mean they are also good for regular raytracing?
                    Well, RTX series is able to pull of realtime raytracing thanks to 10x faster raytracing than 10xx series
                    RTX support in DX12 should be also helpful here.

                    I wonder, Turing architectures utilizes Tensor cores for denoising the same as Volta cards used to?

                    Comment


                      after changing GPU lightmass settings a couple of times from Medium to High, for example, I get this error at the beginning of the building process.

                      <None> === Lightmass crashed: ===
                      Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:c:\ue4-gpulightmassintegration\engine\source\runtime\core\public\Containers/Array.h] [Line: 611]
                      Array index out of bounds: 8 from an array of size 8


                      0x00007ffbafd6a388 KERNELBASE.dll!UnknownFunction []
                      0x00007ffb09cd44c0 UnrealLightmass-ApplicationCore.dll!UnknownFunction []
                      0x00007ffb04239a5c UnrealLightmass-Core.dll!UnknownFunction []
                      0x00007ffb041cc55d UnrealLightmass-Core.dll!UnknownFunction []
                      0x00007ff65608ef70 UnrealLightmass.exe!UnknownFunction []
                      0x00007ff6560974ef UnrealLightmass.exe!UnknownFunction []
                      0x00007ff6560ed0ff UnrealLightmass.exe!UnknownFunction []
                      0x00007ff65609ea4c UnrealLightmass.exe!UnknownFunction []
                      0x00007ff6560c1c22 UnrealLightmass.exe!UnknownFunction []
                      0x00007ff6560e33c7 UnrealLightmass.exe!UnknownFunction []
                      0x00007ff65617a858 UnrealLightmass.exe!UnknownFunction []
                      0x00007ffbb04d3034 KERNEL32.DLL!UnknownFunction []
                      0x00007ffbb2eb1431 ntdll.dll!UnknownFunction []


                      What's that?
                      Please help

                      Nazzareno Giannelli
                      CTO | Senior 3D Artist
                      myD3SIGN Ltd

                      +39 335 13 12 044
                      Skype: nazza87
                      nazzareno@myd3sign.com
                      www.nazzarenogiannelli.com

                      Comment


                        I had a similar problem once. Maybe some files are still write protected if UE (or the launcher) is still in use?

                        1. Remove the Binaries & Config folders (with the GPU lightmass alterations) from the Unreal directory.
                        2. Use Unreal to install the original code (use the Verify option in the Launch Dropdown).
                        3. Copy the newly generated Binaries & Config folders to a backup location (in case this error returns)
                        4. Paste the chosen GPUlightmass folder (medium/high etc) to the correct position.

                        It worked after that and thanks to 3, the next time an error happens OR you need the standard Lightmass for some reason, you can easily put back the original code (much faster than 2)
                        Last edited by maxbrown; 08-24-2018, 07:22 AM.

                        Comment


                          Originally posted by Luoshuang View Post
                          I've uploaded 4.20.2 version. Also, support for Sparse Volume Lighting Samples should have been recovered in 4.20.2. Let me know if it doesnt work.

                          For video card recommendation, I would suggest waiting for RTX.
                          Hey bud, just checked in 4.20.2 here and it looks like sparse volume lighting samples are working great.

                          I have noticed though that it's not automatically feeding emissive materials into lightmass any more like it did on 4.19. Is there a way to change this behaviour to force it to automatically do this without needing to set the 'use emissive for static lighting' bool on the mesh?
                          Thanks for the great work on this!!

                          Comment


                            Originally posted by Cyberglobe View Post
                            after changing GPU lightmass settings a couple of times from Medium to High, for example, I get this error at the beginning of the building process.

                            <None> === Lightmass crashed: ===
                            Assertion failed: (Index >= 0) & (Index < ArrayNum) [File:c:\ue4-gpulightmassintegration\engine\source\runtime\core\public\Containers/Array.h] [Line: 611]
                            Array index out of bounds: 8 from an array of size 8


                            0x00007ffbafd6a388 KERNELBASE.dll!UnknownFunction []
                            0x00007ffb09cd44c0 UnrealLightmass-ApplicationCore.dll!UnknownFunction []
                            0x00007ffb04239a5c UnrealLightmass-Core.dll!UnknownFunction []
                            0x00007ffb041cc55d UnrealLightmass-Core.dll!UnknownFunction []
                            0x00007ff65608ef70 UnrealLightmass.exe!UnknownFunction []
                            0x00007ff6560974ef UnrealLightmass.exe!UnknownFunction []
                            0x00007ff6560ed0ff UnrealLightmass.exe!UnknownFunction []
                            0x00007ff65609ea4c UnrealLightmass.exe!UnknownFunction []
                            0x00007ff6560c1c22 UnrealLightmass.exe!UnknownFunction []
                            0x00007ff6560e33c7 UnrealLightmass.exe!UnknownFunction []
                            0x00007ff65617a858 UnrealLightmass.exe!UnknownFunction []
                            0x00007ffbb04d3034 KERNEL32.DLL!UnknownFunction []
                            0x00007ffbb2eb1431 ntdll.dll!UnknownFunction []


                            What's that?
                            Please help
                            Have you tried to clean your lightmass cache?
                            I had the same issue, clearing my cache fixed it.

                            Comment


                              Originally posted by Kirillkesler View Post

                              Have you tried to clean your lightmass cache?
                              I had the same issue, clearing my cache fixed it.
                              Same Here.
                              clearing my cache fixed it.
                              CHECK OUT:- Visit https://3darchstuffs.com/ for Unreal arch-viz tutorials, Unreal Demo EXE and Unreal projects with source files.


                              https://www.youtube.com/playlist?lis...X3Sm2Z9NXEHFV9

                              Comment


                                Originally posted by 3darchstuffs View Post

                                Same Here.
                                clearing my cache fixed it.
                                Silly question - how do you clear cache ?

                                Comment

                                Working...
                                X