Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Wilkes View Post

    After running a few successful tests on smaller maps, I tried to run a bake on a pretty big map using the command line. After the "Building BVH" bar gets to 100%, I get an error that says "invalid argument." When I press OK on that, it gives me this: https://i.imgur.com/pwswHGe.png

    After hitting "retry," it fails and then gives me this output log: https://pastebin.com/2X90z3Ry
    Originally posted by PixelDigitalArts View Post

    in one of my scenarios, the lighting is all black, except for the direct light of the directional light (without indirect lighting). I left the light source angle value at 1 and I deactivated the Use Area Shadows option. This light is static.

    In addition to directional light, I have a skylight with an hdr, also static light that does not seem to be illuminating the scene. the result is all black.

    Any idea what I might be doing wrong?
    While I would like to work and debug the problems you guys have, I'm currently on my relocation to Cary, NC and my desktop computer is still in transport so I cannot work on codes. Sorry for that!

    Comment


      Originally posted by Luoshuang View Post
      I'm currently on my relocation to Cary, NC and my desktop computer is still in transport so I cannot work on codes.
      Wait... Does it mean you gonna work on GPU Lightmass as regular Epic employee?

      Comment


        Originally posted by Cheshire Dev View Post

        Wait... Does it mean you gonna work on GPU Lightmass as regular Epic employee?
        Please let the rendering Gods show us favor and let this be true

        Comment


          I finally build one of the 3rd party UE4 forks with GPULightmass. How would I know UE4 is using GPULightmass and not vanilla Lightmass ? When I built lighting on a very small level, I didn't see any special progress indicator. Everything seemed as usual. Since level was tiny, I can't really tell building speed difference.

          Comment


            Originally posted by motorsep View Post
            I finally build one of the 3rd party UE4 forks with GPULightmass. How would I know UE4 is using GPULightmass and not vanilla Lightmass ? When I built lighting on a very small level, I didn't see any special progress indicator. Everything seemed as usual. Since level was tiny, I can't really tell building speed difference.
            The attached screencap is a new window you should have with the GPU lightmass when you start a bake. The CPU (OG) lightmass doesn't have it.
            Antoine Guillo, FR
            Virtual Reality Designer
            https://groupe-legendre.com/

            Comment


              Originally posted by LegendreVR View Post

              The attached screencap is a new window you should have with the GPU lightmass when you start a bake. The CPU (OG) lightmass doesn't have it.
              Hmm... I didn't see that one

              Comment


                I had the issue with freezing baking status windows when I switched lightmap resolution to 4K, but 2K worked fine. Please lower some lightmaps to 2K or lower.

                Comment


                  Alright, getting another issue

                  Initially I followed the instructions, copied files where they should be and of course those files got overwritten during solution build process. That's why I wasn't getting any indicator for GPULightmass building lighting.

                  However, after I copied GPULightmass files over the freshly built engine, I got this error (screenshot attached). Any idea what's going on?

                  Thanks beforehand

                  P.S. I am not sure why it's not taking this path "../Win64/GPULightmassKernel.dll" - the file is there.

                  P.P.S. Now that I am thinking about this in the morning, I might have updated the source with newer release, but never updated the code in Lightmass.cpp
                  Attached Files
                  Last edited by motorsep; 05-30-2018, 09:58 AM.

                  Comment


                    Originally posted by Luoshuang View Post

                    The total number of samples taken by the Brute Force GI Engine is fixed:

                    Fast Preview: 16 * 16 * 2 = 512
                    Medium Quality: 32 * 32 * 2 (Fixed) + 32 * 32 * 2 (Adaptive) = 4096
                    Ultra High: 64 * 64 * 2 (Fixed) + 64 * 64 * 2 (Adaptive) = 16384

                    However, the secondary radiosity caching GI engine does accept a parameter to reduce/increase the quality: MappingSurfaceCacheDownsampleFactor (minimum 1) in BaseLightmass.ini. Basically the engine uses your lightmap resolution as a reference and divides it by the downsample factor to deduce the final indirect lighting resolution. Raising the downsample factor can reduce video memory consumption but can also introduce leaks. A workaround is to split the lightmap UV at where the lighting leaks.
                    ========================

                    if .ini is impossible yet
                    can you make this hardcoded version for us ????

                    Ultra Ultra High: 256 * 256 * 2 (Fixed) + 256 * 256 * 2 (Adaptive) = 262144


                    Last edited by Farshid; 05-30-2018, 02:17 AM.

                    Comment


                      portal lights doesnt work on GPU lightmass ?
                      it seams so
                      with or without portals took 30 minute to render

                      Comment


                        similar to wilkes, I'm getting an error (attached)
                        Its not consistent though, was just testing a scene and went down to a very basic level, basically just a simple plane and point light. When that was the only object in the scene I would get that error immediately, however if I added a second mesh to the scene it would bake fine.
                        Attached Files

                        Comment


                          I used the high quality settings on a scene i am currently working on and when it baked, the lighting was extremely bright and blown out compared to default ligtmass.ini. Also, I have so much blotchy noise, even with the light turned way down its completely covered in noise. Should I have to completely rebuild my lighting from ground up to use this tool?

                          EDIT: MY BAD! I USED A LOT OF EMISSIVE AND AFTER SETTING BOOST TO '0'ON EACH MESH WITH EMISSIVE THE SCENE RENDERS REALLY NICELY. GREAT WORK:P
                          Last edited by gartht3d; 05-31-2018, 02:39 AM.

                          Comment


                            my GPU Lightmass Try !!!
                            Render Time : 1 Hour
                            GPU : GTX 1060













                            Last edited by Farshid; 05-31-2018, 01:33 AM.

                            Comment


                              Congratulation!
                              Originally posted by Luoshuang View Post

                              While I would like to work and debug the problems you guys have, I'm currently on my relocation to Cary, NC and my desktop computer is still in transport so I cannot work on codes. Sorry for that!

                              Comment


                                Originally posted by Farshid View Post
                                my GPU Lightmass Try !!!
                                Render Time : 1 Hour
                                GPU : GTX 1060
                                Perfect lighting!
                                I'm curious to know if you had to configure something special in the lights...

                                my results are far from yours...
                                I have just a Directional light and a skylight with the default settings, and my scene is almost black... To see some indirect light I have to boost the indirect light intensity from to something like 100. But even then the results aren't as good as yours...

                                ‚Äč

                                Comment

                                Working...
                                X