Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by syrom View Post
    noticed the binary install link has 3 files. do i download all?
    I was confused at first to, I don't think OP has set up user controls so I believe those are just 3 different quality settings(fast, low and ultra), so each is a zip that you just dump into the epic games/engine folder, it will overwrite default settings so back those up if you want to go back.

    Comment


      Any idea why this is happening? Using Volumetric Lightmaps:
      https://www.artstation.com/melviso
      https://www.behance.net/melvisuzokf304

      Comment


        Thank you for this amazing tool! I have a scene with some grass, scattered with the foliage tool, that can't render when there is an override in the lightmap size.

        Comment


          getting this error after using gpu baker

          Comment


            Originally posted by haideralix1 View Post
            getting this error after using gpu baker
            See the TDR fix. the baker crashes because your GPU is stalling and doesn't respond while computing some big lightmaps. Increase the TdrDelay value to around 100/200.
            Antoine Guillo, FR
            Virtual Reality Designer
            https://groupe-legendre.com/

            Comment


              great work.. sometest with gtx970

              just 30 minutes gpu bake time.(ultra setting pack)

              with cpu got 7.5 hours. :/

              this feature deadline killer of some archviz projects. that should definitely be in the new release.

              Luoshuang thx mate this is game changer!
              Last edited by Nocturness; 05-14-2018, 07:08 AM.

              Comment


                Does it work flawlessly with 4.19.2 ?

                Comment


                  I've tried this today. It's really fast but I'm curious if there are there no tweakable parameters? I had my DiffuseBoost at 2.5 previously and the GPU bake seemed to have removed nearly all of it. Also AO seems to be reduced. Can someone do a writeup on how to actually use this for us a bit less technically inclined?

                  Edit: Something else is weird. I completely removed the folders from the download file and replaced them with my backup from before. Somehow the GPU Lightmass is still running like some black magic. How can I revert?

                  Edit2: I'm also getting lightmap errors still. I feel like I'm using this entirely wrong.
                  Last edited by Brygelsmack; 05-14-2018, 11:30 AM.

                  Comment


                    Awesome Work. Keep it up.
                    CHECK OUT:- Visit https://3darchstuffs.com/ for Unreal arch-viz tutorials, Unreal Demo EXE and Unreal projects with source files.


                    https://www.youtube.com/playlist?lis...X3Sm2Z9NXEHFV9

                    Comment


                      Anybody tried to create package? With 4.18.2 I can create package without any problem. But using modyfied version of 4.19.2 packaging process stops after a few moments, shows window "Compiling shaders" which increasing from 103 to 1280 and then nothing happens. Editor works. I can move camera and stop the packaging process.

                      I think, I found problem - 64-bit)): LogInit: Display: LogModuleManager: Warning: Found module file ../../../Engine/Binaries/Win64/UE4Editor-UnrealEd.dll (API version 0), but it was incompatible with the current engine API version (3944462). This is likely a stale module that must be recompiled.

                      How to fix this?

                      EDIT. False alarm. Something happened with project file after import Open World Demo Collection. I've exported all assets to the new project file and everything works perfect.
                      Last edited by Lukas0891; 05-14-2018, 05:47 PM.

                      Comment


                        Originally posted by Brygelsmack View Post
                        I've tried this today. It's really fast but I'm curious if there are there no tweakable parameters? I had my DiffuseBoost at 2.5 previously and the GPU bake seemed to have removed nearly all of it. Also AO seems to be reduced. Can someone do a writeup on how to actually use this for us a bit less technically inclined?

                        Edit: Something else is weird. I completely removed the folders from the download file and replaced them with my backup from before. Somehow the GPU Lightmass is still running like some black magic. How can I revert?

                        Edit2: I'm also getting lightmap errors still. I feel like I'm using this entirely wrong.
                        This is my fear. Hate to install it and ruin everything and have to start fresh. I have some projects i dont want to corrupt. Maybe more clear instructions can help and a walk through on what to back up exactly to revert. Im still confused on downloading all 3 files from the link or just 1.

                        Comment


                          Hello, I'm trying to install the GPU Lightmass, however, whenever I try to bake lighting, it says it can't and shows this. I used both the Binary installation and Source ( Hybrid) installation, and none of them worked.

                          Comment


                            Originally posted by Nocturness View Post
                            great work.. sometest with gtx970

                            just 30 minutes gpu bake time.(ultra setting pack)

                            with cpu got 7.5 hours. :/

                            this feature deadline killer of some archviz projects. that should definitely be in the new release.

                            Luoshuang thx mate this is game changer!
                            I think this shows we never can go back to the old lightmass. Great work Nocturness.

                            Originally posted by lukaszcieslak View Post
                            Anybody tried to create package? With 4.18.2 I can create package without any problem. But using modyfied version of 4.19.2 packaging process stops after a few moments, shows window "Compiling shaders" which increasing from 103 to 1280 and then nothing happens. Editor works. I can move camera and stop the packaging process.

                            I think, I found problem - 64-bit)): LogInit: Display: LogModuleManager: Warning: Found module file ../../../Engine/Binaries/Win64/UE4Editor-UnrealEd.dll (API version 0), but it was incompatible with the current engine API version (3944462). This is likely a stale module that must be recompiled.

                            How to fix this?
                            No problem here. Making a package works fine for me on 4.19.2. Have you got 4.19.1 maybe (still) installed? Does 4.19.1 give you the same problem?

                            Comment


                              I'm not getting as great results in some of my scenes, this one in particular is very noisy. I have another scene which I can't share here that I got much better results in. Is there a way to mitigate the noise seen in these images? I tried increasing the lightmap resolutions but that only seems to help a small amount.
                              3D Artist & Virtual Reality Specialist

                              Comment


                                Originally posted by jeroen_v View Post
                                No problem here. Making a package works fine for me on 4.19.2. Have you got 4.19.1 maybe (still) installed? Does 4.19.1 give you the same problem?
                                No. I have fresh 4.19.2 only.

                                Comment

                                Working...
                                X