Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by pax invictus View Post
    GPU Lightmass 4.26.0

    Download binaries

    Source code
    Naaaaaaah....
    You rrrrrock !!! Master of The Universe! .

    Comment


      Originally posted by pax invictus View Post
      GPU Lightmass 4.26.0

      Download binaries

      Source code
      Thank you!
      Tcimage3d Studio
      Unreal Artist & Developer in archi & interior Visual
      Real Estate VR Tutor: http://tcimage3d.wixsite.com/3dvr

      Request a quote today:tcimage3d@gmail.com
      Follow us on Facebook: https://www.facebook.com/TCimage/

      Comment


        Originally posted by tc22 View Post

        Thank you!
        does it fork for u on 4.26 ?
        i get this error:

        Click image for larger version

Name:	Screenshot_4.png
Views:	2301
Size:	14.1 KB
ID:	1843457

        Comment



          Does anyone know how to fix this weird shadow bug?. I'm sure it's not the lightmap's bug. Thanks
          Attached Files

          Comment


            This is my first time installing this. When i replace the Engine folder the launcher wants to repair the engine. Is this normal?

            Comment


              This is my first time installing this. When i replace the Engine folder the launcher wants to repair the engine. Is this normal?

              Comment


                Originally posted by xmasjazzy View Post
                Does anyone know how to fix this weird shadow bug?. I'm sure it's not the lightmap's bug. Thanks
                What GPU are you using? I have the same artifacts on 2080ti. But on my home PC with 1080ti there are no problems

                Comment


                  Originally posted by xmasjazzy View Post
                  Does anyone know how to fix this weird shadow bug?. I'm sure it's not the lightmap's bug. Thanks
                  Are you using Stationary lights instead of Static?
                  RTX RayTracing easy global settings tweaker

                  Advanced HDRi background tool + 64 HDR images

                  Comment


                    Originally posted by iDeal3d View Post

                    What GPU are you using? I have the same artifacts on 2080ti. But on my home PC with 1080ti there are no problems
                    My GPU is RTX 3080. Before that i used 2080 also had the same situation.

                    Comment


                      Originally posted by Miguel1900 View Post

                      Are you using Stationary lights instead of Static?

                      I have tried both but still get the above error. Black streaks move from one position to another

                      Comment


                        Originally posted by xmasjazzy View Post


                        I have tried both but still get the above error. Black streaks move from one position to another
                        I used to get this error with earlier versions. Just delete the light and create a new one, then bake again.

                        Comment


                          How are you guys? A doubt.
                          I am having 1 month having problems with cudaCheckError: out of memory.
                          Also in Unreal 4.26 new gpu render ... without memory.

                          What is my limit that I can render? How can I find out what is in excess? I've tried everything. (TDA, unreal in cmd to render, 1k textures).
                          If I share (swarm) the process with another notebook (same configuration) can I circumvent this lack of memory?


                          Intel Core i7-9750h, 32GB RAM, NVIDIA RTX 2060 NVIDIA® GeForce® RTX 2060
                          Skylight import processing 1.724s with CubemapSize 2048
                          FStaticLightingSystem started using GKDOPMaxTrisPerLeaf: 4
                          Number of texture mappings: 6454
                          Number of static mesh instance mappings: 6454
                          Scene surface area calculated at 19211.600 million units (6.714% of the estimated 286131.531 million units)
                          Importance volume surface area calculated at 678.918 million units
                          Collision Mesh Overview:
                          Num Triangles : 13134666
                          MeshInfos : 0.5Mb
                          UVs : 82.8Mb
                          LightmapUVs : 82.8Mb
                          Embree Used Memory : 964.0Mb
                          EmitDirectPhotons complete, 0.918 million photons emitted in 0.2 seconds
                          Built photon segment map in 0.0 seconds
                          EmitIndirectPhotons complete, 3.259 million photons emitted in 1.0 seconds
                          Marking Irradiance Photons complete, 0.117 million photons marked in 0.1 seconds
                          Caching Irradiance Photons complete, 53.814 million cache samples in 136.8 seconds
                          Calculate Irradiance Photons complete, 0.094 million irradiance calculations in 10.4 seconds
                          Radiosity Setup 2711.2s

                          Comment


                            Originally posted by pax invictus View Post
                            GPU Lightmass 4.26.0
                            The new GPU lightmass build for 4.26 works nicely. For testing purposes, I also enable Epics GPU lightmass & rhi12 & raytracing in the same project. I get quite some crashes due to this combo when trying to play the level. Does this error make sense to you? GpuLightmass related OR Epics new GPU lightmass related OR maybe just the combo?''
                            Edit; disabling Epics new plugin, rhi back to default and no raytrace = no crashes for the last hour.
                            Edit2: when reverting to a clean Epic Launcher build, no crashes. Must be the combo somehow.
                            Code:
                            Assertion failed: (void*)((&ElementData[InstanceIndex]) + 1) <= (void*)(InstanceTransformDataPtr + CurrentSize) [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\Engine\Public\StaticMeshResources.h] [Line: 1618]
                            
                            UE4Editor_Core
                            UE4Editor_Core
                            UE4Editor_Engine
                            UE4Editor_Renderer
                            UE4Editor_Renderer
                            UE4Editor_Renderer
                            UE4Editor_Renderer
                            UE4Editor_Renderer
                            UE4Editor_Renderer
                            UE4Editor_Core
                            UE4Editor_Core
                            UE4Editor_RenderCore
                            UE4Editor_RenderCore
                            UE4Editor_Core
                            UE4Editor_Core
                            kernel32
                            ntdll
                            Last edited by maxbrown; 01-09-2021, 08:49 AM.

                            Comment


                              Hey everyone! First of all, thanks for this amazing tool! It's a huge time saver! However, I've been scracthing my head over this problem and I can't find a solution. I've spent hours reading this thread, trying different settings, but I can't figure out what's causing these red splotches everywhere:

                              Click image for larger version

Name:	splotches.jpg
Views:	1282
Size:	188.7 KB
ID:	1850378

                              Anyone has any pointers? Any help would be greatly appreciated! Thanks!
                              Environment Artist
                              www.thiagoklafke.com
                              www.gumroad.com/thiagoklafke

                              Comment


                                Originally posted by Minos View Post
                                Hey everyone! First of all, thanks for this amazing tool! It's a huge time saver! However, I've been scracthing my head over this problem and I can't find a solution. I've spent hours reading this thread, trying different settings, but I can't figure out what's causing these red splotches everywhere:


                                Anyone has any pointers? Any help would be greatly appreciated! Thanks!
                                So, I figured out what was the problem. Turns out that the baker wasn't recognizing my skybox, since I enabled "Is Sky?" in the material flags. When I turned this off, the red splotches were almost gone, but I was still getting some. After realizing that the hole at the bottom of my custom dome was exposed to the void, I realized that these "rogue" splotches were being spawned from there. After completely encapsulating the dome, and changing the FireflyThreshold option to 10, I got a perfect bake! Here's how the scene looks like now:

                                Click image for larger version  Name:	sampa.jpg Views:	1 Size:	487.4 KB ID:	1850747

                                Thank you so much for this amazing tool!
                                Last edited by Minos; 01-08-2021, 11:03 PM.
                                Environment Artist
                                www.thiagoklafke.com
                                www.gumroad.com/thiagoklafke

                                Comment

                                Working...
                                X