Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Try to free up as much vram as possible before baking. That could mean closing other applications (like Substance painter or other 3d apps), turning off realtime viewport, setting engine scalability settings to low.

    Comment


      Hi,
      I have a doubt that would like it to be clarified.
      Luoshuang's GPULightmass works with any of these cards?
      Nvidia tesla k10, k40, k80
      Thank you

      Comment


        I wanted to try the tool with v4.25, as I noticed a loss of quality when using it on 4.22. The best results (I think) was obtained using v4.20, lot of months ago.

        This is 4.20:
        Click image for larger version

Name:	420 gpu.jpg
Views:	1775
Size:	405.1 KB
ID:	1791873

        And this is 4.25:
        Click image for larger version

Name:	425 gpu.jpg
Views:	1732
Size:	384.1 KB
ID:	1791874
        (You can download both and, for example, paste it into photoshop, and enable/disable one of the layers, so you can quickly compare). For me, on 4.20, global illumination bounces and ambient occlusion were better.

        Regards!
        RTX RayTracing easy global settings tweaker

        Advanced HDRi background tool + 64 HDR images

        Comment


          Hi everyone! I have a problem with the 4.25.1 version of the GPU Lightmass plug. So Im doing an interior, not too complex. Optimized it in 3dsmax, exported it with Datasmith, set the materials and all. Switched off ForceNoPrecomputed Lighting, running it hybrid, raytrace reflection, AO, mode, no RTX GI running. After 2 days of trying I finally managed to downgrade the lightmaps and run a lighting bake. I get a ton of UV lightmap overlap errors and also my scene looks like there is no light being cast from the windows. I need some pointers to what environment i should set up, should I use a skydome, does the GPU lightmass support rectangle lights for window portals and basically how can I get a decent bake from this. I have posted images to how it looks AFTER baking the light.
          Ignore the lightbake warning, i turned off some light properties.

          If anyone can help or give me a step by step or pointers what to do and what not to use, lightmap uv generation etc. That would be grand!

          Click image for larger version

Name:	viewportgrab2.jpg
Views:	1634
Size:	387.4 KB
ID:	1792775Click image for larger version

Name:	viewportgrab3.jpg
Views:	1637
Size:	441.4 KB
ID:	1792776Click image for larger version

Name:	viewportgrab4.jpg
Views:	1636
Size:	388.5 KB
ID:	1792777Click image for larger version

Name:	viewportgrab5.jpg
Views:	1630
Size:	388.5 KB
ID:	1792778Click image for larger version

Name:	viewportgrab1.jpg
Views:	1780
Size:	395.5 KB
ID:	1792774

          Comment


            Originally posted by petermayer1129 View Post
            Hi everyone! ...
            What about simply using a static Sky light and a static or stationary Directional light?
            RTX RayTracing easy global settings tweaker

            Advanced HDRi background tool + 64 HDR images

            Comment


              Originally posted by Muchasty View Post
              Bake Performance problems.
              When bake:
              1) Turn off Realtime in EDITOR
              2) Move the SWARM app to the top ( visible - it really helps, believe me ) ( you can find its yellow icon in the system try )
              3) Do not overload CPU with other things ( it can be a bottleneck for GPU computation cause CPU is also utilized very hard)

              I have the same issues with my RTX2080ti and this what I wrote is a solution for it.
              What do you mean by "Move the SWARM app to the top"?

              Comment


                Move SWARM to top means to make window visible while baking cause I believe that sometimes Windows can manage it like a background process.
                I mentioned it because sometimes it helps and the GPULM suddenly starting to compute as it should. Sometimes not. ( even if I ma sure that I have no other programs open that could use CUDA or GPU somehow ).

                https://www.artstation.com/tomaszmuszynski

                Comment


                  Hello,
                  I am using GPU lightmass in 4.25. I have some "problems" with GI and shadows. Not sure if it is the expected result or if there is something wrong in the scene.
                  Lightmaps are made with 3dsmax, and resolutions are really high. Lightmass compression is off. Num indirect lightning bounces set to 10 (tryed 100 with same result)
                  Bake is set to production and in the Base Lightmass.ini I have NumPrimaryGISamples=128 NumSecondaryGISamples=64

                  As you can see in the next iages, the "problem" is that light does not "disperse" it is like every window is like a beamer of light, wich is how it should be, but I am not sure if this is too exagerated. Do we need lightportals with GPU?

                  Thank you in advance

                  EDIT: lightportals seem to have no effect on the result.
                  the "problem" seems to be more exagerated when the rooms have only indirect light, like the third picture.

                  Click image for larger version  Name:	HighresScreenshot00004.jpg Views:	0 Size:	74.3 KB ID:	1793623

                  Click image for larger version  Name:	HighresScreenshot00005.jpg Views:	0 Size:	109.9 KB ID:	1793625


                  Click image for larger version  Name:	HighresScreenshot00006.jpg Views:	0 Size:	66.9 KB ID:	1793624
                  Last edited by Idgi_; 07-27-2020, 08:30 PM.

                  Comment


                    Originally posted by Idgi_ View Post
                    Hello,
                    I am using GPU lightmass in 4.25. I have some "problems" with GI and shadows. Not sure if it is the expected result or if there is something wrong in the scene.
                    No one??
                    Please guys!!! just need to know if this is expected behavior or if there is a way to make GI more disperse/scattered ??

                    because this is not usable for production...cannot have beams of light in the walls

                    Comment


                      New problem has arised since yesterday. Now it just crashes. Anyone have the same? thanks
                      Click image for larger version

Name:	Annotation 2020-07-28 162606.jpg
Views:	1328
Size:	111.9 KB
ID:	1793903

                      Comment


                        Originally posted by petermayer1129 View Post
                        New problem has arised since yesterday. Now it just crashes. Anyone have the same? thanks
                        Click image for larger version

Name:	Annotation 2020-07-28 162606.jpg
Views:	1328
Size:	111.9 KB
ID:	1793903
                        try clean and after validate the Swarm cache on the Cache tab of the swarm agent

                        Comment


                          Originally posted by Idgi_ View Post
                          Hello,
                          I am using GPU lightmass in 4.25. I have some "problems" with GI and shadows. Not sure if it is the expected result or if there is something wrong in the scene.
                          Lightmaps are made with 3dsmax, and resolutions are really high. Lightmass compression is off. Num indirect lightning bounces set to 10 (tryed 100 with same result)
                          Bake is set to production and in the Base Lightmass.ini I have NumPrimaryGISamples=128 NumSecondaryGISamples=64

                          As you can see in the next iages, the "problem" is that light does not "disperse" it is like every window is like a beamer of light, wich is how it should be, but I am not sure if this is too exagerated. Do we need lightportals with GPU?

                          Thank you in advance

                          EDIT: lightportals seem to have no effect on the result.
                          the "problem" seems to be more exagerated when the rooms have only indirect light, like the third picture.
                          If you could recreate that same project in an older version of UE4 and share it (only the necessary things, of course), I could test it on 4.22 and 4.24 too, as I noticed some changes that I didn't like on 4.25. I addition we could see how is your actual exterior illumination. Maybe the sky is too powerful.

                          Originally posted by petermayer1129 View Post
                          New problem has arised since yesterday. Now it just crashes. Anyone have the same? thanks
                          I have never been ablo to solve those kind of errors. Maybe idgi recommendation works. For me, usually, it was due to a certain asset I added and was not "compatible", for any reason, with GPUL.

                          Regards!
                          RTX RayTracing easy global settings tweaker

                          Advanced HDRi background tool + 64 HDR images

                          Comment


                            Originally posted by Miguel1900 View Post

                            If you could recreate that same project in an older version of UE4 and share it (only the necessary things, of course), I could test it on 4.22 and 4.24 too, as I noticed some changes that I didn't like on 4.25. I addition we could see how is your actual exterior illumination. Maybe the sky is too powerful.
                            thank you...I am doing a small test to recrate the problem...I noticed that when I have no landscape or floor outside the house, and in the skylight "lower hemisphere is solid color" is uncheck, then as the light come from all directions to the inside and the results are as expected.

                            I will download ue 4.24 and try to do the same there and send it to you, thank you!

                            Comment


                              I wasn't thinking so I updated the engine to 4.25.3 and reapplied 4.25.1 GPUlightmass but it looks like now both GPUlightmass and regular lightmass(swarm) are run when building lights. Or is swarm supposed to show up?

                              Comment


                                Originally posted by MohsenBlur View Post
                                I wasn't thinking so I updated the engine to 4.25.3 and reapplied 4.25.1 GPUlightmass but it looks like now both GPUlightmass and regular lightmass(swarm) are run when building lights. Or is swarm supposed to show up?
                                I think it is supposed to show up, at least it has allways showed up for me in 4.22 and 4.25

                                Comment

                                Working...
                                X