Announcement

Collapse
No announcement yet.

Luoshuang's GPULightmass

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Originally posted by Metathesus View Post

    Click image for larger version

Name:	Sans-titre1.jpg
Views:	1603
Size:	197.4 KB
ID:	1711025
    In task manager, You can select Cuda in one of the four graphs...
    Yup I know where its at, but unlike what your pic shows none of my 'graphs', show Cuda at all.
    Solo but Seismic - feel free to apply
    https://neighborlee1.wixsite.com/theheartseed

    Comment


      I just happened to bake scene with CPU Lightmass and then GPU Lightmass (same project, very simple, testing stock 4.24.1 vs Oculus 4.24.1 with has GPU Lightmass). I noticed that CPU Lightmass takes environment color from World Settings for Skylight when no cubemap is specified (and if skysphere is missing). GPU Lightmass ignores it completely (so my indirect lighting is pitch black).

      I never noticed that before because I always had skysphere. Is it a bug or an unsupported feature in GPU Lightmass ?

      EDIT: After chatting with the Man himself, it sounds like it's unsupported :/
      Last edited by motorsep; 01-21-2020, 11:58 PM.

      Comment


        Has anyone figured out a workaround for GPU Lightmass crapping all over LODed static meshes ?

        Apparently LODs are also not supported and if there is no workaround, it was nice knowing you folks, but I would have to go back to CPU Lightmass

        Click image for larger version

Name:	GPULightmass_Issues.png
Views:	807
Size:	451.6 KB
ID:	1711595




        Comment


          You can use command line to launch the editor and bake lighting to save GPU resources for GPULightmass, especially video memory.

          Engine/Binaries/Win64/UE4Editor-Cmd.exe "path\to\your\project\yourproject.uproject" -run=resavepackages -buildlighting -allowcommandletrendering -map=/Game/Maps/MyMap.umap
          Remember to replace Content with Game in the umap path
          As mentioned before, is there any way to use this command on macOS or Linux?
          I tried "UnrealLightmass" command in ProjectFolder\Engine\Binaries\Linux instead of UE4Editor-Cmd.exe on Ubuntu 18.04 LTS, but got error below again and again...

          Code:
          Failed to open scene channel with GUID {00000123}:{00004567}:{000089ab}:{0000cdef}
          LogInit: Error: Timed out waiting for the recipient (TimeWaitingSec = *****)

          Comment


            Hey guys its just a dumb question, but i read a lot of pages in this thread and still couldnt figure out, how i can setup the GPU Lighmass properly. Can you give me a litttle help?. Do i have to build the Engine from source and then switch out the selectet Engine Binary files?

            Comment



              Originally posted by Lesuge View Post
              Hey guys its just a dumb question, but i read a lot of pages in this thread and still couldnt figure out, how i can setup the GPU Lighmass properly. Can you give me a litttle help?. Do i have to build the Engine from source and then switch out the selectet Engine Binary files?
              Look back one page to the posts by Bdcoll, Theirs a link to download the GPU Lightmass in a format that just needs extracting to the right folder, and the folder location is all in the Readme in that link. No need to rebuild from source etc. just extract that to the right place

              Comment


                Originally posted by Jamie.Marshall View Post


                Look back one page to the posts by Bdcoll, Theirs a link to download the GPU Lightmass in a format that just needs extracting to the right folder, and the folder location is all in the Readme in that link. No need to rebuild from source etc. just extract that to the right place
                Sorry my bad, i had to wait for the Swarm Agent to push the data to the GPU Lightmass. It worked
                Last edited by Lesuge; 01-22-2020, 10:50 AM.

                Comment


                  Originally posted by Bdcoll View Post

                  Thanks for the response, thats actually useful to know.

                  I only ask as i'm trying to solve this. I literally only have a skylight in the scene, intensity set to 1 but i'm getting terrible results even on production settings

                  Click image for larger version

Name:	1.png
Views:	976
Size:	351.1 KB
ID:	1711041
                  Skylight casts very scattered light and it looks like you've got a low ray count, you need to edit your BaseLightmass.ini.

                  Medium quality is I believe:
                  Code:
                  DevOptions.GPULightmass]
                  NumPrimaryGISamples=32
                  NumSecondaryGISamples=16
                  Extreme (I wouldn't go any higher than this) is:
                  Code:
                  DevOptions.GPULightmass]
                  NumPrimaryGISamples=256
                  NumSecondaryGISamples=64
                  The lightmass configuration script makes it very quick and easy to change this.

                  Comment


                    Originally posted by wickerman123 View Post

                    Skylight casts very scattered light and it looks like you've got a low ray count, you need to edit your BaseLightmass.ini.

                    Medium quality is I believe:
                    Code:
                    DevOptions.GPULightmass]
                    NumPrimaryGISamples=32
                    NumSecondaryGISamples=16
                    Extreme (I wouldn't go any higher than this) is:
                    Code:
                    DevOptions.GPULightmass]
                    NumPrimaryGISamples=256
                    NumSecondaryGISamples=64
                    The lightmass configuration script makes it very quick and easy to change this.
                    Ah thats great thanks for this. I'll have to look into using the script as i dont see a GPULightmass option in my BaseLightnmass, despite having it installed -_-


                    Edit: Actually i lie, its tucked away down at the bottom of everything, and Ctrl+F was failing to find it for some reason
                    Last edited by Bdcoll; 01-22-2020, 02:42 PM.

                    Comment


                      Click image for larger version

Name:	Adsız.png
Views:	860
Size:	215.6 KB
ID:	1712091
                      Gpu slow down and cpu always 100 percent. What is my problem. All lights close just sky and sun. All emissive material delete but still same

                      Comment


                        Originally posted by motorsep View Post
                        Has anyone figured out a workaround for GPU Lightmass crapping all over LODed static meshes ?

                        Apparently LODs are also not supported and if there is no workaround, it was nice knowing you folks, but I would have to go back to CPU Lightmass
                        Lods should work fine. In 4.24 though, if you have UE create LODs the lightmap channel is set wrong and so artifacts are all over the place.
                        Putting the proper lightmap channel manually can crash UE. Its been reported and fixed and will be in 4.24.2

                        Comment


                          Originally posted by maxbrown View Post
                          Lods should work fine. In 4.24 though, if you have UE create LODs the lightmap channel is set wrong and so artifacts are all over the place.
                          Putting the proper lightmap channel manually can crash UE. Its been reported and fixed and will be in 4.24.2
                          They don't and Luoshuang said LODs are going to give me headaches, which is exactly what happened (as you can see on the pic). LODs are handmade, not generated by UE4.

                          I rebuilt lighting with CPU Lightmass and not only got no artifacts at all using Preview settings, but also got nicer lighting in general (especially ambient lighting).

                          I am thinking GPU Lightmass was made with archviz in mind (it seems like I only got good results, fast, using it for indoor lighting and always had issues with outdoor lighting and LODs).

                          Comment


                            motorsep Strange. I never had any problems until the 4.24 lod-bug but I'm not doing any landscapes - just archviz.
                            We can only hope the new solution Epic (and Luoshuang) are working on will fix landscapes too. Still no word/sign when it will be in beta though.

                            Comment


                              Originally posted by maxbrown View Post
                              motorsep Strange. I never had any problems until the 4.24 lod-bug but I'm not doing any landscapes - just archviz.
                              We can only hope the new solution Epic (and Luoshuang) are working on will fix landscapes too. Still no word/sign when it will be in beta though.
                              Well, if you do archviz, why do you even need LODs That terrain is not Landscape. It's a bunch of static meshes made to match seamlessly regardless of LOD.

                              Comment


                                motorsep I need the LODs because the objective is to view the viz on Quest.

                                Not to drag this any further but I still fail to see why LODs would go wrong;
                                GPUlightmass is just another way to calculate the lightmaps. Unreal only calculates them for LOD0 as far as I know (tested this a while ago).
                                If manually created LODs have their lightmap UVs in exactly the same layout/position as LOD0, they would just re-use the same lightmap solution.
                                If artifacts are visible, I expect the uvs of the manually created LODs are not perfectly matching the internal layout of the LOD0 uvs.

                                Due to the LOD bug currently in 4.24 you can't test it now but when 4.24.2 is here, you could test the LOD + GPUlightmass by just importing one of the meshes and have UE auto-create a few LODs. Run GPUlightmass and no artifacts should be visible.
                                Last edited by maxbrown; 01-24-2020, 03:34 AM.

                                Comment

                                Working...
                                X