Announcement

Collapse
No announcement yet.

Render Distance Pulling My Hair !

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Render Distance Pulling My Hair !

    Please guys I need monster help this issue is breaking my game , Any help towards the right direction will be much appreciated !

    #2
    these are LOD's, did you create them or are they third party assets?
    CEO of Prydetech

    https://www.artstation.com/ixicalibur

    Originally posted by ixicalibur
    Here you go, this is a link to every tutorial you could ever need plus instructions to access all the collective knowledge of mankind: [Super massive awesome link that every amazing game developer uses to instantly learn to be super awesome at making stuff]

    Comment


      #3
      Third party assets , but it does it to everything . Fences , Light Post , Benches and indoor items . and it looks fuzzy at times .

      Comment


        #4
        Disable "Auto Compute LOD Distances" under the LOD Settings in the Static Mesh Editor. Then adjust the Screen Size under each LOD setting to adjust when the transitions happen based on their screen size.

        Keep in mind that the longer you render a higher poly mesh to avoid the transition because of LODs will result in higher load on your GPU. This is common for games, even AAA ones like Far Cry.

        https://youtu.be/TZVNqBmwtws?t=31s

        Ideally, you'd make better LOD meshes to make the transition less noticeable, but since these are third-party assets, you may not be editing them yourself.
        Tim Hobson | Learning Resources | Epic Games
        UE4 Documentation

        Comment


          #5
          Thanks Tim , Unfortunately it did nothing .
           

          Comment


            #6
            Try using a model (like the tree mesh). That had definitively different models that were popping. This example seems to be a material issue based on distance (maybe) and not a LOD popping on and off. I say this because you can see that the chain link part fades out and is not popping.

            To inspect the LODs individually and verify this, you can use the LOD picker in the viewport and change LOD from LOD Auto to LOD [Number] to inspect. For the fence, you can apply a material that is not the chain link and see if you still get the fading which I suspect you won't indicate that that's how the material may have been set up.

            For troubleshooting further, it's best to focus on a single mesh that we help with instead of different ones like this because it can be a separate issue not related to LOD specifically. Again, I think the tree would be a good one to start with and get you sorted. Then you can work from that and we can look at others as they come up.
            Tim Hobson | Learning Resources | Epic Games
            UE4 Documentation

            Comment


              #7
              The fnece looks like a mipmap problem. The smaller mips seem to pop in faster than usual. Make sure your ViewDistance in the Scalability settings is set to High. If it is lower, LODs and Texture Mips are calculated with a bias (Higher LODs and MIps are displayed earlier)

              Comment


                #8
                brr... with fence - you play with 0 lod obviously - nothing will change.
                anyway - you can go into actor/sm details=>rendering=>lod=> and set min lod for current actor

                Comment

                Working...
                X