Announcement

Collapse
No announcement yet.

Large building scaled down and bad lightmass

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Large building scaled down and bad lightmass

    Hi all,

    I’m looking for some enlightenment, I’ve got a building, modelled in Max at real world scale and brought in to Unreal where it’s scaled down to 0.01 to be about a meter long when it’s in AR, the thing is the building light maps build well when it’s 1.0 scale in the scene, but that obviously won’t do once in AR as it’s huge, when it’s scaled down however the light map build is very poor, the lightmap sizes are around 512 and the UVs are all good as it looks fine at 1.0.

    Is this down to the static lighting level scale? Seeming as the meshes are so densely packed at 0.01 scale I should lower the static lighting level scale down to say 0.1? I know it’ll really hit build times but I have power for that.

    I have lightmass importance volume set up but would ambient occlusion also cause problems at such a small scale?

    I tried building the light at 1.0 scale and then setting world scale at run time but that seems to completely remove shadows once world scale is changed.

    Ive attached a screenshot showing the poor *** light maps at the moment, this was done with a static lighting level scale of 1.0 and preview settings.

    Sorry I’m not so comfortable with lighting in UE4 and this is yet another new thing I’ve not dealt with before, any help would be most appreciated however, it really will.
    Attached Files
    Last edited by CGough; 03-16-2018, 07:29 PM.
    Modeller at Visualisation One

    #2
    If that's a single object you're not going to be able to get good lighting on it, it's too complex for even a high resolution lightmap.

    Comment


      #3
      Sorry I didn’t mention, it’s broken into many constituent parts, the windows, glass, each floor are all separate meshes with their own UVs with ample space for lightmaps.

      This will build nicely at 1.0 scale but will look like the image above at 0.01 scale.
      Modeller at Visualisation One

      Comment


        #4
        Hi!

        I've seen strange results on the forum caused by scaling... and in this case you downscale it by a LOT... why not doing it in your 3d app and bring in the proper size to Unreal?

        Comment


          #5
          Hi.

          I did try that, the building was scaled down and the xform was reset, however I only scaled down to 10% and not 1% so maybe that last percentage is a problem? I’ll have to try and hope to the high heavens it’s the cause.

          This is the problem having the “luxury” of 3ds Max and V-Ray, you don’t have to worry about things too much, in Unreal you really benefit from knowing the real way to do things, but you’re lost if you don’t.
          Modeller at Visualisation One

          Comment

          Working...
          X