Announcement

Collapse
No announcement yet.

Lighting Build Fails on linux

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Lighting Build Fails on linux

    On Unreal Engine 4.12 i was able to build lighting after deleting a leftover library as shown here in the link (https://answers.unrealengine.com/que...-on-linux.html) but this is not working on Unreal Engine 4.17.2 as there is no such file to delete.
    Lighting build stuck at 0% and then the Build Fails. Please help !
    My Logs are here -:

    #2
    I tested with UE4.18.3 on Fedora 27, no problems encountered; maybe you can consider migrating to newer engine versions.

    Also there is one way to enable Embree support on linux:

    Modify UnrealLightmass.Build.cs to include:

    }
    else if (Target.Platform == UnrealTargetPlatform.Linux)
    {
    Definitions.Add("USE_EMBREE=1");
    PublicAdditionalLibraries.Add("embree");
    }

    then use the system's package manager to install embree's development package. For Fedora, it should be

    sudo dnf install embree-devel

    which will install embree-2.17.3.

    P.S.: Newer version of embree is not fully tested with Lightmass so use it at your own risk. The reason why Lightmass is still using embree 2.7.0 is that some newer version was detected to have memory leaking problems. Performance wise, I observed that 2.17 is 15% faster than 2.7 in ray-tracing performance. So you can do similiar things on Windows if you want performance and do not care about the memory problem.

    Comment


      #3
      ok Thanks Unreal 4.18.3 was fine but the mac and android icon is missing but still not a major problem will see thanks. I will try to use Embree I am on OpenSUSE currently.

      Comment


        #4
        Its still like that ! Same problem tried on linux mint and fedora too (Fresh Installed). Here is My log same on all the OSs i have tried after lighting build after downloading 4.18 now as you suggested

        Comment


          #5
          After a bit of research i don't know see my 4.17 logs at my question (1st post) and on 4.18 there is a thing in common timed out to find the recipient It might be something related to that please help

          Comment


            #6
            For Fedora, you need to open udp port 6666 in the firewall settings.
            Last edited by Luoshuang; 03-02-2018, 04:57 AM.

            Comment


              #7
              how to open ports can you send me the terminal command Im now on openSUSE will try to do that on openSUSE.

              Comment


                #8
                Or how to do it GUI way ?

                Comment


                  #9
                  Originally posted by jatin_zlatanist View Post
                  Or how to do it GUI way ?
                  For Fedora, there is a gui program called "firewall" which can be launched directly from the start menu (at least for KDE)

                  Comment


                    #10
                    Lighting build completed but then my editor crashes when it was importing static meshes

                    Comment


                      #11
                      Originally posted by jatin_zlatanist View Post
                      Lighting build completed but then my editor crashes when it was importing static meshes
                      Well then that's not something I can cover for you, you have to work it out by yourself...

                      Comment


                        #12
                        I tried on an example project i also added lightmass importance volume but as soon lighting build completes it crashes the editor closes

                        Comment


                          #13
                          This Answer solved my problem Thanks for help ! I was able to work on my openSUSE after running these two commands and allow multicasting.

                          Comment

                          Working...
                          X