Announcement

Collapse
No announcement yet.

Shadows for small object fades out to early

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Shadows for small object fades out to early

    Hi, ich need help with my shadow rendering.
    I use the CSM and as you can see, the shadow of the wire fades out to early.
    I set r.Shadow.RadiusThreshold to 0.001 (lower values=no change).
    The performance isn't important atm. I just want normal DYNAMIC shadows.

    Attached Files

    #2
    Try to set Dynamic Shadow Distance to 20 000

    Comment


      #3
      If you're referring to the dotted appearance of the shadow, that looks more like a lower resolution cascade. Type in r.Shadow.MaxCSMResolution ? to see the resolution you're using and try increasing it.
      Lighting Artist II @ Crystal Dynamics
      ArtStation
      Twitter

      Comment


        #4
        Looks like you're out of the CSM range and probably in the distance field shadow range (if you have them enabled). As Quadart suggested, try setting the CSM range to 20000 and see if it goes away. Thin wire-like objects typically don't play well with shadows, let alone dynamic shadows. You might have to try increasing the diameter of the wire.

        Comment


          #5
          Thanks for your help! But when I increast the max csm resolution the shadows render range decreased and when try to increas the shadows range the resolution decreased so the quality is still the same.

          Comment


            #6
            No one who can help me?

            Comment


              #7
              Make sure you have max cascades and also set the scalability settings to cinematics
              Also you can try to use Distance fields shadows, with some high DM Resolution for that mesh
              https://docs.unrealengine.com/latest...istanceFields/

              Comment


                #8
                Distance field shadows was a nice tip thanks!

                Comment


                  #9
                  Ok, using distance field shadows worked but I prefere CSM. If someone know how to solve my previous problem (wit CSM) please tell me how!

                  Comment


                    #10
                    I think you need to increase the Shadow Resolution Scale (Directional Light)
                    Last edited by Babush61; 09-03-2019, 06:07 PM.
                    Plugin for HISM and ISMC https://www.unrealengine.com/marketp...nstance-editor

                    Comment


                      #11
                      You can increase resolution and tinker with settings at a great cost of performance and little change to your scene bottom line is this, you cant really fix this issue as it is directly related to some of the limitations that come with realtime shadow maps and cascades and biases. Unless you bake things you will continue to run into these shortcomings.

                      Comment

                      Working...
                      X