Announcement

Collapse
No announcement yet.

Problem with layered landscapes material displacement

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problem with layered landscapes material displacement

    Hi there, i already made a post on the answerhub but nobody seems to know the solution so i wanted to test my luck here.

    https://answers.unrealengine.com/que...-a-single.html

    I am not sure if this is a bug or just a material problem. Thanks !

    #2
    The only way for that to happen is that in the same landscape component you have mixed both materials with and without displacement. Set the painting tool strength to 1 and paint grass over the area and it should erase the displacement from the rock. It is important set the correct strength to avoid this. Also there is a limit of materials per landscape component you can paint (4 I guess).
    Nilson Lima
    Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
    Join us at Discord: https://discord.gg/uFFSEXY

    UE4 Marketplace: Cloudscape Seasons
    supporting: Community FREE Ocean plugin

    Comment


      #3
      Hi Nilson, thanks for your answer !

      Unfortunately, the results are the same, regardless of the toolstrength. Even when i clear the rock layer, fill the landscape with grass on a toolstrength of 1 and then paint rock on it, the spikes appear again.

      I also added a displacement map to the grass.


      Comment


        #4
        I have checked the material from that stream and it should work, unless you have done some modification that has changed it and some bug introduced. Can you share a picture of the material or export the nodes as text? Or,,,the amount of displacement for each texture should not be the same, I mean, maybe you are displacing the grass too much... Do you have specific scalars to tell how much displace each layer?
        Last edited by NilsonLima; 02-06-2018, 06:41 PM.
        Nilson Lima
        Technical Director @ Rigel Studios Ltda - twitter: @RigelStudios
        Join us at Discord: https://discord.gg/uFFSEXY

        UE4 Marketplace: Cloudscape Seasons
        supporting: Community FREE Ocean plugin

        Comment


          #5
          Hi again !

          I am using this as grass
          https://www.poliigon.com/texture/ground-forest-003

          and this as rocks
          https://www.poliigon.com/texture/cliff-jagged-004

          I only replaced the grass with the ground forest (and all the other respective maps) and the cobblestones with the cliff jagged.

          Unfortunately, dont know how to export the nodes as text, i will try to make it as clear as possible.

          https://imgur.com/a/MqprX

          I dont think the multiplier is the problem, i tested it also with a constant.

          I also tried to play around with the parameters but none of them seemed to be the cause of the problem.
          Last edited by Wizze192; 02-07-2018, 09:59 AM.

          Comment

          Working...
          X