Announcement

Collapse
No announcement yet.

Very short shadow fade distance for small static meshes.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Very short shadow fade distance for small static meshes.

    Yeah, I've seen that topic before. But those were about movable objects influenced by a stationary directional light.

    I've posted about this in the answer hub, to no avail or answer. Though at the time, I tried to use the LPV to circumvent Lightmass. Having seen little success with LPV, I turned back to Lightmass.

    So. Long story short, small static meshes cast shadows fine... and sharp, too. Within maybe a meter or two. If I ever want to actually deploy what I'm working on, that has to change.
    I've read up on the previous threads, tried out various fixes, increased / decreased settings within the .ini files as required, but nada. Nothing works. By comparison, the entire building
    casts sharp shadows even when seen from great distances. That bit in the right corner, still decent, though it suffers the same issue to a lesser degree. And the fencing just breaks apart
    beyond a couple meters out.

    What do? I'll settle for stationary dynamic lights for now, with stationary meshes too. Just so I can get at least one clean lighting solution going.

    I've also attached an image where I get texture warping on the walls. I have laid out clean, flat UVs for the wall, no distortion in those. What I did do though was to use a TextureCoord node,
    to scale the tiling. The settings are fairly extreme, 80 U and 220 V, given it had to go across the entire wall. Could that cause it?
    Attached Files

    #2
    Yeah, I've seen that topic before. But those were about movable objects influenced by a stationary directional light.

    I've posted about this in the answer hub, to no avail or answer. Though at the time, I tried to use the LPV to circumvent Lightmass. Having seen little success with LPV, I turned back to Lightmass.

    So. Long story short, small static meshes cast shadows fine... and sharp, too. Within maybe a meter or two. If I ever want to actually deploy what I'm working on, that has to change.
    I've read up on the previous threads, tried out various fixes, increased / decreased settings within the .ini files as required, but nada. Nothing works. By comparison, the entire building
    casts sharp shadows even when seen from great distances. That bit in the right corner, still decent, though it suffers the same issue to a lesser degree. And the fencing just breaks apart
    beyond a couple meters out.

    What do? I'll settle for stationary dynamic lights for now, with stationary meshes too. Just so I can get at least one clean lighting solution going.
    Have you tried using static lighting and click build lighting? This can give you great shadow resolution that is baked into a lightmap that will not fade on distance. Stationary lighting can be a balance between dynamic and static by giving you shadow detail for distances while giving you dynamic lighting within a closer range of your objects.

    Dynamic shadows will work within a range but need to be adjusted in the details panel under the section "Cascaded Shadow Maps". Changing the Dynamic Shadow Distance Movable, Num Dynamic Shadow Cascades to any value up to 10 (will have to manually type in any value above 4, but will come at a rendering cost), and Cascade distribution exponent should help get you some better shadow resolution.



    I've also attached an image where I get texture warping on the walls. I have laid out clean, flat UVs for the wall, no distortion in those. What I did do though was to use a TextureCoord node,
    to scale the tiling. The settings are fairly extreme, 80 U and 220 V, given it had to go across the entire wall. Could that cause it?
    Although you say you have flat UV layouts for the walls can you post a screen shot of your UV layout from UE4? This does appear to be a UV issue though.


    Thank you!

    Tim
    Tim Hobson | Learning Resources | Epic Games
    UE4 Documentation

    Comment


      #3
      I've tried using completely dynamic shadows via LPV, but realized myself that I'd have to increase the cascades. I wanted to, but any values beyond 4 didn't have any return. Increasing the limit in the .ini files, both standard and project, didn't register within the editor - I could input beyond 4, but nothing happens. Maybe I ought to try it in a completely fresh project, perhaps the setting is locked somewhere solely within the project I take issue with.

      As for the UV problem, I have since taken to deleting a few polys from the arching area, though nothing which makes a drastic difference, just about a single edgeloop. The current layout is perfectly flat and will stay that way - there's stonework which follows the curve of the arch, but I'll place separate meshes for that. But that aside, there shouldn't be any warping even so, given that it's a flat UV layout. The right corner area I highlighted in the problem picture was even flatter in that regard, with only quads for polys before import into the editor.
      Attached Files

      Comment


        #4
        Which .ini file did you modify? Should be ConsoleVariables.ini.
        You can also use the commands with the console in-game/editor.
        3.14159265359

        Comment

        Working...
        X