Announcement

Collapse
No announcement yet.

Lock editor FPS for good

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    I can confirm that changing framerate settings in the project affects launched games but NOT play-in-editor

    Leave a comment:


  • replied
    Forgot to mention that I've tried using that, but it doesn't seem to help. In fact looking at it now, it appears as though it adds duplicate entries to the ini file with conflicting values. After setting min desired fps from 35 to 30, DefaultEngine.ini ended up with the following lines:

    Code:
    MinDesiredFrameRate=35.000000
    MinDesiredFrameRate=30.000000
    Editing the file manually afterward seems to fix it, and I can't reproduce it yet. I'll try opening a new project.

    EDIT: Starting with FPS BP in 4.3 displays this behavior for certain, but only on the first change. Subsequent changes won't have an effect. (Also you get a TON of class redirects, but I assume that's intentional.)

    Still haven't found where the other settings in that menu are applied. Smoothed frame rate range isn't being added to my DefaultEngine.ini nor any of the other files in ./Config/ (Or I haven't found it yet, but I've checked relatively thoroughly for any instance of fps and all I get are editor color settings.)
    Last edited by Veovis Muad'dib; 08-12-2014, 03:43 PM.

    Leave a comment:


  • replied
    Have you guys had a look at the framerate settings in Project Settings? See below:

    Attached Files

    Leave a comment:


  • replied
    I too wonder if there's a good way to do this.

    My game suffers visual artefacts for certain particle systems at the targeted 60 FPS when launched which are not present at the native 120FPS it hits in-editor; the ability to cap the framerate in-editor would go a long way toward helping me troubleshoot these problems, without having to re-build and re-launch the game every time I tweak a setting in Cascade.

    Leave a comment:


  • started a topic Lock editor FPS for good

    Lock editor FPS for good

    Using t.MaxFPS 30 in the editor's console, I can limit my framerate for that session. However I'd like to have it default to 30fps every launch. According to this wiki page it should just be a matter of adding to an ini file, but after making the changes they are not reflected in the fps display in editor.

    EDIT: After making the changes and relaunching of course.

    EDIT: It dawns on me that I'm using 4.4 preview right now. Let me go check 4.3.... Yep, doesn't work in 4.3 either. The wiki page listed mentions changes in 4.2 that affect setting the built game's framerate.
    Last edited by Veovis Muad'dib; 08-11-2014, 09:24 PM.
Working...
X