Announcement

Collapse
No announcement yet.

Compiling Shaders Crash

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Compiling Shaders Crash

    Hi guys,

    I'm experiencing a crash when trying to compile more than ~2000 shaders at one time. I can quickly compile around that amount, but anything beyond that number will give me a bluescreen with the report of WHEA_UNCORRECTABLE_ERROR (which is the least helpful error message in the world). This is the only time my computer crashes, and my hardware is relatively new (and powerful), so I can't figure out what the issue is. Sometimes I can compile more than 2000 shaders, but if I try to reach 2500 it will crash 100% of the time. This has been happening since 4.1, and I haven't found any solutions yet on my own. Now that I have a new wave of content coming into one of my projects, I'm sitting here trying to break it into multiple maps so I can try to compile 65k shaders, 2k shaders at a time. I'd really just like a solution that doesn't feel like a band-aid.

    Here's my specs:

    Windows 8.1 Pro 64-bit (6.3, Build 9600)
    Intel Core i7-4790K @ 4.00 Ghz (not overclocked) - http://www.newegg.com/Product/Produc...82E16819117369
    2x8GB Corsair DDR3 1866 RAM - http://www.newegg.com/Product/Produc...82E16820233536
    ASUS Maximus VII Hero motherboard - http://www.newegg.com/Product/Produc...82E16813132125
    NVidia GeForce GTX 680
    The perforce repository + engine is located on a SSD with 90 gigs of space.

    I don't know if anyone else has had this issue, or if someone could at least tell me what might be affected most by shader compilation (CPU?), that'd be helpful.

    My guess:
    I used to have an older CPU model - the Intel Q6600 - that was bought in 2008. When compiling shaders it would also crash around the 2000 mark, but it would also go from ~90 degrees C to ~105 degrees C, then crash. It was old and running very hot, so it needed replaced. I was assuming that was the issue, but this new CPU will go from ~50 degrees C to ~100 degrees C during the time it takes to reach 2000 shaders, then Core Temp starts throwing warnings about it getting very hot right around crash time. I have a new case with 2x240 MM fans and 4x smaller fans, and excellent air flow. My CPU will push all 4 cores to 95% capacity while compiling shaders.

    Am I just overheating my CPU when trying to compile shaders? Is there a software-based solution to try and calm down the CPU while doing this? I'm compiling roughly 2000 shaders per minute, and don't mind at all if I have to compile slower if that means not crashing.

    Thanks in advance!

    Zach

    #2
    Make sure to always post the answerhub link into your forum thread: https://answers.unrealengine.com/que...ers-crash.html

    -run your pc with the "power saver" power setting -> then your PC will be slower and it will probably decrease the temperature
    -close all other programs
    -limit the cpu usage from the ue4 -> I think there are some programs around which can do that (just google it )

    Comment


      #3
      Do you by any chance have large world composition turned on? or is this from opening a demo project (like the effects cave)?

      The only time I have seen that error was when I had more than 1 streaming level, and then trying to build all levels. I was also receiving errors in my level about level bounds not being set, even though they were.

      I have an i5 4670k @ 4.2ghz (with nothing but the default fan currently), and during shader compiles the highest I reach is 50 degrees at 100% CPU load. So I am unsure why is it going that high for you. I can also regularly go well beyond the 2000 shader compile limit, I have not run into any issues yet, and the highest was 4000 or so.

      -- OH, hang on now I remember! --

      I just realized I had this problem before (I will leave the rest above as it may help someone), but that error occurred for me by overclocking too high, it would only happen when there was CPU load though. If you have yours overclocked, turn it down a bit and try again, for me 4.5ghz started causing the issue, when the CPU was used (even just to run google chrome) I would get a BSOD. Hope that solves it for you!

      *EDIT: If you haven't overclocked, reboot and go into your bios settings and ensure all overclocking related items are set to AUTO, then reboot and try again.
      Last edited by DotCam; 08-09-2014, 02:40 PM.
      Free Community Ocean & Sky Project || Join us on Discord! || Trello Roadmap

      Comment

      Working...
      X