Announcement

Collapse
No announcement yet.

Lighting Problem?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Lighting Problem?

    I have a character that has textures and everything for it. Everything looks good in the preview windows. But when i put the mesh into the editor it all gets deformed looking. I have rebuilt lighting,messed with the lighting. Everything i could think of but i cannot figure this out. Im not sure if this is a lighting problem or not. Can someone look at the screenshots below and see if you can figure this out. Please and Thanks.

    How the character should look.

    Click image for larger version

Name:	Normal.png
Views:	1
Size:	108.2 KB
ID:	1137296

    How the character looks ingame/in editor

    Click image for larger version

Name:	Broken.png
Views:	1
Size:	336.3 KB
ID:	1137297

    #2
    For me it looks like a normal map problem -> flip your green channel (you can do that in the material editor with a constant 3 node (1,-1,1) + a multiply + the normal map)

    Comment


      #3
      Originally posted by fighter5347 View Post
      For me it looks like a normal map problem -> flip your green channel (you can do that in the material editor with a constant 3 node (1,-1,1) + a multiply + the normal map)
      I tried that but i get a error when trying to plug in the Constant

      Click image for larger version

Name:	Material.png
Views:	1
Size:	78.1 KB
ID:	1053332

      Comment


        #4
        Plug the constant 3 vector and the texture sample into the multiply -> after that connect the multiply with the normal

        Comment


          #5
          Originally posted by fighter5347 View Post
          Plug the constant 3 vector and the texture sample into the multiply -> after that connect the multiply with the normal
          Thanks that fixed it alot. But its still a little messed up around the rib area is there a way to fix it fully?

          Click image for larger version

Name:	Rib.png
Views:	1
Size:	379.9 KB
ID:	1053348

          Comment


            #6
            Probably it helps when you change the value in the constant 3 vector a little bit. How have you created the normal map?

            Comment


              #7
              Originally posted by fighter5347 View Post
              Probably it helps when you change the value in the constant 3 vector a little bit. How have you created the normal map?
              No i got this character from Fuse. Ive just been animating it.

              Comment


                #8
                You want to fix this problem when you import the texture. If you double click the texture in the editor and open it in the preview window, you can flip the green channel there. It is under the "Texture" heading, but you will need to click the little arrow at the bottom of the category to reveal extra options (including "Flip Green Channel").

                You do not want to correct it in the material because your GPU will be calculating the correct normal every frame for every pixel that uses that texture. It is much more efficient to pre-compute it once on import (or simply correct it in the source image).
                Last edited by CaptainScience; 08-09-2014, 10:14 PM.

                Comment


                  #9
                  Originally posted by CaptainScience View Post
                  You want to fix this problem when you import the texture. If you double click the texture in the editor and open it in the preview window, you can flip the green channel there. It is under the "Texture" heading, but you will need to click the little arrow at the bottom of the category to reveal extra options (including "Flip Green Channel").

                  You do not want to correct it in the material because your GPU will be calculating the correct normal every frame for every pixel that uses that texture. It is much more efficient to pre-compute it once on import (or simply correct it in the source image).
                  Ok i tried this and the box was already checked. So i unchecked it and its still the same.

                  Comment


                    #10
                    Originally posted by Firezown View Post
                    Ok i tried this and the box was already checked. So i unchecked it and its still the same.
                    The only other thing I can think of off the top of my head is to make sure the compression is set to normal map. Normal maps have a special way of being stored in a texture so if you have compression set to a different type, UE4 won't know it's a normal map and will sample it like a regular texture. Normal values can range from -1 to 1 so you need to scale and bias the texture values properly to get the correct values.

                    Also double-check that you aren't accidentally sampling the wrong texture in your material because I would think that inverting the green channel would produce a noticeable difference in pretty much any texture.

                    You can always open the original texture up in Photoshop or GIMP and make adjustments manually.

                    Comment


                      #11
                      Originally posted by CaptainScience View Post
                      The only other thing I can think of off the top of my head is to make sure the compression is set to normal map. Normal maps have a special way of being stored in a texture so if you have compression set to a different type, UE4 won't know it's a normal map and will sample it like a regular texture. Normal values can range from -1 to 1 so you need to scale and bias the texture values properly to get the correct values.

                      Also double-check that you aren't accidentally sampling the wrong texture in your material because I would think that inverting the green channel would produce a noticeable difference in pretty much any texture.

                      You can always open the original texture up in Photoshop or GIMP and make adjustments manually.
                      Ok thanks ill try that. And the one i inverted green channel on was the normal. is that the one i was supposed to invert?

                      Comment


                        #12
                        Yep you had to invert the normal map

                        Comment


                          #13
                          Originally posted by fighter5347 View Post
                          Yep you had to invert the normal map
                          Yeah i inverted it and it did nothing. The only thing that seems to work is what Fighter said to do earlier but it still look a bit off. But its better then it was. If anyone knows how to fix it fully please post.

                          Comment


                            #14
                            Originally posted by Firezown View Post
                            Yeah i inverted it and it did nothing. The only thing that seems to work is what Fighter said to do earlier but it still look a bit off. But its better then it was. If anyone knows how to fix it fully please post.
                            Ok, lets try out something else -> do you still get those spots when you delete your normal map? -> after that we will know if it's probably also a light problem

                            Comment


                              #15
                              Originally posted by fighter5347 View Post
                              Ok, lets try out something else -> do you still get those spots when you delete your normal map? -> after that we will know if it's probably also a light problem
                              When i delete the normal its fine but there is just no detail on it.

                              Comment

                              Working...
                              X