Announcement

Collapse
No announcement yet.

Static Lighting Occlusion Artifact

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Static Lighting Occlusion Artifact

    Using static lights with very close objects somehow leads to occlusion banding effect or something.

    It is how static lighting looks


    It is how dynamic lighting looks and static lighting supposed to look like


    Just to be sure I unchecked Ambient Occlusion, built light with production quality, bumped up lightmap resolution to 256 and even changed indirect intensity to 0.0.

    It is my second UV for lightmap.


    What could possibly cause this issue ?
    Last edited by caner_ozdemir; 08-06-2014, 12:08 PM.
    https://canerozdemirportfolio.wordpress.com

    #2
    Setting "Static Lighting Level Scale" in World Properties lower like 0.1 solves this problem.
    https://canerozdemirportfolio.wordpress.com

    Comment


      #3
      Decreasing Static Lighting Level Scale improves lightmap quality but it also affects build time. You can try scaling up those UV seams since currently there is too much wasted space in the UV layout. Those chamfered edges of the mesh occupy very little space and that is causing the shadow bleeding you are seeing i suppose.
      FREE Lightshow
      FREE VR Drum Kit Project

      FREE Color LUT Collection
      FREE Physics Driven Spacecraft Project
      FREE GTA Style Vehicle Interaction
      Dynamic DoF(Depth of Field)
      Camera Crossfade

      Comment


        #4
        I found a quick way to eliminate this on my scenes. I'm guessing you have overlapping lights? Just disable shadows on all that overlap, except one for each part.

        Comment

        Working...
        X