Announcement

Collapse
No announcement yet.

Leaves losing texture after opacity mask is applied.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Leaves losing texture after opacity mask is applied.

    My workflow-
    Blender, create tree using sapling.
    - convert to mesh
    - select Trunk+branches
    - create "trunk" material
    - load bark texture into material
    - select leaves.
    - Apply leaf texture in same manner.
    - join leaves+trunk into one entitiy.
    - Export FBX
    - import to UNreal
    - Place tree into world to view.
    (textures are showing up on trunk and leaves, yet opacity mask isnt working yet for the leaves)
    - open leaf material.
    - change settings to masked, two sided foliage, and click two sided.
    - preview shows leaves as they should be with mask in tact..
    - Apply new settings to world.
    - Leaves no longer visible.
    What am I doing wrong?
    (UPDATE): It's worth mentioning that if I import the leaves as a separate entity and bluprint the leaves to the trees, I don't have this problem.. however, If i do this, I cant place them with the foliage tool. Any help here would be outstanding.
    Last edited by lucidtransition; 07-29-2017, 01:00 AM.

    #2
    Nobody has an answer to this? really? (0.o)

    Comment


      #3
      Need more info. At least show what the material looks like.

      Comment


        #4
        I figured it out... For future reference to anyone having this problem... The const coordinate was defaulting to zero on the texture .. make sure you set it to 1, and do the same with any normal maps, etc.... Problem solved. Thanks for replying Jonimake. take care. (Edit) I would place "Solved" at the end of the Thread name, but I have no option to rename the thread.
        Last edited by lucidtransition; 07-31-2017, 08:12 PM.

        Comment


          #5
          Originally posted by lucidtransition View Post
          I figured it out... For future reference to anyone having this problem... The const coordinate was defaulting to zero on the texture .. make sure you set it to 1, and do the same with any normal maps, etc.... Problem solved. Thanks for replying Jonimake. take care. (Edit) I would place "Solved" at the end of the Thread name, but I have no option to rename the thread.
          Shouldn't it be 0 though? Do you have 2 UV maps?

          Comment

          Working...
          X