Announcement

Collapse
No announcement yet.

Volumetric Fog feedback thread

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    There seems to be a bug when using world position in a light function in combination with volumetric fog. Notice in the attached images the incorrect masking of the volumetrics. The expected result would be that only the volumetrics below the cube surface are darkened similar to the sides of the cube. The issue is also camera relative, so this masking flies around the scene depending on the camera angle making this combination of features unusable.

    To make matters worse there doesn't seem to be a way of disabling the light function just for the volume fog effect. In my usecase (and I imagine for others as well) I wouldn't need that anyway so it seem like a useful optimization to offer that option.

    Edit: I submitted a bug report with an example project here on answerhub.
    Attached Files
    Last edited by Arnage; 08-15-2019, 06:44 AM.

    Comment


      I didnĀ“t find any discussion about theatrical lighting, sorry if there is some.

      But my question is:
      Is there anyway to make volumetric lights with gobos like in this picture?
      I already try in lightfunction material and it works in objects and surface. but not in the air.



      Click image for larger version

Name:	Gobo1.jpg
Views:	122
Size:	166.3 KB
ID:	1653318

      Comment


        Hello,

        I just start on ue4 and I'm working on my first project, so i want to apply a local volumetric fog, and I already follow the instructions to do it with the ue4.21 version and it worked very well, so now I wanna do this again in the ue4.23 and it doesn't, I don't understand why.

        I made the material, I customize it a little, after that I run it through a particle, set the light and the exponentiel fog and it worked. I do all this once again, I read all the volumetric fog ue4 docs, and idon't what I forget.

        So, it will be welcome if someone can help me to solve this problem.


        My computer run with
        -i7 4770
        -16GbRAM
        -nvidia GeForce GTX 1060 OC

        Thanks for your help!

        Comment


          Originally posted by II_ADN_II View Post

          The problem is that you can use the volumetric fog to simulate sun rays trough the clouds. It works perfectly but only in really small scales. There isnt a reason why this shoudnt work on a real scale since the resolution of the shadows and the volumetric fog still the same. Also the draw distance of 100,000,000 is just as an example in an empty scene, unfortunately it breaks much earlier in a standard game scene with lots of assets.
          Any workarround?
          Check 3d tips! POLY DNA

          Comment


            I have a project with Niagara plugin enabled on UE4.22.3 and I am following this tutorial to build a fog particle system. https://www.youtube.com/watch?time_c...ture=emb_title However, I first tried to create the material and apply it to a Niagara particle system, I've gotten some errors, so I deleted that particle system from content and project and went back to implementing exactly how it's done in video with a regular cascade particle system. However, my material is getting errors related to Niagara still, and it's not rendering properly. I've attached a screenshot of the material function and errors. Anything I'm doing wrong? maybe I should disable Niagara? I'm using it with another particle system that works fine, so I'd rather not...

            UPDATE: I upgraded the project to 4.231 and I get the error:

            [SM5] /Engine/Private/VolumetricFogVoxelization.usf(61,33-110): error X3004: undeclared identifier 'VertexFactoryGetTranslatedPrimitiveVolumeBounds'

            UPDATE 2: I disabled the Niagara plugin and the volumetric material now works... so It's not possible to use volumetric materials with Niagara? Or should I do something different?


            Click image for larger version  Name:	20191202-21_08_54TP_Demo--Unreal-Editor.jpg Views:	0 Size:	580.4 KB ID:	1693593
            Last edited by vbs; 12-03-2019, 03:16 PM.

            Comment

            Working...
            X