Announcement

Collapse
No announcement yet.

planar reflections With illuminated walls

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    planar reflections With illuminated walls

    I'm trying to make a mirror with planar reflections but my walls and floors are appearing super bright. It only disappears when I turn off the "deferred lighting" option but my glow materials do not have texture, how do I solve it?
    image 01
    Click image for larger version

Name:	espelho01.jpg
Views:	1
Size:	197.7 KB
ID:	1216691

    image 02
    Click image for larger version

Name:	espelho02.jpg
Views:	1
Size:	232.1 KB
ID:	1216692

    #2
    Did you build your lighting?

    Comment


      #3
      Originally posted by darthviper107 View Post
      Did you build your lighting?
      yes, This bathroom wall is only 1 object

      Comment


        #4
        I already managed to clean

        Comment


          #5
          I experienced something similar and it looks kinda like planar reflections arent picking up baked shadows for some reason. I have an exterior with a little lake in a valley. The sides of the valley are in shadows and it reflect correctly as long as I am so close to the "walls" that they still get the dynamic shadows from the sun. But when I move away and it fades over to the baked shadows, those are missing from the planar reflection then.
          Check out UNREAL 4 Lighting Academy
          https://forums.unrealengine.com/show...ng-like-that-)

          Comment


            #6
            Originally posted by Daedalus51 View Post
            I experienced something similar and it looks kinda like planar reflections arent picking up baked shadows for some reason. I have an exterior with a little lake in a valley. The sides of the valley are in shadows and it reflect correctly as long as I am so close to the "walls" that they still get the dynamic shadows from the sun. But when I move away and it fades over to the baked shadows, those are missing from the planar reflection then.
            It may be a planar angle setting, what do you think?

            Comment


              #7
              Originally posted by predzao View Post
              It may be a planar angle setting, what do you think?
              Hmmm....good catch, I will have a look at that
              Check out UNREAL 4 Lighting Academy
              https://forums.unrealengine.com/show...ng-like-that-)

              Comment


                #8
                planar reflection

                Originally posted by predzao View Post
                I already managed to clean

                how did you fix this? I'm having the same issue, but deferred lighting does not help.

                Thanks!

                Comment


                  #9
                  Originally posted by lulubru View Post
                  how did you fix this? I'm having the same issue, but deferred lighting does not help.

                  Thanks!
                  The problem is that I was using two directional light

                  Comment


                    #10
                    Planar reflections does not support dynamic shadows for direct light source. Turn cascaded shadows for direct light source to 0.

                    Comment

                    Working...
                    X