Announcement

Collapse
No announcement yet.

Dissable Color Grading and Tone mapper completly or...!?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Dissable Color Grading and Tone mapper completly or...!?

    Heya! so yeah, I'm working on a 2.5D Pixel art styled game and the textures are way to dark, and are washed out.
    I can not for the life of me get the result I'm looking for which is to match the textures before they are rendered in game. ( I have my texture plugged into emissive of the material, so that I can get the unlit effect which is needed so that I could tweak the tone mapper and color grading without worrying about scene lighting effecting results, but the results just are not close enough.

    I'm running V4.15.1. and Inside the GlobalPostProcessVolume, i've been messing around with the tone mapper and color grading options for weeks now, going threw tutorial after tutorial looking for a way to tweak them or disable them completely. The Unlit Rendering mode seems to disable the tone mapper and post process effects for the result I'm after, but I don't think it can be used at game runtime, even if it could be , the post process is disabled completely, I still need post process for running material effects on screen though.

    Please if someone has some settings that they could share, it would really help out so much !
    Last edited by Tuxmask75; 03-28-2017, 09:20 AM.

    #2
    I found that there is a way to disable Tonemapper in the viewport of the editor, however It does not take effect when you launch the game.
    Go to: Show, than Post Processing, and than uncheck Tonemapper.

    If it can be done for the editor side of things, than there should be a way to disable it during game right?! But how?
    Last edited by Tuxmask75; 03-29-2017, 11:25 AM.

    Comment


      #3
      Ok so I found a setting for tone mapper in EditorPerProjectUserSettings.ini located in D:\Unreal Projects\Project_AXSX\Saved\Config\Windows

      I changed both to False like so:
      PostProcessVolume.Color Grading=False
      PostProcessVolume.Tonemapper= False
      Yet nothing happens ! Is this because its in the saved folder?!( does the engine even use stuff in the saved folder?)
      Is there another EditorPerProjectUserSettings.ini file in another location? If so, I searched all over and could not find it.

      Right now this is the last visual hurdle holding my project back from perfection. I'm sure other people would love to know how to do this also. I've found a lot of topics where many people have the same issues. but there does not seem to be any solution. If the tone mapper can be disabled in the editor so easily, there must be a way to do so during gameplay.

      Comment


        #4
        OK so yeah! We now have a conclusion to the question, although I wonder if there is something we can just add to the ini file somewhere.

        With the help of a good Discord friend, We've got one way to disable the tonemapping in game using blueprints and the console command ShowFlag.Tonemapper 0

        Anyways this is for you guys who like me are not so familiar with all the aspects of unreal 4 yet.
        First I opened the level blueprint than added a Event BeginPlay and Execute Console Command set of nods.
        And in the command nod, added ShowFlag.Tonemapper 0 than connected them. Holy **** dude !
        So yeah when you execute this using blueprints , be warned that the tonemapper will also disable in the level editor as well,
        and to reverse it just change the 0 to 1 if you need. Also another command I found is Show Tonemapper. but that toggles the tone mapper on and off so every time you play the game it will toggle lol
        another note ! if you go to show>Post Processing and toggle the check box for tone mapping for the Editor viewport than that check box no longer works until ShowFlag.Tonemapper 1 ( is set to 1).

        I think that about covers it ! But yeah, again, I wonder does anyone know how to do this for an INI file?

        Click image for larger version

Name:	tonemapper.PNG
Views:	1
Size:	55.6 KB
ID:	1125713

        P.S. it would really help to get some answers to my other questions above in regards to the save folder items in weather or not they are used or are just backups....
        Last edited by Tuxmask75; 03-29-2017, 11:26 AM.

        Comment


          #5
          thank u soooooooooooooooooooooooooooooooooo much!!!

          Comment


            #6
            Your so very welcome ! Wish people on this forum were a bit more helpful though! I usually always end up salving my own problems after weeks and sometimes months of searching for the solution, For me It's really a next to impossible to get help around here. so that's why I always post the solution if I find it, so that maybe someone else who really needs it can find it if they search.
            I'm very glad you found the answer you were looking for!

            Comment


              #7
              Thanks that was my problem, but it broke the "bloom" effect on glow material
              Last edited by skeleton60; 08-20-2017, 05:52 AM.

              Comment


                #8
                Originally posted by Tuxmask75 View Post
                OK so yeah! We now have a conclusion to the question, although I wonder if there is something we can just add to the ini file somewhere.

                With the help of a good Discord friend, We've got one way to disable the tonemapping in game using blueprints and the console command ShowFlag.Tonemapper 0

                Anyways this is for you guys who like me are not so familiar with all the aspects of unreal 4 yet.
                First I opened the level blueprint than added a Event BeginPlay and Execute Console Command set of nods.
                And in the command nod, added ShowFlag.Tonemapper 0 than connected them. Holy **** dude !
                So yeah when you execute this using blueprints , be warned that the tonemapper will also disable in the level editor as well,
                and to reverse it just change the 0 to 1 if you need. Also another command I found is Show Tonemapper. but that toggles the tone mapper on and off so every time you play the game it will toggle lol
                another note ! if you go to show>Post Processing and toggle the check box for tone mapping for the Editor viewport than that check box no longer works until ShowFlag.Tonemapper 1 ( is set to 1).

                I think that about covers it ! But yeah, again, I wonder does anyone know how to do this for an INI file?

                [ATTACH=CONFIG]135193[/ATTACH]

                P.S. it would really help to get some answers to my other questions above in regards to the save folder items in weather or not they are used or are just backups....
                Thank you so much for this, I'm also in the position where I desperately needed this solution but I don't know how blueprints work, so simple now that you've shown us!
                www.artstation.com/kurtmitchell

                Comment


                  #9
                  man, this sucks, it's clearly a bug, all paper2D example dont talk about this problem and dont need to disable the tone mapper which is an essential feature of the rendering pipeline

                  Comment


                    #10
                    Sigh, So yeah when packaging a game,,,,,, using the
                    ShowFlag.Tonemapper 0 command does not work when packaging a game...…Very disappointed that this is even an issue for my game.
                    Last edited by Tuxmask75; 09-20-2018, 11:12 AM.

                    Comment


                      #11
                      4-Kay Man! (Okay Man!)
                      I figured something out which works in a Packaged build of the game. (wish it were more simple than this, but ehhh)
                      Check this **** out ! ! !

                      r.TonemapperGamma 0
                      r.TonemapperFilm 0
                      r.Tonemapper.Quality 0

                      Use all 3 Instead of ShowFlag.Tonemapper 0. because they work in Packaged build of game.

                      my test BP:
                      Attached Files

                      Comment


                        #12
                        You could just make a Post-Process Material set to "Replace Tonemapper" if you want to use something else(Hejl, Reinhard, etc.) You need some sort of tonemapping from the scene-referred linear down to your display(sRGB/Rec709, HDR/Rec2021), so you could do a simple Power function on the PostProcessInput and that's it.

                        I don't know if the CVAR does this, but replacing the tonemapper will also disable all color grading, so you'd have to rebuild it in the Post-Process Material.
                        Lighting Artist II @ Crystal Dynamics
                        Former Lighting Artist @ Obsidian Entertainment
                        ArtStation

                        Comment


                          #13
                          Changing the console variables is not good. If you'll use console "exec" to set ShowFlags.Tonemapper to 0 or 1, then it will be either enabled or disabled, and viewport's checkbox under "Show" button (Postprocessing / Tonemapper) won't work unless you'll set it back to value 2 (default state). Also, fully disabling tonemapper will stop bloom etc effects working. Another case is if you'll try the game in PIE, and want to restore console variable back to value 2 when PIE session ends - you can't catch any event of shutting down a game in Blueprint, no events will be generated. In other words, changing console variable to 0 or 1 during PIE will break tonemapper checkbox functionality.

                          I came another way to solve bad (or "unwanted") picture contrast when tonemapper is enabled. I tried to tune tonemapper to get picture as much closer to disabled tonemapper as possible. I think I've found a way of setting tonemapper to keep it working, but still with having picture which is closer to disabled tonemapper appearance. Here are my results.

                          Original picture, with default tonemapper:

                          Click image for larger version  Name:	img1defaulttonemap.png Views:	1 Size:	485.2 KB ID:	1556042


                          Then with tonemapper disabled:

                          Click image for larger version  Name:	img2notonemap.png Views:	1 Size:	413.3 KB ID:	1556043

                          And finally, adjusted tonemapper:

                          Click image for larger version  Name:	img3adjustedtonemap.png Views:	1 Size:	483.1 KB ID:	1556044

                          You may see that default tonemapper make everything grey-ish - clouds, reflections. Bright areas are darker, and dark areas are almost black. Adjusted tonemapper makes picture much closer to no-tonemapper appearance, and still have bloom etc working (look at sun). To adjust tonemapper settings, select PostProcessVolume in your scene, reset all settings to default values, and change the following ones:

                          ColorGrading
                          • Contrast = 1.57
                          • Gamma = 0.96
                          Tonemapper
                          • Toe = 0.0
                          • Shoulder = 1.0
                          Lens / Auto Exposure
                          • MinBrightness = 0.4
                          • MaxBrightness = 0.8
                          Pictures with settings:

                          Click image for larger version  Name:	img4settings1.png Views:	1 Size:	77.1 KB ID:	1556046Click image for larger version  Name:	img4settings2.png Views:	1 Size:	63.7 KB ID:	1556045

                          I hope this will help to someone.
                          Last edited by Gildor; 12-17-2018, 03:58 PM.

                          Comment

                          Working...
                          X