Announcement

Collapse
No announcement yet.

Lightmass: multi-bounced sky lighting

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Forget about CPU Lightmass and better switch here for GPU Lightmass:
    https://forums.unrealengine.com/deve...s-gpulightmass
    https://www.artstation.com/tomaszmuszynski

    Comment


      Originally posted by Makigirl View Post
      Hi!

      Your settings are very high so could be normal... depends on the size of your scene... lightmap reolutions...
      ...maybe you could check in swarm if anything is happening!
      Originally posted by rosegoldslugs View Post
      10 Sky Light bounces is a little extreme and is likely where your time baking has been spent. It is non-distributable, and I believe done on a single core, and scales exponentially with each bounce you set. Sky lighting and emissives are generally not the brightest thing in your scene, so naturally their bounces are less noticeable.
      Hi

      With your help, I have now built it faster. Thank you very much!

      But now I have a problem with CPU because I can't make seems quality as GPU, do you have any suggestion on how i can improve this?



      Last edited by Fabian.le; 11-18-2019, 04:53 PM.

      Comment


        Originally posted by Fabian.le View Post
        But now I have a problem with CPU because I can't make seems quality as GPU, do you have any suggestion on how i can improve this?
        You can waste time tweaking CPU lightmass to get slightly better results with significantly longer rendertime, but still quality which is quite inferior to GPU lightmass. CPU lightmass uses irradiance caching and photon mapping while GPU lightmass uses path tracing. There is a reason no commercial renderers these days use ancient techniques like IC and Photon Mapping, at least not by default. It produces inferior results and takes longer. Unfortunately, CPU lightmass is now literally almost decade behind technology level adequate to today.
        https://www.artstation.com/artist/rawalanche

        Comment


          Those "light bleeds" are usually coming form "defected" meshes: usually normals are flipped... you can try to uncheck use "tangents and binormals" in the mesh's properties or if it's 3ds max use an xfrom modifier on those meshes and re-import them, it should solve that problem!

          Comment

          Working...
          X