Announcement

Collapse
No announcement yet.

4.15 Lightmap Bug?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    4.15 Lightmap Bug?

    We just moved our game from 4.14 to 4.15, excited to get our hands on the new features.

    Out of many hundreds of static meshes, a few have suddenly incurred lightmap overlap issues.

    Click image for larger version

Name:	BurnedLookingBales.JPG
Views:	1
Size:	444.6 KB
ID:	1211632

    Meet our Haybale2, (Haybale1 is fine -.-)
    The lighting now looks like it's been incinerated. The outside shades darker, and the inside, lighter.

    Here's the Anatomy of the Bales, for reference:

    Click image for larger version

Name:	MayaMesh.JPG
Views:	1
Size:	216.6 KB
ID:	1211633

    Here's Unreals little 'Auto-Shadowmap'

    Click image for larger version

Name:	Channel2.JPG
Views:	1
Size:	271.2 KB
ID:	1211634

    Here's my, more conservative, Shadowmap

    Click image for larger version

Name:	Channel1.JPG
Views:	1
Size:	271.8 KB
ID:	1211635

    Nothing is even close to overlapping, and is padded to hell and back. But when we build lighting, suddenly!

    Click image for larger version

Name:	LightmapOverlap.JPG
Views:	1
Size:	122.1 KB
ID:	1211636

    Unreal's map: 3.3% overlap
    My map: 1% overlap
    The bale looking burned to hell: Priceless


    At this rate, we may roll perforce back to 4.14! What's going wrong?

    #2
    Exactly the same issues, on 4.104 we had no lightmap problems and on 4.15 suddenly some object are overlapping. Anyone found a solution?
    Proud member of iNFINITE Production - VR and hi-tech development studio (sometimes) available for hire.

    Comment


      #3
      Same issue here as well. 4.14 was fine, no uv overlap. Moved to 4.15 and a couple things (not everything) are shooting back uv overlap errors now. I can't seem to find any logical reason it would have a problem after looking at the lightmaps. It's definitely causing lighting errors on meshes though. Super mysterious. It's either a g..g...ghost, or I clearly don't know as much about lightmaps as I thought I did... Any help would be really appreciated!

      Comment


        #4
        It seems that they deleted the ability to share lighmap between different LOD (at least it's the most logical reason i have found for this), so now the engine build some lightmaps for each lod instead of using the lighmap from LOD0, and it results in these overlaps issues, and in some cases some really bigger build times! (and this last point is a real problem for me cause it takes more than 2x or 3x time to build lighting in my game than 4.14) i really hope they will reverse this change

        Comment


          #5
          Originally posted by Nicobass View Post
          It seems that they deleted the ability to share lighmap between different LOD (at least it's the most logical reason i have found for this), so now the engine build some lightmaps for each lod instead of using the lighmap from LOD0, and it results in these overlaps issues, and in some cases some really bigger build times! (and this last point is a real problem for me cause it takes more than 2x or 3x time to build lighting in my game than 4.14) i really hope they will reverse this change
          This 100% fixed it. I removed the LODs and it just started working again! Thank you so much, I've been trying to figure it out for two days now. I'm still not 100% sure why it's doing what it's doing (best I can tell, it was being reduced too hard by the autolod), but I can monkey my way back to no overlap problems now. You're the hero we need!

          Comment

          Working...
          X