Announcement

Collapse
No announcement yet.

Emissive material does not glow

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Emissive material does not glow

    Hello,

    I was following an 4.10 UE4 lightsaber tutorial, in which the person creates a glow effect around a material.
    So in 4.10 when you give a material emissive output, you get a glow around the material,

    but in 4.14 you dont. Something must have changed in between these versions.
    I migrated the material with glow effect from 4.10 to 4.14 and it stopped glowing.

    I can't think of any reasons why this is, so I my last option is to ask here,

    thanks for any input!

    #2
    It might be that bloom is turned off. Check your post process volume and play around with the bloom intensity value
    My Porfolio

    Comment


      #3
      Thanks for the reply, So I'm guessing you need Post Process Volume and bloom enabled for the material?
      Ahh, then I might understand how the effect works, thanks

      Comment


        #4
        I usually get glow effect even without bloom.
        Have you tried to increase the emmisive input?

        Comment


          #5
          As long as you have the proper node setup, you should be fine. Bloom is helpful, but I suggest not to over do it!
          Here is a picture of what helped me ages ago when I went to do emissive materials, and I worked from there. Hopefully it'll be beneficial to you.
          Click image for larger version

Name:	Emissive_21.jpg
Views:	3
Size:	61.0 KB
ID:	1123045

          Comment


            #6
            Hi, I'm having an issue that is related to emissive material glow. When I put together a material as [MENTION=28569]NicolasKruzel[/MENTION] has, the resulting material is bright white with colored glow around the edges, instead of a fully color saturated glow as shown in his image.

            Click image for larger version

Name:	unreal_glow_attempt_01.jpg
Views:	1
Size:	186.8 KB
ID:	1126619

            I also made another attempt at a glow material following this video, and the result was similar.

            Click image for larger version

Name:	unreal_glow_attempt_02.jpg
Views:	1
Size:	210.8 KB
ID:	1126620

            Anyone have any ideas as to how I can achieve a nice saturated glowing color?

            Comment


              #7
              Originally posted by Golden Yak View Post
              Hi, I'm having an issue that is related to emissive material glow. When I put together a material as [MENTION=28569]NicolasKruzel[/MENTION] has, the resulting material is bright white with colored glow around the edges, instead of a fully color saturated glow as shown in his image.

              [ATTACH=CONFIG]137698[/ATTACH]

              I also made another attempt at a glow material following this video, and the result was similar.

              [ATTACH=CONFIG]137699[/ATTACH]

              Anyone have any ideas as to how I can achieve a nice saturated glowing color?
              This looks like the changes from the new tone mapper. The image above yours likely came before the change to the way emissives operate was made.


              Project Reverie Game | SEJonF.com | Twitter | ArtStation | WIP | UE4 SciFi Assets - Season 1 & Season 2 Discount Bundles Free Asset Demo | Ice Shader

              Comment


                #8
                turn on bloom from p.p. and very important from the project settings

                Comment


                  #9
                  Originally posted by Golden Yak View Post
                  Hi, I'm having an issue that is related to emissive material glow. When I put together a material as [MENTION=28569]NicolasKruzel[/MENTION] has, the resulting material is bright white with colored glow around the edges, instead of a fully color saturated glow as shown in his image.

                  [ATTACH=CONFIG]137698[/ATTACH]

                  I also made another attempt at a glow material following this video, and the result was similar.

                  [ATTACH=CONFIG]137699[/ATTACH]

                  Anyone have any ideas as to how I can achieve a nice saturated glowing color?
                  Since no one gave the correct (and SIMPLE) answer, I will for posterity and anyone who is learning: (I am trying to 'Tidy Up' around here!)
                  To get the full Saturated glow (Like NEON) effect, you need to make it an 'UNLIT' material
                  (it is it's own light!)

                  Click the material creation graph grid-background, then in left panel, go to the Material Drop down,change 'Shading Model' to 'UNLIT' ('default Lit' makes the material take on light as is happening to you...) UNLIT (un-intuitively) lets it 'glow' fully from the internal material expression with no external light diluting (diffusing?) the effect. That should work.
                  Last edited by NextWorldVR; 02-10-2019, 09:53 AM.

                  Comment


                    #10
                    Originally posted by NextWorldVR View Post

                    Since no one gave the correct (and SIMPLE) answer, I will for posterity and anyone who is learning: (I am trying to 'Tidy Up' around here!)
                    To get the full Saturated glow (Like NEON) effect, you need to make it an 'UNLIT' material
                    (it is it's own light!)

                    Click the material creation graph grid-background, then in left panel, go to the Material Drop down,change 'Shading Model' to 'UNLIT' ('default Lit' makes the material take on light as is happening to you...) UNLIT (un-intuitively) lets it 'glow' fully from the internal material expression with no external light diluting (diffusing?) the effect. That should work.
                    The emissive input works the same way whether the material is unlit or not. You'll get a glow effect as long as you have Bloom enabled in the default Project Settings or in a Post-Process Volume. Otherwise, if you go above 1 without bloom, the color becomes desaturated and you get the white core without a colored glow.

                    I don't remember which default scalability setting knocks out Post-Process effects like Bloom, but always make sure you're on Epic at least if you can handle it. The engine will default to lowering the scalability settings if your engine hangs for a certain period of time and you ignore the pop-up asking if you want to change it. Kind of annoying, but you can disable that too.
                    Last edited by rosegoldslugs; 02-11-2019, 11:10 PM.
                    Lighting Artist II @ Crystal Dynamics
                    ArtStation
                    Twitter

                    Comment


                      #11
                      Originally posted by rosegoldslugs View Post

                      The emissive input works the same way whether the material is unlit or not. You could even ignore the emissive input and multiply your Base Color to be >1 and you'll get a glow effect as long as you have Bloom enabled in the default Project Settings or in a Post-Process Volume. Otherwise, if you go above 1 without bloom, the color becomes desaturated and you get the white core without a colored glow.

                      I don't remember which default scalability setting knocks out Post-Process effects like Bloom, but always make sure you're on Epic at least if you can handle it. The engine will default to lowering the scalability settings if your engine hangs for a certain period of time and you ignore the pop-up asking if you want to change it. Kind of annoying, but you can disable that too.
                      Base color is clamped to 1.

                      Comment


                        #12
                        Originally posted by Kalle_H View Post

                        Base color is clamped to 1.
                        Good call. I'm not even sure when that change went in, since I still use the emissive input separately. Maybe I'm remembering UDK... anyway, I've updated my post.
                        Lighting Artist II @ Crystal Dynamics
                        ArtStation
                        Twitter

                        Comment

                        Working...
                        X