Announcement

Collapse
No announcement yet.

How can I get my FBX character less polygonal?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How can I get my FBX character less polygonal?

    Hello All,

    When I import my FBX character to UE4 (version 4.14.3) The character looks smooth and really good as I expected.
    So I export additional FBX Animation files so I can add to the character, but whenever I do this I have a weird error like I got in my earlier thread CLICK HERE TO SEE (I just found out that this is why it happens).

    So, I tried the 2nd option: Export the Character and The animation as 1 FBX.
    Everything works, the character plays the animation but I have a different issue now:

    The Character looks low poly, very polygonal and not smooth when I imported it as a None-Animation FBX.

    Is there a way I can make my character look smooth again without any complex steps?
    or is it impossible on the current UE4 version? I would love to get some help and solve this issue...

    I tried to bake lights on a simple scene... I still get very weird results, Also the screenshots taken from the FBX viewer not the actual scene, I just double clicked the fresh imported FBX files to view them so I guess it's not about baking lights... but I'm a noob what do I know.


    Just to be clear I'm still a noob to UE4 so I hope you can direct me to a tutorial or explain step-by-step.
    Sorry about my bad English and thank you for your patience.

    Click image for larger version

Name:	UE4_FBX_not_smooth.jpg
Views:	1
Size:	523.2 KB
ID:	1209059
    ░[CPU]: Intel Core i7-4770K 3.50 GHz ░[GPU]: EVGA GTX 980 4GB GDDR5 SC ░[RAM]: 32GB ░[OS]: Windows 7 Ultimate 64bit

    #2
    Not sure what 3D package you used, but in Maya for example you can select all the edges you want 'smooth' and Shift+Right Click > Soften/Harden Edges > Soften Edges. That'll help a good amount with the issue you are having.

    Comment


      #3
      I have the exact same problem with my skeletal meshes. I can see the facets, even though they have the same smoothing group assigned.

      Comment


        #4
        The software I used in this case was 3DXchange and it's already smoothed in there.
        My main 3D software is Blender I had the same issues even when I smooth my objects before export.

        I also tried different FBX export options for the smooth... but no luck so far.

        The weird thing is, that the head looks "almost" smooth (not as smooth as the original) but the shoulders and the chest are very flatten.
        Last edited by Alon Dan; 02-07-2017, 10:38 AM.
        ░[CPU]: Intel Core i7-4770K 3.50 GHz ░[GPU]: EVGA GTX 980 4GB GDDR5 SC ░[RAM]: 32GB ░[OS]: Windows 7 Ultimate 64bit

        Comment


          #5
          Have you tried putting the animation in the actual level and looking at it in the viewport? There's a bug in 4.13 and 4.14 where the persona view is faceted because of the directional light settings there. It should be fixed for 4.15.
          Reference: https://issues.unrealengine.com/issue/UE-37188

          Comment


            #6
            Yes, I did and it looks exactly like in the animation preview window / mesh preview.

            I even made a new level as clean as possible with the default map, and baked all the lights... nope, I have no idea what I am doing wrong.

            Maybe this is something that will get fixed later, or maybe some other people already ran into this and know the answer, it will be very helpful.
            Thanks ahead.
            ░[CPU]: Intel Core i7-4770K 3.50 GHz ░[GPU]: EVGA GTX 980 4GB GDDR5 SC ░[RAM]: 32GB ░[OS]: Windows 7 Ultimate 64bit

            Comment


              #7
              It goes away if you check self shadow only on the mesh. Also seems to be gone in preview 4.15.
              Character Customizer

              Comment


                #8
                Actually nvm it's not fixed in 4.15
                Character Customizer

                Comment


                  #9
                  Looks like the issue is that your normal map needs to be set to use normal map compression

                  Comment

                  Working...
                  X