Announcement

Collapse
No announcement yet.

Issue with Distant Field Shadows

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Issue with Distant Field Shadows

    Hey everyone.

    Currently trying to get Distant Field Shadows working. No matter what i do the DFS's only extent a few feet from the Cascaded shadows. any ideas?

    DFS's disabled
    Click image for larger version

Name:	b7571809ebd9a743a7b860ebe087c7d4.jpg
Views:	1
Size:	581.1 KB
ID:	1208359

    DFS's enabled
    Click image for larger version

Name:	8ffa43c79ed926571859b1763e4e26e7.jpg
Views:	1
Size:	577.7 KB
ID:	1208360

    Settings
    Click image for larger version

Name:	4bc2abb014f5ffe73108c673db747b22.png
Views:	1
Size:	22.5 KB
ID:	1208361

    #2
    I think what's happening is the trees don't have a distance field representation. Check in Show->Visualize->MeshDistanceFields. Only things present in there can cast a shadow with RTDF shadows. Foliage defaults to not affecting distance fields because having grass represented can really kill performance. Enable 'Affect Distance Field Lighting' on the tree foliage type.

    Comment


      #3
      Alright, i enabled MeshDistanceFields in the Visualize tab, i had already enabled it on the foliage types i wanted. Still no shadows and its throwing this error, "Distant Field AO is disabled through scalability" which i'm assuming refers to the engine scalability settings, everything is on epic in there. Am i missing something?

      Comment


        #4
        Bump.

        Anyone?

        Comment


          #5
          Originally posted by jerry4222 View Post
          Alright, i enabled MeshDistanceFields in the Visualize tab, i had already enabled it on the foliage types i wanted. Still no shadows and its throwing this error, "Distant Field AO is disabled through scalability" which i'm assuming refers to the engine scalability settings, everything is on epic in there. Am i missing something?
          Daniel said you should enable Show->Visualize->MeshDistanceFields to see if the trees do have a correct distance field represetation. Once that is enabled you should see a black/white view. Post a screenshot of that here. If there is no white, then there is no distance field.

          Based on your screenshot, I would say there is no distance field. I don't know if its a bug, but I've noticed that once you enable distance field shadows, the regular CSM shadow distance is somehow modified a bit, that's why you probably see that the shadow distance is slightly more once you enabled it, even though there are no distance fields in your scene.
          Easy to use UMG Mini Map on the UE4 Marketplace.
          Forum thread: https://forums.unrealengine.com/show...-Plug-and-Play

          Comment


            #6
            I do not get a black and white view, but im assuming thats related to the error its throwing.

            Heres with Visulize MeshDistanceFields enabled. Click image for larger version

Name:	436523350bce61e10db3c35598854914.jpg
Views:	1
Size:	951.5 KB
ID:	1122199

            Comment


              #7
              Make your Engine Scalability Settings a bit higher to see them

              Comment


                #8
                If you are using foliage assets, make sure that "affect distance field lighting" is enable in the foliage options.
                https://www.artstation.com/klass

                Comment

                Working...
                X