Announcement

Collapse
No announcement yet.

Modular Environment Seams

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Modular Environment Seams

    Hi,

    I have been toying with the normal maps on these models and have finally got them matching up fairly well, but now I've gone to test out some lighting on them and each piece seems to show off its edges with each increment of light level.

    Click image for larger version

Name:	2017-01-19 14_04_56-Raptured_Prototype - Unreal Editor.png
Views:	1
Size:	894.1 KB
ID:	1207842

    Any idea how I might remedy this?

    Thanks,
    Ollie

    #2
    You need to change how you construct the environment, due to how the lighting system works, each mesh gets processed individually and some of the settings that improve rendering speed will cause a slight difference in lighting for each mesh. To avoid this, try to make a surface like those out of a single mesh rather than multiple meshes. You can actually just scale a wall section to the proper size but even making a unique mesh that's the size you want is a better method. Using multiple meshes is not as good for performance since it increases the number of draw calls and the visible polygon count and since those meshes are so simple it doesn't save that much in terms of memory using instancing.

    Here's some more information: https://wiki.unrealengine.com/Lighti...irect_Lighting

    Comment


      #3
      Ok thanks for that I'll re-think my meshes.

      Cheers,
      Ollie

      Comment


        #4
        You can also try to use the Actor Merge functionality in UE to merge those modular meshes to one room mesh. Rebuild lighting after that.
        Works pretty good for us.

        Comment


          #5
          this talk about the same exact issue you have

          https://www.youtube.com/watch?v=W6FKOW5Mmnk

          Comment

          Working...
          X