Announcement

Collapse
No announcement yet.

How to make simple shader

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How to make simple shader

    I copied some existing rock bumped material but i don't see any normal map effect on my model ?
    It is something specific to do with normal map texture ?
    Attached Files
    Last edited by Galeon; 07-12-2014, 02:16 PM.

    #2
    Looks good to me. But i can't see everything that's goin on there. Can you provide a screen of the model in a scene? Or even the material preview.
    Some thing to check as well: Is the texture set to TC_Normalmap in the texture properties and in the shader? That might cause unexpected shading.

    Comment


      #3
      Inverse green channel of your normal map, probably it will work after that: https://www.google.at/search?q=udk+i...KYyU_AacyoGgBQ

      Comment


        #4
        I switched from color mode to normal map under "Details" panel when i select the normal map texture, but when i do that the textureSampler becomes black with an error saying it should be color and not normal map.
        I don't know how to convert textureSampler with "normal map" setting to make it work to output normal map channel ?

        Attached Files
        Last edited by Galeon; 07-12-2014, 03:38 PM.

        Comment


          #5
          Just go into the texture settings (double click onto the texture) and there you also have to change the mode to normal

          Comment


            #6
            Galeon> In a way what you've got there is good news, as it looks like your texture wasn't setup as a Normal Map. Like Fighter5347 said, you'll also need to set the texture asset to Normal by double-clicking on it in the content browser to bring up the properties. then, look for Compression Settings in the details.

            Comment


              #7
              I dind't know it was under compression method on texture properties that you specify the normal map mode, it works and looks great.

              For specularity, i imported a specular texture and tried color mode and greyscale for shader and compression settings, branched to specular channel, but nothing specular show in 3D view and in shader view ?

              Click image for larger version

Name:	UE45.jpg
Views:	1
Size:	82.4 KB
ID:	1052569
              Last edited by Galeon; 07-12-2014, 07:56 PM.

              Comment


                #8
                By default, Specular term is a bit depreciated for full PBR correctness, replaced by the roughness. The theory is that if the surface needs to look less specular, it's because it's rougher. For example, concrete or dusty ground is very low shinyness or specularity because it's so rough.

                Also, the Specular term in UE4 is a scalar value, not an RGB value (It's basically clamped 0.0 - 1.0). the specular color is determined by the base color and the metalness: The more metalness, the more the specular/reflection is tinted by the base color.

                Give this a try: You can leave your specular texture as a simple color compression. This is the most efficient. Then, invert it using a One Minus node, or my favorite, send it to the alpha of a Lerp node and set the A to 1 and the B to 0 (Basically Inverting it), then you can play witht he values very easily within the shader or an instance. Here's some shaders I did like that: http://www.tomshannon3d.com/2014/07/...materials.html

                Comment

                Working...
                X