Announcement

Collapse
No announcement yet.

Problems with SSS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Problems with SSS

    Hey all,

    This is my first post and i'm a UE4 Virgin so please be gentle

    I'm trying to work out a material for skin and the problem i'm having it it doesn't appear to me that the SSS shader is working properly. My understanding is that Opacity should adjust the "thickness" of the material, but with a SSS material there should always be some actual subsurface scattering happening as long as there is some light. The problem i'm seeing is that regardless of my Opacity setting, I only get scattering happening in areas of intense light, and the Opacity setting really only seems to affect the threshold for that effect to happen, not the intensity of the effect itself.

    Here are some screenshots. Three are in a bright light area, and three in a darker area. In the darker area there is no SSS happening, at all, regardless of Opacity setting. In the bright area, changing the Opacity changes which areas of the skin get the SS affect applied, but the result of the affect is the same, there is no variation to it. Also the areas not being affect never change.

    tl;dr my results are showing that the SS effect is either ON or OFF, with no variation to it. It also seems to only happen in areas of extreme light.

    Imgur Album: http://imgur.com/a/p1NcE

    #2
    How did you set the material and what did you choose for lighting model? Current SSS shading isnt perfect but it isnt this bad either(the last 3 screenshots.)
    FREE VR Drum Kit Project
    FREE Color LUT Collection
    FREE Physics Driven Spacecraft Project
    FREE GTA Style Vehicle Interaction
    Dynamic DoF(Depth of Field)
    Camera Crossfade

    Comment


      #3
      Originally posted by Jacky View Post
      How did you set the material and what did you choose for lighting model? Current SSS shading isnt perfect but it isnt this bad either(the last 3 screenshots.)
      For the lighting model i've been bouncing back and forth between SSS and Preintegrated Skin, but not seeing any real difference between them. I need to double check what it was set at for this screenshot. I'll also get a shot of my Material Graph for you. Be a little bit as I wandered out to forage for food.

      EDIT: I have a lot of work and tweaking left to do, so please don't look at the material as a whole. Its not even close to being done (For example right now i'm using constant values instead of maps). I'm more focusing on why the subscattering effect doesn't seem to be doing what i'd expect it to.

      Comment


        #4
        Originally posted by Jacky View Post
        How did you set the material and what did you choose for lighting model? Current SSS shading isnt perfect but it isnt this bad either(the last 3 screenshots.)
        I have added a screenshot of my material graph to the album. I've also verified that my lighting model is indeed set to Subsurface.

        Comment


          #5
          I just noticed, i think the reason why it is going nuts in the last 3 screenshots is because of those additional spotlights. Try it in a scene with a single directional light and you should get reasonable scattering like this:

          Click image for larger version

Name:	SSS1.JPG
Views:	1
Size:	38.7 KB
ID:	1052571

          Click image for larger version

Name:	SSS3.JPG
Views:	1
Size:	11.6 KB
ID:	1052572

          Here my material setup is pretty much like yours, only opacity is set to 0,1 and lighting model is preintegrated skin.
          FREE VR Drum Kit Project
          FREE Color LUT Collection
          FREE Physics Driven Spacecraft Project
          FREE GTA Style Vehicle Interaction
          Dynamic DoF(Depth of Field)
          Camera Crossfade

          Comment


            #6
            Originally posted by Jacky View Post
            I just noticed, i think the reason why it is going nuts in the last 3 screenshots is because of those additional spotlights. Try it in a scene with a single directional light and you should get reasonable scattering like this:

            [ATTACH=CONFIG]6649[/ATTACH]

            [ATTACH=CONFIG]6650[/ATTACH]

            Here my material setup is pretty much like yours, only opacity is set to 0,1 and lighting model is preintegrated skin.
            Unfortunately lighting with only one light is a no go for my application. I absolutely must use multiple lights, even if the end result isn't as good looking skin

            My main concern right now is the fact that outside of direct light I get zero SSS going on. That means if I follow the "standard" route of making the skin greyish, and then the subsurface pinkish, then I end up with grey skin in most all places

            Comment


              #7
              Yeah, it seems like there are some limitations with point lights for now, unfortunately. :\
              You may want to try out MatCaps to fake it until SSS gets better.

              Edit: There is another SSS actually, called screen space SSS or something, but i dont know its advantages and the command to enable it. I'll post here if i find out.
              Last edited by Jacky; 07-13-2014, 04:35 PM.
              FREE VR Drum Kit Project
              FREE Color LUT Collection
              FREE Physics Driven Spacecraft Project
              FREE GTA Style Vehicle Interaction
              Dynamic DoF(Depth of Field)
              Camera Crossfade

              Comment

              Working...
              X