Announcement

Collapse
No announcement yet.

Character mesh disappears at certain camera angles

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Character mesh disappears at certain camera angles

    I have no idea if this is the right place for this thread, but it seemed the most logical. I'm very new to Unreal Engine, coming from Unity, and I've got an issue I figure is probably common enough but my googling skills have failed me. I've just created a 3rd person character pawn blueprint and it works, but if the camera is too close to the player mesh, the mesh disappears. What's the best way to keep this from happening?

    #2
    Sounds like that's the camera near clipping setting, though if it's that close maybe you need to make sure the camera isn't too close to the character.

    Comment


      #3
      Where is the near clipping setting? All I can find from google is that its editable in DefaultEngine.ini but that didn't seem to change anything.

      Comment


        #4
        You can edit the near clipping in the general settings inside the projects settings.
        But that doesnt fix the issue. I'm having the same problem. Character disappears around the head area at 90 degrees for me. Looking from bellow or from above doesnt seem to make the mesh disappear.
        Look inside of the animation editor. There're you'll notice that your character isnt having the same clipping errors as in the character blueprint or the editor.
        I guess it has something to do with render volumes. But no idea how to fix it. Might be nice if someone has an answer.

        Comment


          #5
          Sooooo! just fixed it. Look up the solution here! You have to incrase the bounds parameter in the mesh rendering sector.

          https://answers.unrealengine.com/que...appearing.html

          Comment


            #6
            Has anyone found a solution, I'm having the same issue but I think it's to do with the camerboom/spring reaction doesn't match a certain frames for a animation. When I jump, run, or attack there's a few frames where it'll dissappear and none of the solutions mentioned already have fixed it. If I remove the cam from the boom and just make a true 3rd person view and avoid the boom it works fine, but thing is I want 1st person and 3rd option and for that to work you need to have it a child of the spring arm, which causes wierd anomalies.

            Comment


              #7
              PaxiGalaxi Thanks alot !

              Comment


                #8

                how can fix it for alembic format?

                Comment


                  #9
                  Try to increase the bounds scale value. It's in the actor blueprint, where you have to select the actor mesh. If you do that, a "details" tab appears to the right. In that tab just search for "bounds scale" and change the value. If you have multiple meshes (ring, hair, shoes...) attached to the main mesh (character body) than you have to change the value of every "sub-mesh" separately.
                  The smaller a mesh (in relation to the bounds scale of the main object), the higher the bounds scale value has to be for preventing the mesh from disappearing at certain viewing angles.
                  Last edited by Bronislaw666; 12-15-2019, 02:15 PM.

                  Comment


                    #10
                    Scale bounds didn't work for me. What worked was Component Use Fixed Skel Bounds to true, in details panel.

                    Comment


                      #11
                      The second answer "Use Attach Parent Bound" in the link by PaxiGalaxi worked perfectly for my disappearing eyes, eyelashes, and eyebrows. https://answers.unrealengine.com/que...appearing.html

                      Comment

                      Working...
                      X