Announcement

Collapse
No announcement yet.

Is PrimaryAssetLabel broken?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by Wallenstein View Post
    I haven't really used it so I can't help much.
    No worries! Until better documentation comes around the only thing we can do is experiment. To that end, I spent a few days cooking and packaging several different iterations of settings, and the best I can say is "if you click 'Apply recursively', you're going to end up with duplicate assets"

    It's fine I suppose, users have extra space on their drives for that, right? /sarc

    Leave a comment:


  • replied
    I haven't really used it so I can't help much. Maybe try the other methods like Explicit assets and such. I hope I don't run into those problems when I finally get to pack my project. I have to keep the pak files under 2Gb

    Leave a comment:


  • replied
    Originally posted by Wallenstein View Post
    I assume after that it's alot of analyzing the pack file and adjusting priorities and creating more of these assets to fine tune your distribution
    Yeah, that's where I'm stuck. Seems the cooker is really keen on keeping stuff in pak 0. I made a "catch all" asset in the root content directory:

    Click image for larger version

Name:	Annotation-20200203-144919.png
Views:	184
Size:	46.8 KB
ID:	1716765
    Which (to my understanding) should shove anything not already covered by a higher-level PrimaryAssetLabel asset into pak 888, yet nothing ends up there (the file doesn't exist).

    This is just beyond inconceivable. The most basic test epicly fails...

    Leave a comment:


  • replied
    Click image for larger version

Name:	PAL.jpg
Views:	203
Size:	149.1 KB
ID:	1715974

    This is how you actually create the correct one.

    I assume after that it's alot of analyzing the pack file and adjusting priorities and creating more of these assets to fine tune your distribution

    Leave a comment:


  • replied
    Wait, what? OMG! So my muddling in the Primary Asset Types to Scan section is not actually correct then? Such in Unreal I guess.
    To reiterate, you don't create a Blueprint Class of the type PrimaryAssetLabel, but a Data Asset of the subclass PrimaryAssetLabel.

    Sadly, I'm still getting massive duplicate assets (exploding my build from 6.44 Gb to a whopping 11 GB). Le Sigh.

    Leave a comment:


  • replied
    Yes I had some contact with Epic and it turns out when you create a BP with rightclick and then select the PrimaryAssetLabel from the "All Classes" list you get something that does NOT work.
    You have to select the one from Miscellaneous from the long list.
    Another way of making sure you get the right version is to remember that the right version has a RED icon whereas the version with a blue label (normal BP) will not work.
    As for your remark I think you have to jiggle the priority value. When two rules apply to the same asset the one with the higher priority number prevails

    Leave a comment:


  • replied
    So in my experience you apparently need to add the primaryassetlabel files into the Project Settings -> Asset Manager -> Primary Asset Types to Scan or it basically ignores them completely.
    It also seems to ignore the primaryassetlabel's rules settings, so I ended up duplicating the Chunk ID, priority, etc, into that section as well.

    Now that I've done this, the assets do seem to be going into their chunks as expected, but additionally they're being duplicated into other chunks if there is a referenced asset that needs it elsewhere in another chunk! :O

    I wouldn't say it's "broken" per-se, but it is definitely poorly documented and perhaps unfinished...

    Leave a comment:


  • started a topic Is PrimaryAssetLabel broken?

    Is PrimaryAssetLabel broken?

    This is the best forum section I could find for my question.
    I have been trying for hours now to separate my pak file into chunks on disk. I followed all available posts here and did everything I can think of. PrimaryAssetLabel simply does not work. I have to enable the experimental chunk ID feature in the editor settings and assign chunk IDs per hand to each asset, then I get separate chunks.

    I would just love to hear from others. If it is broken then I don't need to waste any more time on this. Does anybody have positive or negative experience with that BP type? Thanks
Working...
X