Announcement

Collapse
No announcement yet.

My project wont open

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    My project wont open

    Hi,

    I cannot figure out why a message pops up saying "The following modules are missing or built with a different engine version."
    I tried rebuilding, but it said to rebuild in visual studio. I rebuilt in visual studio and received an error message saying

    Severity Code Description Project File Line Suppression State
    Error MSB3075 The command ""C:\Program Files\Epic Games\UE_4.20\Engine\Build\BatchFiles\Build.bat" ACDVJeopardyEditor Win64 Development "C:\Users\OMGit\Documents\ACDV Campus Resource Jeopardy\ACDVJeopardy\ACDVJeopardy.uproject" -WaitMutex -FromMsBuild" exited with code 5. Please verify that you have sufficient rights to run this command. ACDVJeopardy C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\VCTargets\Microsoft.MakeFile.Targets 44

    Can someone please help me with this. I don't want to have to restart the project from scratch.

    Thank you,
    Dev Keo

    #2
    It doesn't seem like your talking about editor scripting.

    Or am I wrong?

    The different engine version thing normally happens when you have a game module or plugin built against a different version of the engine to the one your are running.
    i.e. You're using a version of the engine built from github source and are trying to run a plugin downloaded via Epic Launcher.
    Rule#21: Be polite, be professional, but have a plan to kill everyone you meet.

    Comment


      #3
      I am having the same issue and same error. Asking me to attempt to rebuild in Visual Studio code for some reason. Maybe could be due to VScode being the default editor for some things when its expecting VS 2017+?

      Comment


        #4
        I figured it out. Some of my code was wrong and it cause that unusual error. I don't know if you figured it out yet, but try going to output in Visual Studio and seeing if some of your code is wring. I had a few methods called by a widget class whose names didn't match up with the declarations in the game mode base class.

        Comment


          #5
          I meant to say wrong instead of wring

          Comment

          Working...
          X