Announcement

Collapse
No announcement yet.

Editor Utility Widgets Feedback

Collapse
This is a sticky topic.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • replied
    Originally posted by scha View Post


    I did that, but I don't want to put this on the marketplace, because once you fix it this function will be called twice and break things again.
    I just tried out a test case in 4.24 preview and was unable to reproduce it. If you are still seeing it in 4.24 preview (in a copy of your project), can you report a bug using the bug tracker? Thanks!

    Leave a comment:


  • replied
    Another little one: Class Description (the little text which you can set in Class Settings panel of the BP) is not showing up in the content browser. Check the pics below
    Attached Files

    Leave a comment:


  • replied
    Originally posted by Shadow.Storm View Post

    Okay, that does sound like a bug with that node. Could you please report it here: https://epicsupport.force.com/unrealengine/s/ thanks!
    Done! I sent a simple BP Widget. I also found that the bug occurs only if something is already selected before the transaction, if nothing is selected then Ctr-Z works as expected.

    Leave a comment:


  • replied
    Originally posted by scha View Post

    Yes. Check the simplified version of the whole thing:


    Click image for larger version Name:	Annotation-20191104-191041.jpg Views:	0 Size:	180.2 KB ID:	1682439

    And when I use it it will select actors correctly, then on Ctrl-Z it will show the notification"Undo: Select Between", but not undo the selection.

    I use the same schema everywhere and it works everywhere but not with "set selected state"
    Okay, that does sound like a bug with that node. Could you please report it here: https://epicsupport.force.com/unrealengine/s/ thanks!

    Leave a comment:


  • replied
    Originally posted by Shadow.Storm View Post

    Are you also using the BeginTransaction and EndTransaction nodes?
    Yes. Check the simplified version of the whole thing:


    Click image for larger version  Name:	Annotation-20191104-191041.jpg Views:	0 Size:	180.2 KB ID:	1682439

    And when I use it it will select actors correctly, then on Ctrl-Z it will show the notification"Undo: Select Between", but not undo the selection.

    I use the same schema everywhere and it works everywhere but not with "set selected state"
    Last edited by scha; 11-04-2019, 02:15 PM.

    Leave a comment:


  • replied
    Originally posted by scha View Post
    I found another one: it seems that "set actor selection state", from the Editor Scripting Plugin, is not added to the undo transaction properly. When I use it to add actors to the selection inside a transaction, then undo the transaction, the selection doesn't change.

    Or maybe I'm doing something wrong?


    Click image for larger version Name:	Annotation-20191104-154334.jpg Views:	0 Size:	74.3 KB ID:	1682349
    Are you also using the BeginTransaction and EndTransaction nodes?

    Leave a comment:


  • replied
    I found another one: it seems that "set actor selection state", from the Editor Scripting Plugin, is not added to the undo transaction properly. When I use it to add actors to the selection inside a transaction, then undo the transaction, the selection doesn't change.

    Or maybe I'm doing something wrong?


    Click image for larger version  Name:	Annotation-20191104-154334.jpg Views:	0 Size:	74.3 KB ID:	1682349
    Last edited by scha; 11-04-2019, 10:54 AM.

    Leave a comment:


  • replied
    If the "Select Actors Using This Asset" function could be exposed it might be helpful. Someone needs a tool that can select all actors using a certain texture and put them in a folder. Sadly they dont use material instances, so there is no way to check if an actor uses a texture in its material.
    Also I dont know if keyboard input is implemented yet.
    Last edited by Mystice Games; 11-02-2019, 09:28 PM.

    Leave a comment:


  • replied
    EUW are a really amazing tool, but the current documentation isn't really helpful. And there isn't a lot information from other users other than this thread.
    That being said I would really appreciate some help on the player controller issue. I'm trying to select specific mesh that I spawned, not the entire actor. I was hoping to trace from underneath my cursor like I would do from a normal Widget, but I haven't been able to get any kind of player information while in editor.
    I've seen this question being asked a couple of times, but it ended being unanswered.
    Any kind of help would be appreciated

    Leave a comment:


  • replied
    Originally posted by scha View Post


    I did that, but I don't want to put this on the marketplace, because once you fix it this function will be called twice and break things again.
    Currently this isn't scheduled for a 4.23 hotfix, and I'm not confident that a fix would follow hotfix rules, so I believe you can update with this for 4.23. Thanks!

    Leave a comment:


  • replied
    Originally posted by Shadow.Storm View Post

    Still investigating, but I think a workaround for now would be to put a function on your actor that gets called after spawn. Thanks!

    I did that, but I don't want to put this on the marketplace, because once you fix it this function will be called twice and break things again.

    Leave a comment:


  • replied
    Originally posted by scha View Post

    Sorry to bump, but are there any news about this?

    We're receiving negative reviews on the Marketplace because we cannot update out Marketplace product to 4.23 because of this bug.
    Still investigating, but I think a workaround for now would be to put a function on your actor that gets called after spawn. Thanks!

    Leave a comment:


  • replied
    Originally posted by Shadow.Storm View Post

    I agree that this seems like there is an issue here, and we'll look into it on our end. Thanks for letting us know!
    Sorry to bump, but are there any news about this?

    We're receiving negative reviews on the Marketplace because we cannot update out Marketplace product to 4.23 because of this bug.

    Leave a comment:


  • replied
    Hello Guys, I am having problems to pass variables to TileViews when I am creating new child widgets, it seams absolutely broken, does someone is having the same problem?.
    here is a step by step:

    1.- Create a new widget utility
    2.- Set a TileView Widget inside
    3.- Create another widget utility and set the UserObjectListEntry interface
    4.- Set a TextBlock inside the child widget utility
    5.- Create a function to pass a string variable and set the text for the text block (or make a variable public and expose on spawn, not working either)
    6.- go back to the first widget utility and set the child in the TileView settings
    8.- Create a new widget and init that variable

    Adding the widget to any other panel container works, looks like the TileView is generating a copy

    Leave a comment:


  • replied
    I would love to see editor widgets have the ability to work with things during runtime.

    For example, I'd like to build an editor tool that monitors player network data, and displays each player in a server-list type fashion. However I can't pull data from players mid-game.

    I think this is one of the best things to be added to the engine in awhile. It's going to help with tool creation a lot. Thank you!!! Please keep adding to it <3
    Last edited by TSpartanT; 10-24-2019, 07:56 PM.

    Leave a comment:

Working...
X