Announcement

Collapse
No announcement yet.

VR Preview mode not available?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    VR Preview mode not available?

    I am using VIVE with SteamVR, but after launching the editor, VR Preview button is grey, is it disabled, or I am doing something wrong?

    #2
    I've found that SteamVR/VIVE are not included into the project so unless you have a Oculus, you won't be able to run the game from the editor. Also, if you try to run the game in Standalone, it will tell you there is something wrong with the device.

    It's nothing you are doing wrong, just a limitation set by the project. My guess is that because Oculus paid for the project, they made it so no other competing VR can use it, which is a bummer for us VIVE users.

    Comment


      #3
      Originally posted by fengkan View Post
      I am using VIVE with SteamVR, but after launching the editor, VR Preview button is grey, is it disabled, or I am doing something wrong?
      Sorry, the game is meant for touch users only... So unless you have a Oculus and touch also how did you even download this?
      But I digress... you maybe able to mod it to work with steam VR not sure how much extra work tho... first thing is you will have to enable the steam vr plugin and possibly change all of the VR code to steam's code. Replace the cameras and the controller scripts etc.

      Comment


        #4
        Thank you, what a pity.

        Comment


          #5
          Originally posted by fengkan View Post
          I am using VIVE with SteamVR, but after launching the editor, VR Preview button is grey, is it disabled, or I am doing something wrong?

          Check this out. I wasn't able to get the VR preview to work on this either, but I feel this is a step in the right direction.

          Comment


            #6
            Anyone have an update on this by any chance, two years later?

            Seems it comes with some "Odin" plugin which doesn't want to play nice with 4.21 out of the box (says it requires a recompile, which is above my skill level).

            Comment

            Working...
            X