Announcement

Collapse
No announcement yet.

Unresolved compiler error - PB_Functions & PM_Functions? [SOLVED]

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Unresolved compiler error - PB_Functions & PM_Functions? [SOLVED]

    Hello!

    I am new to UE4 modding, and could use some help. I am following this tutorial: https://survivetheark.com/index.php?...tting-started/, and I am at #3, but when I attempt to strict compile, and play, it gives me an error:
    Code:
    One or more blueprints has an unresolved compiler error, are you sure you want to Play in Editor?
       PB_Functions
       PM_Functions
    I hit continue.
    It then plays, but the mod does not run. Nothing happens. I'm not surprised, but I don't know how to fix it. I can't find any help while searching for the error, but I may not know the right lingo to search.

    I have closed the app, then verified the files for the devkit. I reinstall it. I have deleted the tutorial mod, and started over. I am unsure what to try, next?

    Help? XD
    Last edited by OpalMoonstride; 09-15-2019, 07:53 PM. Reason: solved

    #2
    After much beating of my head against a wall, I think I have found my answer.

    Apparently "Strict Compile" does not mean compile in the isolated environment of the mod - there's no separate of workspaces? So, I had downloaded source code for another mod, which is no longer maintained, to learn from it, and placed it in my "Mods" folder. Don't do that. I believe "PM_Functions" and "PB_Functions" are broken references to the other mod I downloaded, despite that I hadn't touched anything in it.

    glhf

    Comment

    Working...
    X