Announcement

Collapse
No announcement yet.

Custom Landscape Terrains Turn Black With Visibility Tool

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    Custom Landscape Terrains Turn Black With Visibility Tool

    I created custom terrain textures for the landscape on the map i'm creating, they paint on and work just fine except when I use the landscape visibility tool to cut holes to make caves the custom terrain textures turn black, i've tried everything to get it to work, the built in, regular textures like the default grass and what not works fine with the visibility tool but even if i cut a whole in the default terrain textures and its right next to the custom ones the custom ones still turn black.

    -Keep in mind that im fairly new/noobish to ark modding so when you guys suggest what to do / try, please point out exactly how to do it or i'm not gonna know what your talking about. Anyway, any help is appreciated

    -Here's a screenshot so you guys can see what im talking about: http://prntscr.com/nx87sc
    Last edited by Tair-Genell123; 06-03-2019, 07:09 PM.

    #2
    Does the area turn black only where you are specifically painting visibility? Like precisely on that spot, or does it turn black around that area?
    You probably either have a issue with a specific material inside your landscape mat or the visibility setup.
    Are you using a modified or custom landscape material? If using a existing material, do you have the hole version also applied to the landscape.

    If you are using a custom material you need a hole version, all you need to do to make a hole version is duplicate your mat, and add a "Landscape Visibility Mask" node to your graph, then connect it to the Opacity Mask input of your final material node.
    Sorry for the later reply. but hopefully this helps.

    Click image for larger version  Name:	Screenshot_25.jpg Views:	1 Size:	71.6 KB ID:	1630285
    Last edited by Nanobot; 06-12-2019, 07:26 AM.
    Download my ARK map "Roraima" now! http://steamcommunity.com/sharedfile.../?id=547828060
    2nd place mapping category winner in the ARK international modding contest!

    Comment


      #3
      Thanks for the response, and no it did not fix the problem, i have ALL that in place, the hole material the visibility mask i checked all that and it didn't fix it.

      Comment

      Working...
      X