Announcement

Collapse
No announcement yet.

I cannot do anything with any BP files without hardlocking.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    I cannot do anything with any BP files without hardlocking.

    Hi there:

    I want to get into messing with ARK modding. Downloaded the ADK from the launcher, install went fine. After opening it, I always AFK to let it discover all assets, until it is done. I can look at skeletal meshes (they are always wearing a hat or on fire for some reason), diffuses, normals, but the second I double-click a BP it hardlocks the UE4 editor. If I select it with a single click and try to copy a BP to a different folder, the second I paste it, it hardlocks the UE4 editor. Also, if I rightclick the play-area and select "play from here," it also hardlocks the UE4 editor.

    I strongly feel this isn't a case of "you need to wait, give it time to do its stuff." I have let it sit for as long as an hour, closer to 1hr15min. There is disk usage the whole time, and CPU usage, but I cannot tab back to the UE4 editor while it is in this hardlock state.

    I'm running a Ryzen 5 1600x with 16gb memory, a Vega56, and regrettably there isn't room on my SSD so I have the ADK on a WD 1tb Black. My system doesn't seem to have issues, but I have no idea what to do. I have uninstalled/reinstalled, verified the install, and restarted the computer multiple times after the steps.

    #2
    same here, when clicking on a blueprint item in the left folder-structure the ADK completly freezes
    but the complete package seems to be out of date, it shows me v288.0 while ARK itself is at v294.x
    When I create a new level with the single groundplane I can let it check lightning, paths, geometry, aso without errors but when I press play there are hundreds of errors shown in the console, missing files and conections, the app grows in RAM endlessly and will not stop until you kill it manually.
    I think the whole ADK is already dead, killed by missing support from developers.

    Comment


      #3
      in main directory of the ADK there is a ARKDevKit.bat
      run this to start ADK
      When u try to open a blueprint the ADK isn't hardlocking, watch all the action in the console window!

      With a plain, empty new level, nothing in it I pressed play, then in console window I see tons of errors, action all the time, after 1.5hours with memory usage of around 20GB (16GB RAM+swapfile) it begins to compile hundrets of missing shaders, using extra processes, which bring full load to my Core i7 for hours, memory usage is increasing constantly, on first attempt whole thing crashed with error, that the swapfile isnt big enough to perform the action
      I increased swapfile to 32GB, now I'm waiting again. PC is on full load, HDD + Prozessor + RAM, dont know what it needs else to compile a complete empty level Maybe I need to buy a Cray supercomputer first...

      Comment


        #4
        That hint to start by the .bat file was golden, thank you MickDundee. I guess it doesn't change what it's doing but in the command window I was able to see it was not locked fully. So I waited for about 3 hours (i7; 16GB Ram; Editor, Data and 32GB Swapfile on SSD) after clicking on "play" (empty level) and saw the edtior is calculating loads of files. After all the wait the game finally started.

        When I went trough this process I could finally start using the editor. Before that step I couldn't open almost any blueprint without freezing the editor window. Now most action work.

        Comment


          #5
          Is there anyone able to check if there is a Ragnarok-folder in Mods folder inside the ADK?
          There is none in my fresh installation and it gives me alot of errors "can't find file" in mods/Ragnarol/...

          Comment


            #6
            I've been asked to try to edit something, so installed again.
            Again started a new completly empty level, put a stair, a player spawn and a point light into it and started it inside the GUI.
            I had to wait 4 whole hours, with a Core i7 under full load, >32GB RAM used (with swap-file), on HDD.
            In the console u can see that it is compiling hundreds of shaders (?) and ogg-files.
            After this is done once u are prepared finally to start to work.

            Then u can load and edit blueprints.

            THX SUPPORT for no support!
            Would be nice if u would write that onto the download-page!

            Comment


              #7
              So... I was watching all the errors in the console window, most of which are 'missing files'. So I did a little exploration, and found that while they are missing from the devkit, they exist within my ark folder... figured why not... and gave it a go...

              Copied all the folders except Mods from the ark Content folder to the unreal projects/shootergame/Content folder

              Copied ragnarok folder from the ark/shootergame/content/mods folder to the unreal projects/shootergame/content/mods folder.

              When prompted to overwrite files in both cases - I told it NO.

              relaunched using the bat file.

              this cut out a lot of the missing project asset errors, but the errors for /Game/ were still there.

              Part of the problem with the devkit is they don't include all the required files for the thing to function properly and not spew out 1k+ errors at you while attempting to load a project, make blueprints etc. If all the files were in their proper place, for the loading im sure the engine would run a lot smoother.

              Comment

              Working...
              X