Announcement

Collapse
No announcement yet.

Error messages and missing files after Cooking map.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Error messages and missing files after Cooking map.

    Hello!
    I've been working on a map of Westeros from the popular book series "A Song of Ice and Fire" and the popular TV Show "Game of Thrones".

    I've been following Exilogs tutorials on youtube and used his tutorial map files that he links in this youtube video; https://www.youtube.com/watch?v=iEZVpYBmSsU
    I've also used the Universal Landscape Material found on this site; https://wiki.arkmodding.net/index.ph...scape_Material

    I made a new folder under Games > Mods called "Westeros", made a 2nd folder inside "Westeros" called "WesterosMaterials" where I placed the materials from the Universal Landscape Material .7z file and set it up by following this tutorial; https://www.youtube.com/watch?v=52LWue2pjdU

    It all works well and I make my terrain and I can paint in my materials
    I then copy the "PrimalGameData_BP_GenericMod" from Game > Mods > GenericMod into my Westeros folder and rename it to "Westeros_PrimalGameData_BP".
    I then open the "Westeros_PrimalGameData_BP", go to File > Reparent Blueprint and reparents it with BASE_PrimalGameData_BP

    I then link ALL the levels (BossArena_01, BossArena_Dragon, BossArena_Gorilla, LandscapeSublevel, Mainmap, PersistentGameplaySublevel, WorldEnd) with "Westeros_PrimalGameData_BP" by going into the World Settings and add the "Westeros_PrimalGameData_BP" in Primal Game Data Override on every level.

    Click image for larger version

Name:	a7o5YsolRneMXBIkI1ETiQ.png
Views:	1
Size:	48.9 KB
ID:	1225649

    I save everything and go to Steam Upload to Cook Map, I fill in all the information and press "Cook Map"
    Click image for larger version

Name:	wEXC81OmTPudlZLJ_UxlQw.png
Views:	1
Size:	122.0 KB
ID:	1225652

    It takes 1 or two hours to cook and when it's done I go to Program Files\Epic Games\ARKDevKit\ModTools\Output\Westeros and I see that I'm missing the preview image that I added before cooking and some other files.
    Click image for larger version

Name:	SXm3oGtaQJudlOV3rDb3bw.png
Views:	1
Size:	4.8 KB
ID:	1225648
    Click image for larger version

Name:	AUYkOx0yTG2PjQIcTbqt-A.png
Views:	1
Size:	39.1 KB
ID:	1225650
    Click image for larger version

Name:	yrVTWJj8QBGXhmUE7NDK5Q.png
Views:	1
Size:	17.8 KB
ID:	1225651
    Looks the same in the LinuxNoEditor folder.

    I also get "Failure - 14 error(s), 2472 warning(s)" when it's done cooking but I have no idea on how to get the log file and post it on here, but I found two of the errors:
    "LogBlueprint:Error: [compiler] Error Variable node Set bBoostIconHidden uses an invalid target. It may depend on a node that is not connected to the execution chain, and got purged."
    "LogBlueprint:Error: [compiler] Error Failed to find class for pin Element Bar"

    I also made a CookingTest map doing the exact same things but didn't use Exilogs map files, instead I made my own levels and linked them together using World Composition. This gave the exact same problem.

    What am I doing wrong?

    #2
    [SOLVED]

    I verified the files and now I don't get any errors. Uploading to the workshop seems to work fine now!

    Comment

    Working...
    X