Announcement

Collapse
No announcement yet.

How to get animations to work for a custom dino?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

    How to get animations to work for a custom dino?

    I've been working with the ARK Dev Kit for about three months and reading/watching tutorials online to answer a lot of the questions I've had along the way, but I've had some trouble finding a tutorial on how to get skeletons/animations to work for a custom dino. The dino I'm working with is basically a smaller model of the Allosaurus, shrunk down to about Raptor size. I can get saddles and eggs working correctly and I can adjust the various other parameters in the BP and those work fine. I can also edit the copied Allosaurus skeletal mesh to scale to different sizes and that works fine as long as I use the Allosaurus skeleton as a base. The animations all play fine when I keep it set to the base Allosaurus skeleton and link to the Allosaurus animation montages in the BP for my custom dino. The problem I'm having is that I want to change a few things that require me to alter the skeleton and I can't get the animations to work properly after I switch the skeleton in the skeletal mesh for my custom dino to a duplicate of the original Allosaurus skeleton, with or without editing any of the settings of the new copied skeleton.

    To give you an idea of where I might be getting things wrong, I'll post the link to another post on the forums that I was using as a reference. I was following the instructions listed on this tutorial:
    https://forums.unrealengine.com/show...Dino-Resizing!. I followed it step by step and when I finish with step 2.3, the preview in the animation blueprint is no longer disfigured and works properly, so copying and retargeting appears to be working. However, when I then open the BP for my custom dino and click on Components to preview my dino, the animations are broken and the dino isn't moving anymore, so I know something is going wrong at that point.. When I bring it onto the test map and hit play, none of the animations work, as one would expect (the dino can "move" around and attack, but it's frozen in the default skeleton pose the entire time rather than actually moving its limbs). I tried Google for information on editing custom dinos, but the tutorial above is the closest I could find to explaining the exact changes I'm trying to make. The post is from 2015, so I don't know if the information is still correct or if they've made changes in how skeletons or animations are referenced since then.

    There are two things I'm trying to do. The first is make a copy of the Allosaurus skeleton and re-position the RiderSocket on the back so that the rider sits at the right height (using the default Allosaurus skeleton, the rider sits too high above the saddle on my custom resized dino). The second is to change the walking animation so that there is no longer a ground/camera shake on my custom dino when it walks, because it looks ridiculous when the ground shakes from a dino the size of a Raptor. I can basically get 98% of the changes I want working on my custom dino, those are the two things I can't seem to get to work right.

    #2
    Try this video -

    https://youtu.be/YdRm_eOdxrU


    My Mods | P0k3r's Workshop

    Comment


      #3
      Many thanks for the link, this video got everything working for me!

      Comment


        #4
        --------------
        Click image for larger version

Name:	004a044e1927a979dbf090ba65323894381708169d8592afbb7b70100f3e244a.jpg
Views:	1
Size:	43.8 KB
ID:	1130454


        My Mods | P0k3r's Workshop

        Comment

        Working...
        X