Announcement

Collapse
No announcement yet.

HELP! Custom Sword - Almost done, but doesn't equip or show in player's hands.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HELP! Custom Sword - Almost done, but doesn't equip or show in player's hands.

    Hi guys -

    I think I'm nearly done with my first Ark mod, and I'm pretty freakin' jacked up about actually making something of my own. I'm 35 and I've been teaching myself this **** for fun, and it's nuts to have these kinds of tools to play with. Anyway ... I've hit a roadblock.

    Things that are working:
    TPV and FPV meshes are weight painted correctly import and animate perfectly - based off PrimalItem_WeaponStoneHatchet
    Custom Engram - shows up in the Engram list, and crafts correctly
    Sword appears in Inventory, w/correct stats, icon and text, can be slotted into hotbar.

    Until recently, upon trying to equip the sword, the editor would crash. I realized that I used the wrong weapon blueprint, fixed that, and now no crashes anymore. But also no sword.
    Pressing the hotbar key causes the hotbar slot to flash, and nothing else happens.

    Here's the mod folder:
    Click image for larger version

Name:	cb79aea1d8.png
Views:	1
Size:	76.2 KB
ID:	1199626

    Blueprint:
    Click image for larger version

Name:	a78a4aaf02.png
Views:	1
Size:	267.5 KB
ID:	1199627

    Engram:
    Click image for larger version

Name:	31e10a8698.png
Views:	1
Size:	314.1 KB
ID:	1199628

    In the new Weapon Blueprint, WeapStoneHatchet_ECTC_Katana, it references the original PrimalItem core blueprint -- could this be the problem, and if so, where the hell do I change that link to my custom one!?
    Click image for larger version

Name:	bcc7bdefa8.png
Views:	1
Size:	127.2 KB
ID:	1199629

    I've re-looked at everything so much I'm basically blind to it. I'd really love to get this working.

    Thanks!

    #2
    You've got the wrong primalitem linked in pics 2 and 4. It is "PrimalItem_WeaponStoneHatchet" when it should be "PrimalItem_WeaponStoneHatchet_ECTS_Katana"
    It goes like this: The primal game data holds the reference to the engram, the engram has the reference to the primal item, the primal item references the weapon BP, the weapon BP references everything else like mesh, animations, etc.
    The way it looks now is that if you spawned a stone hatchet it would be your sword.


    My Mods | P0k3r's Workshop

    Comment


      #3
      Originally posted by P0k3r View Post
      You've got the wrong primalitem linked in pics 2 and 4. It is "PrimalItem_WeaponStoneHatchet" when it should be "PrimalItem_WeaponStoneHatchet_ECTS_Katana"
      It goes like this: The primal game data holds the reference to the engram, the engram has the reference to the primal item, the primal item references the weapon BP, the weapon BP references everything else like mesh, animations, etc.
      The way it looks now is that if you spawned a stone hatchet it would be your sword.
      Oh man, thank you so much for responding!

      Could I bother you for the easiest way to fix it?

      I'm really really new to Unreal and trying not to get overwhelmed; and half the time I'm stabbing blindly in the dark.

      Comment


        #4
        It looks like you have two broken chains....

        1 -> 2 -> 3
        2-> 3 -> 4

        Instead of

        1 -> 2 -> 3 -> 4

        Your files should be

        PrimalGameData -> EngramKatana -> PrimalItemWeapon_Katana -> ECTC_Katana

        Look at pictures 2 & 3. Notice how the link breaks. Open up Weapon_Katana and point the weapon reference to ECTC_Katana, it should be that easy
        I will finish this mod.

        Alchemy (A Full Blown Skill)

        Comment


          #5
          Thanks very much for getting back to me.
          I see what you mean, I think.

          When you said, "Open up Weapon_Katana and point the weapon reference to ECTC_Katana, it should be that easy"
          I should open the weapon blueprint, WeapStoneHatchet_ECTC_Katana, right?

          Where do I change that reference?? I can see that it's wrong in the reference viewer, but don't know where in the blueprint to change that association.
          It's probably something stupid easy, I just don't know what I'm looking for.

          Again, many thanks for helping out a noob.

          Comment


            #6
            Your engram is referencing the right file, your primalitem is not.
            Open primalitemweapon_katana & find "weapon Template". Set it to your sword. Pretty sure that's all you would need to do at this point.

            Also,
            Originally posted by Bettista View Post
            and half the time I'm stabbing blindly in the dark.
            Get used to it
            Last edited by P0k3r; 11-01-2016, 01:01 PM.


            My Mods | P0k3r's Workshop

            Comment


              #7
              Originally posted by P0k3r View Post
              Your engram is referencing the right file, your primalitem is not.
              Open primalitemweapon_katana & find "weapon Template". Set it to your sword. Pretty sure that's all you would need to do at this point.
              Dude, gonna try this as soon as I get home today --- thank you very, very much!!

              Also, Get used to it
              Hehe, duly noted. Thanks again

              Comment


                #8
                Ok, found it, changed it -- thanks!

                But of course I have a brand new error.

                Ensure condition failed: NewObject->IsA(this->GeneratedClass) [File:C:\SVN_Ark\Engine\Source\Runtime\Engine\Private\Blueprint.cpp] [Line: 585]
                Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000040 VERSION: 247.83 UE4Editor-Engine

                Yarg.

                Comment


                  #9
                  If that is when you equip it, make sure the weaponbp is pointing to the correct animbp


                  My Mods | P0k3r's Workshop

                  Comment


                    #10
                    P0k3r - it is when I equip it -- will check tonight on it's animation links.

                    THANK YOU SO MUCH!

                    Comment


                      #11
                      This is what it's set up as -- seems OK to me, but I'm not positive what it's supposed to be.

                      Click image for larger version

Name:	fb6dff6523.png
Views:	1
Size:	81.2 KB
ID:	1117849
                      Click image for larger version

Name:	ebedc33d32.png
Views:	1
Size:	36.3 KB
ID:	1117850

                      How's that look to your eyes, Mr. P0k3r, sir?
                      Last edited by Bettista; 11-02-2016, 11:10 PM.

                      Comment


                        #12
                        You're missing the FPV animbp
                        Click image for larger version

Name:	64cfaabb18034fa05f44ff4cee3a3da3.png
Views:	1
Size:	45.8 KB
ID:	1117851


                        My Mods | P0k3r's Workshop

                        Comment


                          #13
                          ... Yeah I guess that'll do it. Do I need to change anything for TPV?

                          And again, holy freakin' thanks man. I owe you a beer or six.

                          Comment


                            #14
                            P0k3r my friend, it's still crashing, even after using the new animation bp. If the base item is the hatchet, I'm not required to use the hatchet animations, right? The sword animations looked fine in the previewer... but I'll use the hatchet ones if I have to.


                            Fatal error!

                            Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0x00000040

                            VERSION: 248.3
                            UE4Editor-Engine.dll!UnknownFunction (0x000007fed0731605) + 0 bytes [UnknownFile:0]
                            UE4Editor-Engine.dll!UnknownFunction (0x000007fed0731579) + 0 bytes [UnknownFile:0]
                            UE4Editor-ShooterGame.dll!AShooterWeapon::PlayWeaponAnimation() (0x000007fec7ecff28) + 0 bytes [g:\svn_ark\projects\shootergame\source\shootergame\private\shooterweapon.cpp:1719]
                            UE4Editor-ShooterGame.dll!AShooterWeapon::OnEquip() (0x000007fec7ecf64f) + 0 bytes [g:\svn_ark\projects\shootergame\source\shootergame\private\shooterweapon.cpp:482]
                            UE4Editor-ShooterGame.dll!AShooterCharacter::SetCurrentWeapon() (0x000007fec7d9b5a2) + 0 bytes [g:\svn_ark\projects\shootergame\source\shootergame\private\shootercharacter.cpp:1906]
                            UE4Editor-ShooterGame.dll!AShooterCharacter::GivePrimalItemWeapon() (0x000007fec7d8e6cd) + 14 bytes [g:\svn_ark\projects\shootergame\source\shootergame\private\shootercharacter.cpp:1533]
                            UE4Editor-Engine.dll!UnknownFunction (0x000007fed0524cac) + 0 bytes [UnknownFile:0]
                            UE4Editor-Engine.dll!UnknownFunction (0x000007fed056fa05) + 0 bytes [UnknownFile:0]
                            UE4Editor-Engine.dll!UnknownFunction (0x000007fed014bb27) + 0 bytes [UnknownFile:0]
                            UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fece9d1374) + 0 bytes [UnknownFile:0]
                            UE4Editor-UnrealEd.dll!UnknownFunction (0x000007fecee460b6) + 0 bytes [UnknownFile:0]
                            UE4Editor.exe!UnknownFunction (0x000000013fbaa4b4) + 0 bytes [UnknownFile:0]
                            UE4Editor.exe!UnknownFunction (0x000000013fb9f66f) + 0 bytes [UnknownFile:0]
                            UE4Editor.exe!UnknownFunction (0x000000013fb9f6da) + 0 bytes [UnknownFile:0]
                            UE4Editor.exe!UnknownFunction (0x000000013fbabb40) + 0 bytes [UnknownFile:0]
                            UE4Editor.exe!UnknownFunction (0x000000013fbaca89) + 0 bytes [UnknownFile:0]
                            kernel32.dll!UnknownFunction (0x0000000076c259cd) + 0 bytes [UnknownFile:0]
                            ntdll.dll!UnknownFunction (0x0000000076e5b981) + 0 bytes [UnknownFile:0]
                            ntdll.dll!UnknownFunction (0x0000000076e5b981) + 0 bytes [UnknownFile:0]
                            Last edited by Bettista; 11-03-2016, 12:01 AM.

                            Comment


                              #15
                              P0k3r -- IT WORKS!!!!

                              Couldn't have done it without out you! Seriously, I'll beer you over the internet somehow.

                              I changed the animation bp to this, and we're GOLDEN.


                              Holy sweet **** this is amazing.

                              Comment

                              Working...
                              X