Announcement

Collapse
No announcement yet.

Event BPContainer_Activated not being fired

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Event BPContainer_Activated not being fired

    I am triyng to know when a structure is activated.
    The structure is electric and is autoactivated when powered.

    But the events BPContainer_Activated (or BPContainer_Deactivated) are not being fired.

    Can someone help me with this?

    Thank you.

    PS: I have another secondary doubt, there is any way to know when an structure is placed? I tried to use "begin play" but it is only fired once on the whole game (first time you are going to place or if it is placed, when the server starts).
    Last edited by Cucharón; 07-28-2016, 11:22 AM.

    #2
    Hey, did you check "Use BPActivated" in the default settings?



    You can use event begin play for when a structure is placed. Begin play fires when the structure is put in placement mode but you can filter this case by checking the "is preview structure" bool. It will fire again when the structure is placed and also on server restarts. It will also fire for clients as soon as they get into replication range.
    ARKModding.net Wiki --- ARKModding.net: Resource Collection, BP Snippets --- ADK Tutorial/Example Blueprint Collection on github --- Tutorial: Adding custom MultiUse(Radial) menu entry/action --- My Steam Workshop

    Comment


      #3
      Originally posted by Mezzow View Post
      Hey, did you check "Use BPActivated" in the default settings?



      You can use event begin play for when a structure is placed. Begin play fires when the structure is put in placement mode but you can filter this case by checking the "is preview structure" bool. It will fire again when the structure is placed and also on server restarts. It will also fire for clients as soon as they get into replication range.
      Yeah was that! I feel a bit idiot for forget to activate that. Thank you!

      PS: Thank you again for the Begin event, it is perfect :-)

      Comment

      Working...
      X